Jump to content
CCleaner Community Forums

v5.10.5373 slow to launch


nukecad
 Share

Recommended Posts

  • Moderators

The latest CC free version, v5.10.5373 (64-bit) is verrrry slowwww to launch.

Doesn't matter if I double click the icon, or right click and select run.

Both are taking 10 to 15 seconds before the CCleaner window opens.

This only happens the first time I open CC in a session, If i've opened it (slowly) once, close it, then open again, it comes up as normal (in about 1/4 second).

 

Windows 10 64-bit.
Intel Celeron CPU N2840 @ 2.16GHz, 4.0GB RAM, Intel HD Graphics.

*** Out of Beer Error ->->-> Recovering Memory ***

Worried about 'Tracking Files'? Worried about why some files come back after cleaning? See this link:
https://community.ccleaner.com/topic/52668-tracking-files/?tab=comments#comment-300043

 

Link to comment
Share on other sites

  • Moderators

is monitoring turned on?

Backup now & backup often.
It's your digital life - protect it with a backup.
Three things are certain; Birth, Death and loss of data. You control the last.

Link to comment
Share on other sites

  • Moderators

Are you using SKIPUAC setting in ccleaner? If so turn that off and see if it still does it.

 

ADVICE FOR USING CCleaner'S REGISTRY INTEGRITY SECTION

DON'T JUST CLEAN EVERYTHING THAT'S CHECKED OFF.

Do your Registry Cleaning in small bits (at the very least Check-mark by Check-mark)

ALWAYS BACKUP THE ENTRY, YOU NEVER KNOW WHAT YOU'LL BREAK IF YOU DON'T.

CCLEANER, RECUVA, DEFRAGGLER AND SPECCY DOCUMENTATION CAN BE FOUND AT  https://support.piriform.com/hc/en-us and  https://www.ccleaner.com/docs

Pro users file a PRIORITY SUPPORT request at https://support.piriform.com/hc/en-us/requests/new

link to WINAPP2.INI explanation

Link to comment
Share on other sites

  • Moderators

Some more info may help:

* What version of Windows are you using?

* What antivirus and anti-malware are you using?

Already posted in OP - Win10 64-bit.

AV is Windows Defender, plus weekly scans with Defender, SAS, and MBAM

 

CC activie monitoring is off.

 

SKIPUAC was on, will turn it off and see what happens. (Will need a reboot to replicate the problem).

 

As I say I have made no changes other than updating to v5.10.5373 last Friday.

 

To repeat this only happens the first time I run CC in a session, after that it opens quickly as normal.

*** Out of Beer Error ->->-> Recovering Memory ***

Worried about 'Tracking Files'? Worried about why some files come back after cleaning? See this link:
https://community.ccleaner.com/topic/52668-tracking-files/?tab=comments#comment-300043

 

Link to comment
Share on other sites

  • Moderators

Mmmm,

 

Turning off SKIPUAC resulted in the Windows pop up asking for permission to let CC make changes to the computer.

 

CC did launch quickly when confirmed though.

 

Turning SKIPUAC back on brings the slow launch problem back.

 

Looks like the account check is causing the problem then.

Not sure why it should suddenly start happening with this version update, but who knows what the coders have changed.

 

Oh, well.

I suppose I'll either change the user account control settings in windows, roll back to the previous CC version, or just put up with the initial launch delay until the next CC update and hope that fixes it.

 

Thanks for the help.

*** Out of Beer Error ->->-> Recovering Memory ***

Worried about 'Tracking Files'? Worried about why some files come back after cleaning? See this link:
https://community.ccleaner.com/topic/52668-tracking-files/?tab=comments#comment-300043

 

Link to comment
Share on other sites

  • Moderators

Something in task scheduler seems to be causing the bottle neck then if it launched right with skipuac

Can you maybe post the xml of your skipuac task

 

ADVICE FOR USING CCleaner'S REGISTRY INTEGRITY SECTION

DON'T JUST CLEAN EVERYTHING THAT'S CHECKED OFF.

Do your Registry Cleaning in small bits (at the very least Check-mark by Check-mark)

ALWAYS BACKUP THE ENTRY, YOU NEVER KNOW WHAT YOU'LL BREAK IF YOU DON'T.

CCLEANER, RECUVA, DEFRAGGLER AND SPECCY DOCUMENTATION CAN BE FOUND AT  https://support.piriform.com/hc/en-us and  https://www.ccleaner.com/docs

Pro users file a PRIORITY SUPPORT request at https://support.piriform.com/hc/en-us/requests/new

link to WINAPP2.INI explanation

Link to comment
Share on other sites

  • Moderators

Yes, I was just looking into that after reading that SKIPUAC used the scheduler.

 

The action is "C:\Programme Files\CCleaner\CCleaner.exe" $(Arg0)

 

I'm not sure what that argument should be?

Or whether that should be pointing to CCleaner64.exe?

 

EDIT

Think I'll try changing it to point at -64.exe and see if that does the trick.

(Trouble is that to replicate the problem I have to do a reboot as it only happens the first time).

*** Out of Beer Error ->->-> Recovering Memory ***

Worried about 'Tracking Files'? Worried about why some files come back after cleaning? See this link:
https://community.ccleaner.com/topic/52668-tracking-files/?tab=comments#comment-300043

 

Link to comment
Share on other sites

  • Moderators

It'll go faster if you point at 64 but not needed, the argument is correct. More what I was looking for was act as operating system and if run with highest privileges is checked

 

ADVICE FOR USING CCleaner'S REGISTRY INTEGRITY SECTION

DON'T JUST CLEAN EVERYTHING THAT'S CHECKED OFF.

Do your Registry Cleaning in small bits (at the very least Check-mark by Check-mark)

ALWAYS BACKUP THE ENTRY, YOU NEVER KNOW WHAT YOU'LL BREAK IF YOU DON'T.

CCLEANER, RECUVA, DEFRAGGLER AND SPECCY DOCUMENTATION CAN BE FOUND AT  https://support.piriform.com/hc/en-us and  https://www.ccleaner.com/docs

Pro users file a PRIORITY SUPPORT request at https://support.piriform.com/hc/en-us/requests/new

link to WINAPP2.INI explanation

Link to comment
Share on other sites

  • Moderators

Well it was a bit of a waste of time.

 

Changing it to point to CCleaner64.exe just resulted in the permissions pop-up and a slow launch, with the SKIPUAC becoming unticked.

When I ticked it again it changed the scheduled task back to CCleaner.exe

I'm not sure why its doing this as it is CCleaner64.exe that is running. (I checked it in the resource monitor).

Oh well, we live and learn.

 

Scheduler selections are:

Run only when user is logged on.

Run with highest priviledges.

Configured for : Windows 10

 

No triggers defined

 

Actions defined as in my previous post

 

No conditions selected

 

Settings selected are:

Allow task to be run on demand.

Stop the task if it runs longer than - 3 days.

If the running task does not end when requested, force it to stop.

Run a new instance in parallel.

 

 

PS. Not sure where in the world you are but have you been out to take a look at the lunar eclipse?, It's in full eclipse right now.

*** Out of Beer Error ->->-> Recovering Memory ***

Worried about 'Tracking Files'? Worried about why some files come back after cleaning? See this link:
https://community.ccleaner.com/topic/52668-tracking-files/?tab=comments#comment-300043

 

Link to comment
Share on other sites

  • Moderators

A bit of an update.

 

I tried uninstalling 5.10 and rolling back to 5.09 - no noticable change.

 

Uninstalled 5.09 and rolled back to 5.08 - problem gone.

 

Downloaded a new ccsetup510.exe and updated from 5.08 to 5.10 - problem back again.

 

As the problem dissappeared with 5.08 but came back with 5.10 it indicates to me that something has been changed in CCleaner itself that is causing this.

 

Is nobody else seeing the same issue with a slow initial launch in v5.10?

I can live with it but it would be nice if it wasn't happening.

*** Out of Beer Error ->->-> Recovering Memory ***

Worried about 'Tracking Files'? Worried about why some files come back after cleaning? See this link:
https://community.ccleaner.com/topic/52668-tracking-files/?tab=comments#comment-300043

 

Link to comment
Share on other sites

  • Moderators

A few more questions to throw out there.

 

What is your default browser?

 

Do you have automatically check for updates ticked in Ccleaner settings?

 

Do you have Ccleaner configured to either autorun at startup or autorun at shutdown?

CCleaner documentation can be found here

https://www.ccleaner.com/docs/ccleaner

Support contact

https://support.piriform.com/hc/en-us/requests/new

support@ccleaner.com

 

Link to comment
Share on other sites

  • Moderators

Is nobody else seeing the same issue with a slow initial launch in v5.10?

 

I have v5.10, monitoring OFF, auto updates OFF, portable version.

Starts in under 1sec (but I also have a SSD)

Backup now & backup often.
It's your digital life - protect it with a backup.
Three things are certain; Birth, Death and loss of data. You control the last.

Link to comment
Share on other sites

  • Moderators

Hi Hazelnut,

 

Defualt browser is Firefox v40.0.3 (Although I've just seen v41.0 is ready so will probably be putting that on later).

 

Automatic check for updates is ON.

 

No autoruns set. I run it from the desktop just before I shut down, (or just when I feel like it).

 

As I said this morning, it seems to me that if 5.08 does not have the problem on my setup but 5.09 & 5.10 do, then it is the updates to CC itself and not the setup.

 

As I say I can live with it, will probably just turn off the SKIPUAC for now.

*** Out of Beer Error ->->-> Recovering Memory ***

Worried about 'Tracking Files'? Worried about why some files come back after cleaning? See this link:
https://community.ccleaner.com/topic/52668-tracking-files/?tab=comments#comment-300043

 

Link to comment
Share on other sites

  • Moderators

Nope, turning off the automatic updates made no difference.

 

(Just for info, turned off the AU's, rebooted, watched task manager until everthing else had made its checks had calmed down, launched CC).

 

Still takes about 15 seconds for the initial launch of CC, close it again and subsequent launches happen almost instantly.

 

I think we sorted out with Nergal that it is the SKIPAUC setting that is causing this strange behaviour with 5.09 & 5.10 (Free version).

Turn that off and it doesn't happen. (But of course then you get the Windows confirmation pop-up).

 

As I keep saying it's not a great problem, just some strange behaviour that didn't used to happen with previous versions.

*** Out of Beer Error ->->-> Recovering Memory ***

Worried about 'Tracking Files'? Worried about why some files come back after cleaning? See this link:
https://community.ccleaner.com/topic/52668-tracking-files/?tab=comments#comment-300043

 

Link to comment
Share on other sites

  • Moderators

I forgot to say, you need to also change any of your shortcuts to point to ccleaner 64 for the target change in task scheduler to work.

 

Basically the task tells windows to run the task instead if the target is attempted to run, so that's why you had the results you did when you tried it (the uac popup)

 

ADVICE FOR USING CCleaner'S REGISTRY INTEGRITY SECTION

DON'T JUST CLEAN EVERYTHING THAT'S CHECKED OFF.

Do your Registry Cleaning in small bits (at the very least Check-mark by Check-mark)

ALWAYS BACKUP THE ENTRY, YOU NEVER KNOW WHAT YOU'LL BREAK IF YOU DON'T.

CCLEANER, RECUVA, DEFRAGGLER AND SPECCY DOCUMENTATION CAN BE FOUND AT  https://support.piriform.com/hc/en-us and  https://www.ccleaner.com/docs

Pro users file a PRIORITY SUPPORT request at https://support.piriform.com/hc/en-us/requests/new

link to WINAPP2.INI explanation

Link to comment
Share on other sites

  • Moderators

The shortcuts (desktop, start menu, and metro tile) do, and always have, pointed to CCleaner64.exe, it just seems to be the scheduler that doesn't.

I probably would never even have noticed this if I wasn't looking round because of the delayed start thing.

 

Anyway what I have done to stop this delayed launch bothering me is to set CC to run on startup.

(A bit superflous as I usually run it right before I shutdown).

 

That way the initial launch runs as a background task when I boot, so I don't see the delay.

This means that when I do later come to run CC from the desktop it launches immediately as normal.

 

This doesn't cure the delayed initial launch thing, just means that I don't see it.

I've watched it with task manager and it still takes about 15 seconds to launch, enough time for me to open the task manager and sit waiting for CC to launch as a background process.

 

This may also explain why others are not seeing this delay, if they also have run-on-startup set then the delayed first launch is happening in the background.

 

Thanks all again for your inputs.

*** Out of Beer Error ->->-> Recovering Memory ***

Worried about 'Tracking Files'? Worried about why some files come back after cleaning? See this link:
https://community.ccleaner.com/topic/52668-tracking-files/?tab=comments#comment-300043

 

Link to comment
Share on other sites

Problem here too with win 7 laptop and win 10 desktop.  After reaading the posts here, this is what I did.  I deleted/unpinned all shortcuts to ccleaner.  I then made a new shortcut on the desktop pointing to ccleaner 64.  I pinned it to the start up and taskbar.  They all worked, launching normally.  I did a restart (not a cold boot) and they still worked.

 

This is probably unrelated but, I have avast and one of the options in the troubleshooting is to have avast load AFTER all other services, in other words, no boot scan on start up.

I did a fresh (cold) boot this morning and everything still works.  Ccleaner launched normally.

 

So, I can't really say what fixed it, but I suspect it was the shortcut .  So far so good.

 

Off topic, but still looking for a good free AV.  They are all so bloated now.

 

Odd that everything worked perfectly before version 5.10

Link to comment
Share on other sites

  • Moderators

Good to have confirmation that it wasn't just me seeing this.

 

The workaround that I gave in post #18 is doing the job for now so I am not looking for any other solution.

I would advise anyone with the issue to do the same and set CC to automaticaly launch at startup.

 


Off topic, but still looking for a good free AV.  They are all so bloated now.

 

With your Windows 10 you can just use Windows Defender. Theres no need for a third party AV.

 

Defender has been a full AV since Windows 8 when Defender and Microsoft Security Essentials were merged into the one programme.

It runs in the background, takes up very few resources, and the definitions get updated daily in the background.

 

With Windows 7 (and earlier) Windows Defender was not a full AV, it was only Anti Spyware, so you need a separate AV.

 

 

Most guys I know are using Windows Defender to monitor, and then once a week run scans with Windows Defender, Super AntiSpyware, & Malwarebytes.

Thats what I have been doing since Win8.1 and have never had more than a couple of PUPs show up.

(Advice- run CC before running SAS, otherwise SAS wastes time finding and quarantining all the cookies).

*** Out of Beer Error ->->-> Recovering Memory ***

Worried about 'Tracking Files'? Worried about why some files come back after cleaning? See this link:
https://community.ccleaner.com/topic/52668-tracking-files/?tab=comments#comment-300043

 

Link to comment
Share on other sites

I too am using Windows 10 64-bit just like nukecad, with Pentium N3540 @ 2.16GHz, 8GB RAM, Intel HD Graphics and AV is also Windows Defender, plus weekly scans with Defender, SAS, and MBAM as well. With CC active monitoring off, SKIPUAC on, I have the exact same problem upon 1st use. After reading this thread I left SKIPUAC on and set the program to run on startup and the issue is resolved temporarily. I would like to see the program run as it always has (since I started using it in 2007) but, of course, it's not a major issue, just an annoyance. Thanks for all of your help.

"...Did you exchange a walk on part in the war for a lead role in a cage?"

 

Link to comment
Share on other sites

  • Moderators

Again good to see that I was not the only one having this issue.

 

Thanks for the input.

*** Out of Beer Error ->->-> Recovering Memory ***

Worried about 'Tracking Files'? Worried about why some files come back after cleaning? See this link:
https://community.ccleaner.com/topic/52668-tracking-files/?tab=comments#comment-300043

 

Link to comment
Share on other sites

  • Moderators

Mmm, just had this slow launch again, even though I had been logged on  for over 2 hours.

(Maybe the launch at startup hit a snag?)

EDIT- It's because I launched a browser whilst CC was in the initial delay period; see post #30 below.

 

Anyway just in case one of the Piriform coders is following this, here is what I'm seeing at boot with the launch-at-startup selected-

Boot the laptop and open task manager.
CCleaner is shown as a background process, and has reserved 1.8 MB RAM but is not active.
After 10-15 seconds CCleaner then starts using the CPU and accessing the HD.

*** Out of Beer Error ->->-> Recovering Memory ***

Worried about 'Tracking Files'? Worried about why some files come back after cleaning? See this link:
https://community.ccleaner.com/topic/52668-tracking-files/?tab=comments#comment-300043

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...