Jump to content
CCleaner Community Forums

Recommended Posts

Build 5.64.7613 downloaded from the official download website.  On installation, the new 5.64.7613 hangs solid and has to be manually "End Task".  This is on Windows 10x64 Professional, build 18363.693 V1909.  Had to revert back to 5.63.  MS Edge Chromium is my default browser.  

The system Event Viewer reports and Application Hang

The program CCleaner64.exe version 5.64.0.7613 stopped interacting with Windows and was closed. To see if more information about the problem is available, check the problem history in the Security and Maintenance control panel.
 Process ID: c0c
 Start Time: 01d5f179a1aa126e
 Termination Time: 4294967295
 Application Path: C:\Program Files\CCleaner\CCleaner64.exe
 Report Id: 47304467-360f-49b9-ba83-b0aa97a22437
 Faulting package full name: 
 Faulting package-relative application ID: 
 Hang type: Top level window is idle

NOTE: I installed the 5.64 version on a second system with the same HANG results.

Edited by siliconman01
Note: Second System 5.64 hangs also.
Link to post
Share on other sites

Same problem,

Windoze 10 task manager: "This UWP process is suspended to improve system performance"

No previous version to revert back to, please could you include it in https://www.ccleaner.com/ccleaner/builds

Link to post
Share on other sites

Thanks Siliconman01...that exactly what I has to do to clear it from task manager...I'm using Firefox...Win10..
I even shut down Malwarebytes but still the same...so I will leave it alone till the problem is resolved I guess

Link to post
Share on other sites

New update (Version 5.64.7613) broken here. Downloaded and installed fine. But when I open the program I cannot click anywhere within the application, or close it. I have to end task via Task Manager to close it. Even re-downloaded from the link above (Not filehippo, as that site is full of crap and will NEVER go near it again!).

Yet another well tested version has been sent out in the wild...

Link to post
Share on other sites
  • Moderators
9 minutes ago, zoa said:

Will the professional licence will still be picked up when reverting?

 

Open CCleaner, select 'About' from left hand side and the select Upgrade to Pro at the top of the page.. just enter your key there   

Link to post
Share on other sites

I found what was causing V5.64 to hang/freeze on installation on all my systems.  It is the "Block Unwanted Apps" setting in MS Edge Chromium itself.  This setting has to be set to OFF prior to installing V5.64.  I am not using the Health Scan feature and am using the custom scan feature.  

MSEdgeUnwantedApps.thumb.png.d27072bf2515cbae7e8eab52ee521864.png

Link to post
Share on other sites
  • Moderators

Cheers, reported to the staff.

(They are online at the moment and would have seen it anyway, but a flag always makes sure).

Link to post
Share on other sites

Same problem here on Windows 10 x64 Pro 1909 - installed 5.64 update, and when I run it, the CCleaner window is completely frozen and doesn't respond to anything. Can't be closed by right-clicking on the app icon in the system tray and selecting "Close window". Has to be killed via "End task" in Task Manager. I download the update a 2nd time from https://www.ccleaner.com/ccleaner/builds, but a binary compare of that with the original download from Filehippo shows that the two are identical. Uninstalled 5.64, re-installed 5.63, and it runs fine. In Event Viewer there are multiple events from Windows Error Reporting in the Application log showing:

Fault bucket , type 0
Event Name: AppHangB1
Response: Not available
Cab Id: 0

Problem signature:
P1: CCleaner64.exe
P2: 5.64.0.7613

 

Link to post
Share on other sites

win7 sp1 ultimate x64

updated cc tonight to 5.64.7613 x64

same issue as others with the freezing.  task manager shows 2 processes for ccleaner64.exe. only msg in event log is audit success for ccleaner64.exe regarding the IP's for ccleaner's cloud and a request to DNS server.  i can ping these points that ccleaner64 at times is calling:

199.232.40.64, 199.232.42.109, 77.234.42.94, 199.232.42.202, 151.101.38.202

firewall was turned off on this system and hosts file is empty.  no msg of error or blocking from a/v bitdefender.

Link to post
Share on other sites
  • Admin
13 hours ago, zoa said:

Will the professional licence will still be picked up when reverting?

Yes, provided you don't uninstall first. Perform an over-the-top install.

In the meantime, we're looking into this.

Link to post
Share on other sites

On one PC, I also had the problem that the GUI was frozen immediately after starting. (The installation went through without any problems).

This problem is definitely related to the HealthCheck. If I deactivate the HealthCheck via Registry, the GUI works.

Afterwards I compared the settings with another PC and found the cause. The other PC has the following additional CCleaner setting: "DisplayIM=1-1|2-1|". If I add this setting the GUI works again even if HealthCheck is activated.

Can Piriform please clarify this? Thank you.

Link to post
Share on other sites
12 hours ago, APMichael said:

On one PC, I also had the problem that the GUI was frozen immediately after starting. (The installation went through without any problems).

This problem is definitely related to the HealthCheck. If I deactivate the HealthCheck via Registry, the GUI works.

Afterwards I compared the settings with another PC and found the cause. The other PC has the following additional CCleaner setting: "DisplayIM=1-1|2-1|". If I add this setting the GUI works again even if HealthCheck is activated.

Can Piriform please clarify this? Thank you.

 

On the system that froze, is Windows Defender your primary security program?  The reason I ask is that Windows Defender apparently has an option to "Block potentially unwanted apps".  I do not use Windows Defender on any of my systems.  Thus I am not all that familiar with WD; however, I understand that WD has the option to Whitelist apps so that the whitelisted apps are not blocked.   Just curious 🙃

Edited by siliconman01
Link to post
Share on other sites

Confirmed fix - First, close CCleaner with Task Manager

Next, go to REGEDIT, search for the key HKEY_LOCAL_MACHINE\SOFTWARE\Piriform\CCleaner

Change (Cfg)HealthCheck from 1 to 0

Restart CCleaner 

You can now use CCleaner and it wont constantly "bong" at you.

 

Link to post
Share on other sites
  • Moderators
23 minutes ago, AnoneeMouse said:

Confirmed fix - First, close CCleaner with Task Manager

Next, go to REGEDIT, search for the key HKEY_LOCAL_MACHINE\SOFTWARE\Piriform\CCleaner

Change (Cfg)HealthCheck from 1 to 0

Restart CCleaner 

You can now use CCleaner and it wont constantly "bong" at you.

 

 

This is posted 2 posts up. You should give credit to original poster.

 

Link to post
Share on other sites
On 05/03/2020 at 07:22, siliconman01 said:

On the system that froze, is Windows Defender your primary security program?  The reason I ask is that Windows Defender apparently has an option to "Block potentially unwanted apps".  I do not use Windows Defender on any of my systems.  Thus I am not all that familiar with WD; however, I understand that WD has the option to Whitelist apps so that the whitelisted apps are not blocked.   Just curious 🙃

 

On all systems I use Windows Defender with PUA protection enabled. Excluding CCleaner with the whitelist will not cure the frozen GUI. Windows Defender will also usually notify you whenever it blocks a PUA.

I could find another solution: If the regsitry value "(Cfg)HealthCheckIpm" (HKLM) is deleted or set to 0, CCleaner starts with the introduction of the HealthCheck and sets the necessary setting "DisplayIM" (HKCU) itself. Therefore the installer probably sets the wrong start value for "(Cfg)HealthCheckIpm".

Link to post
Share on other sites

Hi all,
The Ccleaner Pro 5.64 update version crashed in the middle install, I had to go through the task manager to exit, (Windows 8.1Fr 64bits).
When the computer reboot, many  software are blocked, Thunderbird, Acrobat reader, and so on, or very slow like Firefox 73.0.1 “15 to 60 seconds for the Google home page”,
the other six computers on the network without Ccleaner have a normal response time
.

The  5.63 Pro reinstall does not change the damage caused.  Uninstalling Ccleaner Pro by the program manager no longer works.
Regards.

Link to post
Share on other sites
11 hours ago, AnoneeMouse said:

Confirmed fix - First, close CCleaner with Task Manager

Next, go to REGEDIT, search for the key HKEY_LOCAL_MACHINE\SOFTWARE\Piriform\CCleaner

Change (Cfg)HealthCheck from 1 to 0

Restart CCleaner 

You can now use CCleaner and it wont constantly "bong" at you.

 

 

Link to post
Share on other sites

AnoneeMouse,

Thank you, thank you.  Followed your fix & presto, it works.  Again, thank you for doing what CCleaner should have done days ago.  You the man!

Link to post
Share on other sites
  • Moderators

That registry change is a work-around but not a fix.

What it is doing is reverting to Easy Clean without the Health Check functions.

Link to post
Share on other sites

@hazelnut The post made my APMichael was great to point me in the right directed, which is why I posted as "Confirmed".
I didnt give credit since the steps weren't detailed out as to what to do. I specifically wrote these steps out for others to follow.

Regardless, this registry hack is just that and the ultimate problem needs to be addressed by Avast.

For those that tried this registry fix, I'm pleased to hear that it works. 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...