Jump to content
CCleaner Community Forums
DennisD

Laptop high CPU useage problem

Recommended Posts

I've googled until I'm google eyed with this problem on a neighbours NEC i-Select M5210 laptop.

 

256mb memory, 1.5GHz processor. XP SP3 fully patched. Not the sleekest animal, but it should still be OK for the usual surfing, emailing and storing family photos.

 

Was running really well and smoothly until yesterday, when it slowed down to a crawl. The only thing showing in Task Manager was Automatic Updates running for a long time, and using up a good chunk of a relatively small memory. Had to disable updates to shut it down.

 

Upon launching Process Explorer, the real culprit was something totally different ...

 

yNfR2s.jpg

 

"Deferred Procedure Calls", and "Interrupts" are soaking up about 50% CPU from the moment the laptop boots until it's closed down again. Happens every time.

 

I've checked the IDE controllers, uninstalling and rebooting for good measure, as the DMA display doesn't always change if PIO mode kicks in. No apparent problems there. Same with the DVD ROM drivers. No problems.

 

Have run chkdsk a couple of times, with no problems apparent.

 

How can you discover why these two are running constantly? There doesn't seem to be any clear answers out there, short of reinstalling Windows, and then finding the problem still there. What a bummer that would have been.

 

And, I've just remembered, an odd message I just caught sight of as it was closing down 20 minutes ago. First time I've noticed it ... "Ending Program Magellan MS Wheel".

 

Booted it up again, and can't find anything with a name like that. Carried out a few searches and nothing at all, and I'm just gonna google that now.

 

Any suggestions welcome. Thanks.

 

 

EDIT: Found out what mswheel is all about, but can't find anything on the laptop relating to this link. Nothing in the appoint folder. And no hidden drivers in device manager. One mouse and one touchpad.

 

http://forums.majorgeeks.com/showthread.php?t=94070

Share this post


Link to post
Share on other sites

I see why you're googled out, while an initial google captured me many results (including a google search suggestion for interrupts high cpu xp ) non of the answers were very useful

 

I'm assuming that on safe mode the same is true?

 

on my xp3 box neither interupt nor dpc have any cpu usage at all

I did find a couple of resources pointing to using xperf http://msdn.microsoft.com/en-us/performance/cc825801.aspx but not sure if you'll even beable to get it to run. This is for win7 http://social.technet.microsoft.com/Forums/en/w7itprohardware/thread/f6443a44-c6c3-4df4-be79-33817a1f368a but may be of some use

you can also try sysinternals procdump

 

can you get speccy to run? maybe we can look at what hardware is running

Share this post


Link to post
Share on other sites

Thanks Nergal, yea I can run Speccy on it, and I found something which is gonna possibly pinpoint the cause, a tool called RATTV3 ...

 

http://www.microsoft.com/whdc/DevTools/tools/RATT.mspx

 

From some of the sites I've hit, it can pinpoint the hardware, or more usually, the driver causing the problem.

 

It's only drawback apparently, is it isn't the easiest of readouts to make sense of.

 

I'll try the stuff in that link of yours as well.

 

Thanks.

Share this post


Link to post
Share on other sites

In the second forum post on this other forum it states Microsoft Intellipoint/Intellimouse software.

 

Make a system restore point before messing around!

If that laptop only uses the standard keyboard and build-in mousepad and if Microsoft Intellipoint and Microsoft Intellimouse are installed there should be startup references in the registry for them which CCleaner or msconfig (Start -> Run -> Type in: msconfig.exe -> Click the Startup tab) can disable from starting then reboot to see if that fixes it. If that's the cause they could be left disabled and still installed, or they can be uninstalled to instead use the default Windows driver originally installed by Windows.

Share this post


Link to post
Share on other sites

There's no Intellipoint stuff on the laptop. Just stuff left over it seems.

 

One strange thing I have found is that there is no "Windows Driver Foundation" service running, and therefore no svchost.exe which normally carries it.

 

This is one of those important "Leave set to Automatic" services, so I've no idea why it isn't there, and I'm now trying to find out if it's an essential part of windows, and how to install it if necessary.

 

This is one of those probs which never ever pop up, which leaves you scratching your head.

Share this post


Link to post
Share on other sites

Where's all the techie guys when you need them!

 

No worries, I've solved the problem.

:)

Share this post


Link to post
Share on other sites

Where's all the techie guys when you need them!

 

No worries, I've solved the problem.

:)

So what was it? bad hardware, or bad driver? (inquiring mind want to know :P )

Share this post


Link to post
Share on other sites

So what was it? bad hardware, or bad driver? (inquiring mind want to know :P )

 

X2

Share this post


Link to post
Share on other sites

You know me guys, I always follow up posts, or pop in an occasional "For Info" thread, but just for once I thought I'd just leave the solution out, and see how many bites I got.

 

Only two. I'm disappointed. :(

 

The hardest part about this was the time it took.

 

After exhausting just about every google and idea I had, I remembered a little tool I found some time ago, and posted on here:

 

DPC Latency Checker:

 

778ac94268d6.jpg

 

It guided me to a probable problematic driver, and in this case it turned out to be the Atheros Wireless driver. It was working OK, but was way out of date.

 

I eventually found a more recent version which when installed, knocked the Interrupts and Deferred Procedure Calls down to the 0% to 5% region, instead of 25% to 30%. Before I did the driver update, I had a look in Process Explorer at the difference between the figures when the Wireless LAN was disconnected. The DPC's etc were hovering at 0% to 2% approx, with the occasional higher peak.

 

I tried a comparison using an Ethernet connection, and again 0% to 2% approx results in Process Explorer.

 

I've probably got the best I'm gonna get for what's an old Wireless Card, but at least the Laptop's usable now.

 

I also found while dredging through all the listed drivers shown in "What's Running", a damned McAfee kernel level driver, which was still alive and running. This is after first disabling, and then removing McAfee A\V with the correct removal tool, and searching through stuff myself.

 

This screeny is after I removed it. (mfetdik)

 

219586098a44.jpg

 

One to look out for if you're removing McAfee anytime.

Share this post


Link to post
Share on other sites

Well done Dennis :)

 

Ah, McAfee's hidden bits and pieces. It's not on really when even after the removal tool there's still bits left :(

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...