Jump to content
CCleaner Community Forums
Elilai

7 programs won't run after Ccleaner registry clean

Recommended Posts

PLS HELP.  I clean my registry periodically with Ccleaner, always make the backup first.  I've never had any trouble... Yesterday I first upgraded from Ccleaner 5.63 to 5.67.  Cleaned the registry.  Did not pay attention to what was cleaned up...  but I did back up the registry first.  Now I have 7 programs that will not run.  I go to their .exe file in file manager and click and it says: Windows cannot find c:\program... and it gives the full, correct path.  But they won't open.  The rest of my programs work as normal.  There is nothing else that I did on my computer or anything obvious...  I am assuming it is due to the registry clean.  I have done MANY things to try to sort this out.  Nothing has helped.  It is a mix of old and new programs that will not open; other very old and brand new programs still work.  What else can I try??  I have tried:

1. restore the backup registry; it didn't help.

2. I use AVG internet security; I did a deep virus scan. Installed Malawarebytes, scanned.  No change.  Uninstalled AVG in case it was conflicting.  No change. Windows Defender is now running.

3. Updated my Win 10, did not help.

4. Checked in the registry for .exe=exefile and suggestions to enter "%1" %* was already in there.

5. Uninstalled 2 of the non-working programs- NordVPN and Acrobat Reader DC, reinstalled them.  Same problem.

6.  Created a new user account, installed NordVPN and still have the same problem.

Unfortunately I don't have an image backup of my whole system.  Any suggestions would be most welcome.

Share this post


Link to post
Share on other sites

Actually now I'm wondering if the new installation of CCleaner 5.67 didn't install some malware or a trojan...  Any comments please?  I downloaded it from the Ccleaner site.

Share this post


Link to post
Share on other sites

From what you say then it is possibly the registry cleaner that has removed needed entries.
Although nobody else has reported a similar problen with v5.67.

You should not be running the registry cleaner regularly, especially not with Windows 10.
Registry Cleaning has it's uses when trying to fix a machine that is already broken, but it will not save more than a few KB of space or 'speed-up' a working machine in any way.
Here is what Microsoft have to say about using a registry cleaner, ie don't use a registry cleaner.
https://support.microsoft.com/en-gb/help/2563254/microsoft-support-policy-for-the-use-of-registry-cleaning-utilities

To your problems.

You seem to have done/tried everything right up to now, except maybe doing a Restart (not shutdown-reboot) after uninstalling the problem apps and before reinstalling them?

First the 'Windows cannot find' File Explorer problem.
Sometimes simply changing an option in File Explore will fix that 'Windows cannot find' error.
(It seems to be a glitch in File Explorer itself and just switching the option fixes it).
Open File Explorer and click the Options button on the right of the toolbar.
That should bring up the 'Folder Options' dialogue open at the 'General' tab.
Change 'Open File Explorer to:' from whichever option it is on to the other option. ('Quick Access' or 'This PC').
You can change it back again later if wanted.
Click 'Apply' click 'OK'.

Reboot and see if your apps will launch now

If not then try fix #2 "Re-register Windows 10 apps" as detailed here: https://windowsreport.com/fix-windows-cannot-find-type-name-correctly/

Note that to re-register the apps for all user accounts then modify the string that you input into Powershell by adding '-AllUsers' as below:

Get-AppXPackage -AllUsers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}

 

I doubt that you have a malware, if there was malware in CCleaner v5.67 then millions of users would be shouting about it by now. (Me among them).

Share this post


Link to post
Share on other sites

Thanks for your reply.  I mean to try a boot in safe mode yesterday and got sidetracked with all my other searching for a solution.  Finally did it just now; all the problem programs that will run in safe mode DID run... and when I rebooted, they all now work...  I wish I understood all this.  I am very relieved.  Thank you for your help and advice.

Share this post


Link to post
Share on other sites

Good to hear that it sorted itself out. Computers can work in strange ways at times.

It does sound like it was a problem with Windows 10 and booting into safe mode helped Windows recognise something was wrong and fix it.

Win 10 is much better at fixing itself that than older Windows versions were.

Share this post


Link to post
Share on other sites

Might be a combination of using the registry cleaner and some weirdness that is in Win10 from time to time, and they did just have the updates Tuesday - perhaps just a coincidence. Restarting a computer is always the first thing to try, sometimes a session can just be buggy and Windows (any version) can be very finicky and weird sometimes.

With Win10 in particular I've seen it have odd or buggy behavior with external USB drives as if they were never initialized or formatted (how a brand new SSD arrives) like there was nothing on them and rebooting and using the drive in the same USB port won't fix it, however what will fix it is to unplug the drive and plug it into a different USB port and Win10 all of a sudden correctly sees the drive.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...