Jump to content

Cannot get Fragmentation level below 30%


Recommended Posts


I am a long time user and firm believer in both Defrag and CCCleaner.



I am trying to defrag the system disk (C:) on a PC running Windows Vista Business SP1, AV is Haspersky Internet Security 2012. I don't normally disable AV when I defrag but I have tried that on this system with no positive affect.


It was something arounf 46% fragmented but after the following actions:


Ran CCleaner to clean up Temp files and Registry

10 'normal defrags'

a boot time defrag (which actually resulted in Defraggler reporting a higher fragmentation level than before the boot time degraf)

a further 10 defrags

defrag the files list

Another Defrag


During the last defrag, the number of fragmented files fell from 149 to 76, No. of total fragments from 738 to 308 but the framentation only fell to 29% :(


Never had this issue before with defraggler which normally finishes with a very low % after a few defrags.


Any ideas anyone?

Link to comment
Share on other sites

H'mmmm, thanks for the suggestion.

Well I did that and it is now REPORTING 2% fragmentation.


But all the files that have large numbers of fragmens (mostly Kaspersky files and Kaspersky temporary files) are still there and fragmented -- just niot being reported.


So it seems to me this just hides the level of fragmentation -- it doesn't actually get the disk any less fragmnented ??

And I've never used these settings previously.

Link to comment
Share on other sites

Restore points and hibernation files are not defragged by Defraggler, Windows Defragger, or other defraggers cos they are protected -- too important to mess with. If the Kaspersky files are still fragmented maybe it's cos Kaspersky locked them. I doubt you'll notice any performance issues with 2% frag. Even if you could attain a true 0% frag the count would begin to climb as soon as you used the computer. Nothing gained.


I use only the file defrag and get a zero frag count with an empty list every time, and within an hour I have 1% fragmentation. :D

Link to comment
Share on other sites



All mine are Kaspersky files and Kaspersky temporary files


I can get to 0% in 3-4 runs no problems at all.


I turn the defrag off (Only) then rerun it again.


Before that I was having a lot of problems and after trying this and that and getting completely confused I "Removed" Defrag and Reinstalled it with Kaspersky in "Pause"


Working faster and a lot better now.



Link to comment
Share on other sites

My problem is similar in that after any program upgrades, my drive won't defrag 100%. Up until the last 2 days, I would uninstall the program, reinstall and then I would get 100% defrag. Not this time though. So I tried the defrag at boot time instructions and while it said 0% when done I could still see the red clusters. I then went back to the normal settings and I have 17% that isn't defragged and the file is 7.3 GB.


What now?


Thanks for your help.

Link to comment
Share on other sites

System Volume Information = Restore Points -- cannot defrag as explained above in post #4.

So do this which will drop your frag count to or near zero.

Then follow with a Boot Time Defrag, which defrags the paging file, etc. 35bv39e.png

You will still see red blocks cos some stuff is not defragged as explained above in post #4.

Link to comment
Share on other sites

Thanks very much ~ I will do this. Curious though why I was always able to get it to zero before when I had this problem.

I didn't try to uninstall and reinstall the upgraded programs, as I've done in the past, as too many programs updated and I was just overwhelmed.


Appreciate you very much!

Link to comment
Share on other sites

  • 7 years later...

Old thread revival!

Win10, same problem and tried all the suggestions here but no change.

On my (new) machine the problem was McAfee antivirus. Deleted it and replaced with another.  Defrag dropped to 1%. Extra bonus is that the machine is noticeably faster when multi tasking.

Link to comment
Share on other sites

- It also could be a "permission" problem. If you don't have the right permission then Defraggler won't touch/move those files.

- There is a program that can set all the proper permissions (for the registry and file) called "Tweaking's Windows Repair". Try it and report back if fragmentation has gone lower.

System setup: http://speccy.piriform.com/results/gcNzIPEjEb0B2khOOBVCHPc


A discussion always stimulates the braincells !!!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.