Jump to content
CCleaner Community Forums

Invalid Default Icon Acrobat Reader


JohnP1111

Recommended Posts

  • Moderators

You can exclude that registry location by starting CCleaner then:

1. Click Options, Exclude

2. Now click Add Registry and use the drop down box to select HKCR

3. Input in the empty field: acrobat\DefaultIcon

Link to post
Share on other sites
  • 1 month later...

Couldn't this be permanently fixed in CCleaner, please?

 

The missing Acrobat Reader registry entry breaks the adobe firefox pdf plugin for me, took a while to find out..

Now I'm using FoxIt and I'm happy with it.

Link to post
Share on other sites
  • Moderators

This is an error on ADOBE's part not ccleaners. I stopped the error by manually editing that registry entry to point to the CORRECT location of the file referenced. So far no problems and the reg entry doesn't come up bad anymore in ccleaner

Link to post
Share on other sites

This is the Registry File (Adobe Fix Acobat 7.0 Reader Icon.reg) I created to fix this problem for Adobe Reader 7.0:

 

1) Cut/Paste ALL the text BETWEEN the 2 lines to a text editor such as Notepad.

 

-------------------------------------------------------------------------

Windows Registry Editor Version 5.00

 

[HKEY_CLASSES_ROOT\acrobat\DefaultIcon]

@="C:\\Program Files\\Adobe\\Acrobat 7.0\\Reader\\AcroRd32.exe"

 

-------------------------------------------------------------------------

 

2) Edit as necessary ("Acrobat 7.0" must be edited if your version is different) and save it.

 

3) Double-click the file name it and the info will be added to the registry to correct/restore the bad/missing entry.

 

 

I created the "Adobe Fix Acobat 7.0 Reader Icon.reg" file because I had removed this entry from other PCs in the house and I needed an easy way to fix both them and other PCs I work on.

Link to post
Share on other sites

I already have a Registry File (Adobe Reader 9.0) for this, but I have to execute it every time I cleaned ActiveX- and Classes Errors (under 'Registry'). Is there a permanent fix for this?

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...