Jump to content

ERROR code: System (12029)


Recommended Posts

  • Admin

If you've got any sort of VPN or firewall active, please disable them for the moment, and then attempt to register. (Make sure to reenable them afterwards, though!)

Could also try resetting any sort of proxy setting present on the computer via:

  1. Open the "Run" dialog in Windows (On the keyboard, hold the "Windows" (?name=Windows+Logo.png) and "R" keys simultaneously)
  2. Type: cmd(without clicking OK or Enter)
  3. On the keyboard, hold/release the CtrlShift and Enter keys simultaneously
  4. Type and enter: 
netsh winhttp reset proxy

 

Alternately, it is possible that an entry in the hosts file could be preventing access.

  1. Open the "Run" dialog in Windows (On the keyboard, hold the "Windows" (?name=Windows+Logo.png) and "R" keys simultaneously)
  2. Type: C:\Windows\System32\drivers\etc > click OK
  3. Right-click on the "hosts" file > click Open with > Notepad > OK
  4. Erase any entries including: piriform.com if present
  5. Click File > Save

If none of these take care of the issue, please feel free to contact our support team via the Contact Us form located here: https://support.piriform.com/hc/en-us/requests/new?ticket_form_id=86507 or by emailing support@ccleaner.com directly and we'll be happy to assist further.

Link to comment
Share on other sites

9 minutes ago, johnccleaner said:

Please also perform the other step mentioned (resetting the proxy) and, if that does not take care of the matter, get in contact with our support team as described above.

Yes did that too and turned off my firewall, even setup rules in it for all of the CCCleaner exe files. I even uninstalled it and cleared the registry lines and installed it on a different drive.

I also noticed when i first installed the trial is kept saying I needed to be online to activate the trial when I was online so I uninstalled that I decided to buy it just in case the trial was faulty.

Could it be a compatibility issue with windows 11 64 bit?

I sent a mail to support now.

Edited by Mr C
Link to comment
Share on other sites

quick update, if i entered C:\Windows\System32\drivers\etc\hosts in explorer I was asked what to use to open the file so i chose notepad but it wasn't as admin a apparently even though i am admin on my PC and no matter how i tried to save it I could save it in the etc folder. The host file did contain piriform.com

The actual host file is also not viewable even if i set the folder to show hidden files so I could copy it to another folder to edit.

If I opened notepad as administrator and chose open and then went to the etc folder I still could not see the file even as "all files". I dragged the whole etc to my desktop but notepad will only save as txt and not sys so that didnt overwrite the original host file.

Only solution I found that allowed me to activate my license was rename the etc folder and reboot so no host file was read.

Now I still need to figure out how to edit the host file in case not having one causes issues.

Link to comment
Share on other sites

  • Admin

That's very strange, I've not heard that occurring before and am not able to reproduce this behavior; though apparently this is indeed normal for at least some installs of Windows 10.

Specifically, I see quite a bit of discussion of cases that sound similar to what you describe here: https://superuser.com/questions/958991/windows-10-cant-edit-hosts-file 

There's also: https://answers.microsoft.com/en-us/windows/forum/all/i-dont-have-a-hosts-file/8c9f1152-25f1-4545-9e1f-acc028e9e018 but that didn't seem as helpful. 

(Not being able to save it in place is fairly normal, though; usually simply dragging the hosts file - with no extension - into the etc folder from another folder like the desktop will work, though.)

Very strange - but I'm glad you were able to figure out something of a workaround. Thanks for letting us know what you found!

Link to comment
Share on other sites

Hi, is there anyone who can help me. Speccy Professional normally registers with the key I bought only CC Cleaner Professional does not want to register even though it has all the data entered and even when deleting and reinstalling it immediately withdraws the data that was already entered. He keeps saying how wrong there is in your registration system. This can be seen in the picture.

cc.jpg

Link to comment
Share on other sites

apparently the problem is being caused by the HOSTS file.

if you cannot access your HOSTS file, adjust file explorer's view-settings to "show hidden files."

one way to nuke the HOSTS file is to rename it to "nohosts." you can change it back to "HOSTS" after you've finished your troubleshooting.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.