Jump to content

CCleaner has a problem deleting folders


RunAmok

Recommended Posts

  • Moderators

wait? so your computer at one point had been set to run ccleaner as win95, and because ccleaner (for past many versions) didn't support 95 it would fail (or was looking in win95 locations)?

devs,

Perhaps ccleaner should look in the registry for old appcompats in the registry (if it doesn't already) I know per se it wouldn't have fixed this instance but. . ?

 

Glad you got it fixed, though I wonder why it once was set to run as 95 :blink:

 

ADVICE FOR USING CCleaner'S REGISTRY INTEGRITY SECTION

DON'T JUST CLEAN EVERYTHING THAT'S CHECKED OFF.

Do your Registry Cleaning in small bits (at the very least Check-mark by Check-mark)

ALWAYS BACKUP THE ENTRY, YOU NEVER KNOW WHAT YOU'LL BREAK IF YOU DON'T.

CCLEANER, RECUVA, DEFRAGGLER AND SPECCY DOCUMENTATION CAN BE FOUND AT  https://support.piriform.com/hc/en-us and  https://www.ccleaner.com/docs

Pro users file a PRIORITY SUPPORT request at https://support.piriform.com/hc/en-us/requests/new

link to WINAPP2.INI explanation

Link to comment
Share on other sites

Nergal, I don't have a clue why that key was there. This system was set up four or five years ago with XP, and it's stayed with XP (plus a service pack and a pot-load of patches) ever since. I don't remember exactly which release of CC I last did the 'full' uninstall (with registry cleanup), but not that long ago - somewhere around the 3.16-3.18 range, it was still regenerating that key when it installed. I'm sure the dev's could explain why that key was added on an XP system 'back when', but the bottom line is that the newer versions should check for the AppCompatFlags\Layer entry (which was the only one there) with the C:\program files\ccleaner\ccleaner.exe REGSZ WIN95 contents, and either delete that key, or the entire AppCompatFlags key if the CC contents is the only thing in the Layer entry - which mine was. The newer versions don't add that key, but they don't delete it on an uninstall - which would have fixed the problem several releases ago.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.