Jump to content
CCleaner Community Forums

Speccy 1.14.288 delivers error msgs in multiple fields

Recommended Posts

Hi eveyone!


I just downloaded Speccy to see if it could help me ID the memory in my system and after running it identified my OS and optical drive but on all other fields it returned the following error:


"Cannot initialise SPC dll"


I am running a Dell Dimension 3000, XP SP3


Can someone help me?


Thanks a bunch!



Share this post

Link to post
Share on other sites

This question may seem odd, however everyone who has claimed your issue has fixed it via this.


Have you rebooted your computer, if not do so


Also are you running any sort of sandboxing program (like sandboxie)

Share this post

Link to post
Share on other sites

Thanks for the reply Nergal!


I tried the reboot and got the same results. I am not running any sandboxing programs. I am running SpyBot S&D and ThreatFire. Would these interfere with Speccy?


Thanks for your time!

Share this post

Link to post
Share on other sites

Can you run Services.msc and tell us if the service "windows management instrumentation" is started and automatic?


I guess threatfire might be stopping something, but on cursory look I didn't find anything about it blocking WMI reads.

Some People had the same issues as you from Outpost Firewall until they turned off "Anti-Leak" does Threatfire have something similar? What Firewall are you running (I'm not familure with ThreatFire is it a firewall as well as an antivirus?)


Are you running speccy as an administrator account?


Have you changed any settings in your computer's bios?


Share this post

Link to post
Share on other sites

Hi folks!


I ran through all the questions and fixes from Nergal and hazelnut and still get the same results Here is what I did:


I ran Services.msc and "windows management instrumentation" is started and on automatic.

As far as I can tell, Threatfire is just an antivirus and not a firewall and does not have a setting similar to "Anti-Leak".

I am running Speccy as an administrator.

I have not changed any of my BIOS settings.

I tried disabling Teatimer, rebooted and still got the error message.

I also tried disabling ThreatFire and running Speccy and got the same error message (though I did not reboot as ThreatFire has a disable option within the program).


Any other ideas? I apologize for being the problem child and I greatly appreciate all the help given.

Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...