Jump to content
CCleaner Community Forums
Titano

CCleaner 2.03.532 shuts down after firewall installation

Recommended Posts

Ciao to everybody. Two days ago I have installed a new and very interesting free firewall, named "Online Armor" v. 2.1.0.31. From that, I have a very annoying problem with the last version of CCleaner: when I run twice the "run cleaner", at the second "run cleaner", CCleaner shuts down as quick as lightning. The same thing appens if, after the first "run cleaner" I try to run another command like "options". It shuts down again!

The option in "options---> advanced---> close program after cleaning" is UNcheked.

My other protection prgrams are: Active Virus Shield as antivirus, and Spybot.

My OS is WinXP Pro SP2 fully updated, and IE7.

I have uninstalled CCleaner, rebooted and re-installed it, but without success. I have tried to install the previous version of CCleaner too, but the same problem happens.

 

Any suggestion?

Titano (Italy)

Share this post


Link to post
Share on other sites
when I run twice the "run cleaner", at the second "run cleaner", CCleaner shuts down as quick as lightning. The same thing appens if, after the first "run cleaner" I try to run another command like "options". It shuts down again!

Any suggestion?

 

Over 100 million downloads....but....have just I this kind of problem around the world? :rolleyes:

I'm a bit frustrated!

 

Thanks in advance

Share this post


Link to post
Share on other sites

I also use Online Armor and CCleaner but I don't have the problem you have Titano.

Share this post


Link to post
Share on other sites
I also use Online Armor and CCleaner but I don't have the problem you have Titano.

 

Hazelnut, thanks for the reply.

 

Before installing Online Armor, my ex firewall was "Dynamic Security Agent" by Privacyware, and I never had this kind of problem with CCleaner. At this point I suspect that new firewall has changed something in my sistem, that I don't understand. That's all.

 

Titano

Share this post


Link to post
Share on other sites

Sorry Titano, I cannot quite make out all the words, i think I saw something like...

 

to a virtual address for which it does not have the appropriate access

 

which could be caused by many things.

 

Are there any clues in the windows event viewer? (control panel>admin tools>event viewer)

Share this post


Link to post
Share on other sites
Sorry Titano, I cannot quite make out all the words, i think I saw something like...

 

to a virtual address for which it does not have the appropriate access

 

which could be caused by many things.

 

Are there any clues in the windows event viewer? (control panel>admin tools>event viewer)

 

Hi Hazelnut. There are no clues in my event viewer. My sistem is Ok (I have recently formatted my hard disk).

In my life this is the first time I got this kind of errors from CCleaner.

 

I re-write the error message, hoping in some help (I don't understand it, unfortunately I'm not a programmer :rolleyes: )

 

Critical Error

A Critical error has occurred in CCleaner, the application must now close.

Error description:

The thread attempted to read from or write to a virtual address for which it does not have the appropriate access.

(This language for me is such as the chinese :rolleyes: )

Thanks in advance

Titano

Share this post


Link to post
Share on other sites
In my life this is the first time I got this kind of errors from CCleaner.

I re-write the error message, hoping in some help (I don't understand it, unfortunately I'm not a programmer :rolleyes: )

 

Critical Error

A Critical error has occurred in CCleaner, the application must now close.

Error description:

The thread attempted to read from or write to a virtual address for which it does not have the appropriate access.

(This language for me is such as the chinese :rolleyes: )

 

First of all I excuse me for the lot of posts in this 3D. :rolleyes:

 

For the moment I have solved the problem switching to CCleaner v1.41.544. It works like a charm!

Probably the last versions of CCleaner ( from 2.00) conflict with "Online Armor" in my sistem. I don't know why...

Hope that programmers of this fantastic program solve the little bugs which are still afflicting the last versions of it (those with new GUI).

Ciao

Titano

Share this post


Link to post
Share on other sites

Hi Titano,

 

Could you run one task at a time using CCleaner V2.xx (it can be v2.03.532) and then post here the name of the task that is causing the problem?

 

For example, uncheck everything and then only check "File Temporanei Internet" and see if works; then go ahead uncheck it and check the next one and so on...

 

With this approach, you can help identify which one is causing the problem.

 

Thanks

Share this post


Link to post
Share on other sites
Hi Titano,

Could you run one task at a time using CCleaner V2.xx (it can be v2.03.532) and then post here the name of the task that is causing the problem?

 

For example, uncheck everything and then only check "File Temporanei Internet" and see if works; then go ahead uncheck it and check the next one and so on...

 

With this approach, you can help identify which one is causing the problem.

Thanks

 

Ciao Htome

 

I'll try to explain that I have discoverd using your intelligent procedure, but I have to state in advance that the error massage rarely appears, because CCleaner 99.999% shuts down very very fastly!

 

Well, I have discovered that the problem is not caused by just one task alone. Checking and UNchecking one task at a time, CCleaner is OK.

The problem appears when they are checked in combination!

 

In detail:

  1. CCleaner works like a charm when the only "Windows Explorer -->Recent Document" is UNchecked and the other tasks are all Checked (both groups "Internet Explorer" and "Windows Explorer" and "System" );

  2. CCleaner shows the problem when "Autocomplete Form History" and "Recent Document" are both checked, and all of other tasks are UNchecked. :blink:

     

    Hope I've made myself clear.

     

    Thanks again for your interest to my problem

    Ciao

 

Share this post


Link to post
Share on other sites

Ciao Titano,

 

This is definetly the kind of information we need to fix problems.

 

Thank you very much for your help.

Share this post


Link to post
Share on other sites
Ciao Titano,

 

This is definetly the kind of information we need to fix problems.

 

Thank you very much for your help.

 

You're welcome Htome!

 

I'm very glad when make myself useful :P

 

Ciao

Titano

Share this post


Link to post
Share on other sites

Hi Titano,

 

Unfortunately, we haven't been able to reproduce the error. If we can't reproduce it is quite impossible to fix it.

 

Let me know if you still having problems.

 

Thanks

Share this post


Link to post
Share on other sites
Hi Titano,

 

Unfortunately, we haven't been able to reproduce the error. If we can't reproduce it is quite impossible to fix it.

 

Let me know if you still having problems.

 

Thanks

Hi Htome

It's very strange this kind of error happens only to me...

 

Anyway...If I use CCleaner 1.41.0.544 is everything all right, while using the 2.03.532, I have to follow the expedients described in post n 10.

 

Thank you for your interest to my question

Titano

Share this post


Link to post
Share on other sites

I'm here again to report an error message I got minutes ago.

 

 

Microsoft Visual C++ Runtime Library

Runtime Error!

Program: C:\Programmi\CCleaner\CCleaner.exe

R6025

-pure virtual function call

 

Hoping it can be useful I wish a Merry Christmas to everyone!

Share this post


Link to post
Share on other sites
I'm here again to report an error message I got minutes ago.

 

 

Microsoft Visual C++ Runtime Library

Runtime Error!

Program: C:\Programmi\CCleaner\CCleaner.exe

R6025

-pure virtual function call

 

UP!

 

Excuse me, but...does this issue have been resolved or not? :(

 

Please let me know ;)

 

Thanks

 

Regards

 

Titano

Share this post


Link to post
Share on other sites
I'm here again to report an error message I got minutes ago.

Microsoft Visual C++ Runtime Library

Runtime Error!

Program: C:\Programmi\CCleaner\CCleaner.exe

R6025

-pure virtual function call

 

Hoping it can be useful I wish a Merry Christmas to everyone!

Try the advice in this post, see if it helps:

 

http://forum.piriform.com/index.php?showtopic=8587

Share this post


Link to post
Share on other sites
There is a microsoft article here about this

 

http://support.microsoft.com/kb/125749

 

however it is beyond me as it seems to be about programs :)

 

Is your version of CCleaner in Italian? perhaps it may be something to do with the language file?

 

Hi Hazelnut, my version is in Italian, but in "Option-->Settings-->Language, choosing "English", doesn't resolve the shutting down.

 

Since I have opened this 3D, I have done many investigations on Microsoft site and...yes I have already read that article... and many others too (I have tried this one http://www.microsoft.com/downloads/details...99-220b62a191ee). But there are no solutions for my issue over there :(

 

Moreover, this language for me is...incomprehensible

post-15925-1200094604_thumb.jpg

post-15925-1200094604_thumb.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...