Jump to content

Recovering from a USB drive


Recommended Posts

I have a ScanDisk USB drive that I have been using successfully for quite awhile. I plugged into my laptop the other and I received the message that it was not formatted, do I want to format now? I clicked no. I then did a search for recovering data in situations like this and Recuva came up as highly recommended.


So, I downloaded Recuva, installed it and ran it. A the bottom of the window it says "Unable to read boot sector". Now I am not a computer whiz but something tells me I'm pretty much out of luck. Any suggestions to recover my files or is all lost?




Link to comment
Share on other sites

  • Moderators

Hi Rob, and welcome to the forum.


I hope all isn't lost.


Have a look at "Test Disk" ...


TestDisk can


Fix partition table, recover deleted partition

Recover FAT32 boot sector from its backup

Rebuild FAT12/FAT16/FAT32 boot sector

Fix FAT tables

Rebuild NTFS boot sector

Recover NTFS boot sector from its backup

Fix MFT using MFT mirror

Locate ext2/ext3/ext4 Backup SuperBlock

Undelete files from FAT, exFAT, NTFS and ext2 filesystem

Copy files from deleted FAT, exFAT, NTFS and ext2/ext3/ext4 partitions.


... it looks at first glance like a command line utility, but it isn't and does in fact have a "choose and select" structure to it.


It may fix your problem.


http://www.cgsecurit...g/wiki/TestDisk (Open Source)


TestDisk Step By Step: (With screenshots)


There's also "MiniTool Partition Wizard Home Edition 7.0" (Free) which may also be able to check and fix the file system on your USB, although I don't have personal experience of working on a flash drive with it.




Worth a look being free.


I would give Test Disk a shot first, and if you have any problems with it, come back and we'll try and assist.

Link to comment
Share on other sites

  • Moderators

Can we confirm what you did and which options you chose?


After choosing to have a log or not, did your USB drive appear as mine does here ...




If it did, did you choose the correct Table Type as shown here ...




And if you got that far did you try to re-write the MBR, as shown here ...




If none of these, did you try some other option, or is your USB drive not being picked up at all?


Going from the info in your first post, it does sound like the data on the drive is fine, but something has corrupted the boot sector.



EDIT: There's still MiniTools to try, but if TestDisk isn't picking up your drive, MiniTools may have the same issue.

Edited by DennisD
Link to comment
Share on other sites

All 7 partitions disappeared from my Laptop.

My operating system was no more.


Before I used my Partition Image Restore Boot CD which covered my vital things like C:\

I took the opportunity to see what MiniTools Boot CD could do.


First it told me the HDD was entirely unallocated space.

Then I launched its Partition Restore Wizard and it scanned my empty drive.

After less than one hour it had presented a list showing the start and finish boundaries of perhaps 20 partitions

( I never had more than 7 at a time but I had shifted and shrunk/expanded over the years )

I proposed the likely boundaries and it showed my the partition labels by which they had been known.


when I was happy I hit the APPLY button and a few minutes it was all restored.

No problems with the NTFS partitions.

Out of two FAT32 partitions one was good,

but on the initial Boot up Windows told me the second FAT32 was corrupt, and I accepted its offer to run chkdsk.

I vaguely recall chkdsk reported a larger than normal quantity of problems on that partition,

but I do not remember any significant damage to any files.


I see no reason why Minitool would fail to resurrect your external drive.


You can get both the Windows version and an ISO download for the Boot CD for a dead system from




My experience was with Partition Wizard 5.0 or there about.

It has been updated now to version 7 with the prefix Minitool.

I am confident the latest version will always restore normality for me,

and perhaps Microsoft recognises my immunity against disaster so it no longer takes away my partitions :)

Link to comment
Share on other sites

In Test Disk my USB drive to show as Drive G: SanDisk Cruzer


I selected it and chose Intel /PC Partition


I then chose Analyze and received the message Partition sector doesn't have the endmark 0xAA55


I said ok and it began to analyze. During the phase it gave messages Read error xx/48/1 <lbq=xxxxx> (the x's equal changing values as they did change alot while this ran)


After Analyze was finished I received the following information


Drive G: - 100 MB / 95 MiB - CHS 23 64 32

Partition Start End Size in sectors


Keys A: add partition, L: load backup, Enter: to continue


At this point I chose to continue and this is where I get the message "No partition found or selected for recovery"


I also went through and tried to write new MBR code but the message said it cannot write new code. I don't know if I should be adding a partition, loading backup or ??? As I stated in the original post, I am not a computer whiz but I am willing to try with guidance. I do appreciate all the help so far.

Link to comment
Share on other sites

  • Moderators

Rob, a few posts went missing due to an Invision Board server glitch but thankfully Alan managed to retrieve one of mine, and hopefully his own as there were a couple of good links in his.


Re-post of one of mine ...


Hi Rob.


Sorry for the delay but I'm away from home at the moment.


Have a look at the first example of using TestDisk here ...




It appears to be your problem exactly. See if you can do anything with the suggested fix below the 2nd hatched window.


I'll get back to this when I get back home, and in the meantime if any of the other guys can help, I'm sure they will.


I'll re-post my other if and when I find the link I used. Not bookmarked as I wasn't in front of my own computer at the time.

Link to comment
Share on other sites

  • Moderators



In Alan's missing post, he highlighted the fact that you have a Sandisk Cruzer which may contain U3 software.


I don't know whether that would make a difference to a repair or not, so without knowing whether you still have the original U3 installation or not, or whether it would make a difference, I'll assume no to both questions for now, and link you to another fix of a corrupt bootsector with "TestDisk".




Scroll down to "Addendum" in the above post.


Hopefully, Alan will be able to re-post his missing links.

Link to comment
Share on other sites

Ok, apparently the forums were down because I couldn't access them for a couple of days. Anyway, I tried following the suggestion from DennisD and did not have the option to either BackUp BS or Rebuild BS. The only option pertain to the Boot Sector is Write TestDisk MBR code to Boot Sector. I don't know if that is the same thing so I did not do it.


I also looked at the neosmart site and the "Addendum". Once I select "Advanced" I get the message "No partition available".


I'll be going to the Sandisk support site to see if they can offer any help but if someone here has other suggestions or can tell me I'm not doing something or am doing something wrong I'd appreciate it.

Link to comment
Share on other sites

  • Moderators

There's other software to try besides "TestDisk", and all free so probably worth the effort.


MiniTool Partition Wizard, mentioned and linked to in posts 2 and 5.


Are you doing something wrong?


I wish I could answer that Rob, but our problem is that unless we've personally suffered a similar problem, or deliberately corrupt one of our own flash drives to test, we can only suggest fixes which we know have worked for other people with the same problem, using the software we suggest.


Without your computer and flash drive in front of us, it's difficult to work out what, if anything, you may be doing wrong.


If you don't get anything positive from the Sandisk forums, please post back and we'll go down the road of trying to get the data off the drive instead of trying to repair the bootsector,


That data will probably be recognized by Windows as "Raw", and not everything can recover raw data, but it is possible.


Sorry I can't give you anything more positive at the moment.

Link to comment
Share on other sites

DennisD, don't apologize. You've been more than helpful and patient. I came here truly believing it was hopeless but your suggestions tell me otherwise. I am going to pursue this for no other reason than you believe it is possible to recover the data. I can't thank you enough for the encouragement.



Link to comment
Share on other sites

  • Moderators

Damn, that's disappointing but no worries as we have other options, and toward that end I've been researching "TestDisk", as contrary to it's looks, it's a very powerful tool provided you know how to use it.


Learning how to use it has been the object of the research. Apart from hopefully getting your data back, the research has been beneficial to me for future use.


I'll get back here with some instructions and screenshots once I've put them together.


You didn't say how big your SanDisk is, but for the first option, you'll need to have sufficient free space on the drive on which you have the TestDisk folder to more than cover the size of that flash drive.


I'm guessing 8gb.

Link to comment
Share on other sites

  • Moderators

The idea here Rob is to create a "Disk Image" file of your flash drive with TestDisk, which can then be accessed and extracted from in a way you can't access your corrupt drive directly.


If TestDisk recognizes and lists your drive, then I can't see why this won't work.


Other programs which do this "Image" creation of a corrupt drive can need more than the size of the drive in free space as they copy the entire drive to the "Image" file.


TestDisk doesn't appear to do this, although I've only got my own test to go by. My 1gb flash drive produced a 230mb file, but until we know, more space than you may need is the wisest option for now.


You probably don't need all the screenshots Rob, but as a fan of Confucius, I use them to save long winded explanations (at which I can excel), and to make it easier for any one else with a similar problem to follow.


1: Select drive.




2: Select type.




3: Select "Advanced".




4: Select "Image Creation".




5: Choose and confirm yes to Image Creation Directory. (The default appears to be the TestDisk "win" folder)




6: Image being created.




7: Newly created TestDisk "image.dd" file.




8: Rename "image.dd" to "image.img" (no quotes).




We now need to extract files from the "image.img" file, and you can do this with 7-Zip (or your own program if it can extract from an Image). Download the portable version from here ...




Double click the downloaded file and follow the dialogue to install it to a folder/location of your choice. (A portable install).


You can either open 7-Zip and browse to the Image file, or open 7-Zip and go to "Tools\Options\7-Zip tab" and add 7_Zip to the right click context menu, which IMHO is the best option for future use.


It can easily be removed if you choose to.


9: Using context menu, right click the "image.img" file and select "7-Zip ....Extract to *image/*", which will extract all files within the Image to a folder called "image" in the same location.




10: You should now have a folder named "image" containing the extracted files.




I hope this all works out as above Rob, and you get your data back, but if not we'll try a different option.


Good luck.

Link to comment
Share on other sites

Dennis, Just for future reference, I'm trying to retrieve data from a 16gb flash drive.


Anyway, I got to step 3 and selected Advanced. Test Disk tells me there is no partition available, so I can't proceed to the next step. While I readily admit to not being a computer whiz at all it appears that whatever partitions were on the drive and now gone.

Link to comment
Share on other sites

I have no knowledge of Test Disk,

and Dennis may know of some other facility provided by TestDisk.


Partition Wizard can run under Windows and show you where the boundaries of the partition(s) were and you can select and resurrect, complete with files.

That is true when there is no U3 complication.

It would be advisable to contact Tech-Support to see if you need take special actions with U3.

As a free user I generally get 24 hour response to emails.


Contact details



Download Free Home edition P.W. from



I have no experience of this, but this is from the same people and is dedicated to recovery



Free Partition Recovery Software, Free Active Partition Recovery Software, Free Disk Partition Recovery Tool,Free NTFS Partition Recovery Tool,

Recovery Partition, Hard Disk Recovery, Drive Partition Recovery, Deleted Partition Recovery, Hard Drive Partition Recovery Tool.

Support FAT12, FAT16, FAT32, VFAT, NTFS, NTFS5 and Windows 2000 Professional/XP/Vista/Window 7 and so on.


Several more useful utilities from the same company at


Link to comment
Share on other sites

  • Moderators

That was quick and quite definitive Rob, and sadly if you can't get past stage 3 above, that nullifies other options.


The issue seems to be that the partition information does not match the boot code, and I know what a problem that is now.


My 1gb flash drive a couple of hours ago ...


Disk_Bad.jpg | Partition_Table_error.jpg


So I now had a flash drive in front of me which was sometimes shutting down Windows Explorer when I clicked on it, and no matter what options I tried in TestDisk, I couldn't get it to work, and I got well past stage 3.


Alans post above brings me to where I was going next, almost. A slight change of plan


I was gonna go to the suggestion I made in post #2 above, and that is to try "MiniTool Partition Wizard Home Edition 7.0" (Free), which fixed my flash drive earlier tonight, and made it possible to recover almost 300 files from it. (Which I didn't want, but it was an enlightening exercise).


Most of the files had been deleted months ago, and the flash drive had been formatted a number of times to get rid of large linux installs.


But we'll leave this as a last option as I would like you to go with Alan's suggestion above, and that is to download and try "MiniTool Partition Recovery version 5", the third link in his post linked to again here.


It's a very straightforward application, not a big install, and you'll soon find out as to whether or not it will work for you as it only takes a couple of the wizard screens to ascertain as to whether you have any lost partitions to recover. Although your drive is corrupt, it may not be deemed as lost.


Give it a try and then post back your findings. I'll hold back on my experience with "MiniTool Partition Wizard Home Edition 7.0" until then.


And thanks for your welcome contributions Alan.

Link to comment
Share on other sites

I downloaded MiniTool Partition Recovery, installed and ran it to no avail. No partition or data is shown once the scan is complete. I did notice a MiniTool Power Data Recovery Tool from the same site that looked like it would recover the data of a lost partition, unfortunately it found nothing as well.


So, once again, I'm back to step one.

Link to comment
Share on other sites

Hi Hazelnut, I'm trying to recover data from a SanDisk Cruzer 16GB Flash Drive. The computer I have been using it on is an HP running Windows XP. I don't think I've mentioned that part before so you're question could very well be valid, I have no idea as I am definitely not a computer whiz. Anyway, I'd like to extend thanks to any and all that have offered suggestions and advice so far. I do appreciate it all.

Link to comment
Share on other sites

  • Moderators



I'm not ignoring your suggestions hazel, they're good questions I didn't ask and worth trying.




I'm trying out a little utility Rob which may be able to correct your drive, but before I post it I'm doing some testing. Don't want to jump straight in until I'm sure of what it does, and how.


I'm hoping you're not too fed up yet because as long as you still in there I'm not giving up. Besides this clever tool, there are still options we haven't explored.


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.