Jump to content
CCleaner Community Forums

"Defragmenting (0%)" forever


Recommended Posts

I resized my system partition (primary, E: is assigned), and after that Defraggler v1.20 is not able to defragment it (though it was successful before).

It just moves reading square (the yellow one) from the right bottom corner, and keeps the writing square (the green one) in the right top corner.

It also says "Defragmenting (0%)" even after several hours of working.

It crashed once in such state.

Luckily no data loss occurred :)

 

I've added "E:\System Volume Information" to the exclude list (as was proposed in http://forum.piriform.com/index.php?showtopic=28761), but it has no effect.

 

The size of the partition 30.9 GB, free space 3.2 GB.

Fragmentation: 29%

OS: Windows XP Pro SP2

post-38970-128022101756_thumb.png

Defraggler.exe.1_20_2012010-07-27_12-01-WithSystemVolumeInformationExcluded.zip

Defraggler.exe.1_20_2012010-07-27_12-31-NoEcxludeDirs.zip

Link to post
Share on other sites
  • Moderators

Hi Anton, and welcome to the forum.

 

I'm wondering if you are on the borderline of having sufficient free space left to carry out a defrag. The required amount is usually stated as about 12% of the drive size.

 

If you have some big files on that drive, Defraggler may not be able to find sufficient space to defrag them. Even though you've added System Volume Information to the exclude list, it's still taking up the drive space it sits on.

 

Do you have sufficient Restore Points to maybe delete all but the last one with Windows "Disk Cleanup", to free up some space.

Link to post
Share on other sites

I'm wondering if you are on the borderline of having sufficient free space left to carry out a defrag. The required amount is usually stated as about 12% of the drive size.

 

Dennis,

thanks for the hint.

 

It could be so that I had a lot of large files on the drive and too small free space.

 

However today I've ran into the same problem on another drive, which has 34,5 GB free (25%) and only 15,7 GB in 13460 Fragmented Files.

Defraggler seems to stuck at writing (trying to write?) something to the first sector, while reading from other sectors chaotically.

 

I've disabled System Restore for this drive, but this change doesn't have any effect.

Link to post
Share on other sites
  • Moderators

I don't know enough about the technicalities of defragging Anton to give you anything positive, but your debug logs will help the devs, and they do read these threads.

Link to post
Share on other sites
  • 4 weeks later...

If you access the "File list" can you defrag files individually (preferable the smaller ones)??

 

Yes, I'm usually able to defragment files by selecting the whole directory with them (it doesn't work in some cases though).

Defragmenting single file (I checked this only with few of them) is also possible.

 

BTW same issue still occurs in the new version 1.21.209 :(

Edited by AntonK
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...