Jump to content
CCleaner Community Forums

ccleaner stops usb mass storage devices working

Recommended Posts

I have a Medion Computer md8351 with usb3 capability, before using ccleaner everything is fine but after I use ccleaner all my usb mass storage devices stop working, Device manager shows error:-

(Windows cannot verify the digital signature for the drivers required for this device. A recent hardware or software change might have installed a file that is signed incorrectly or damaged, or that might be malicious software from an unknown source. (Code 52)


for all mass storage devices these include internal card reader, usb hard drive, memory sticks and usb printer with built in card reader (in otherwords all possible usb mass storage device plugged into any of the usb ports and internally to the computer. Any non mass storage devices continue to work fine.


I have used ccleaner for many years on many computers (I maintain computers for all my family) and have never had any problems before.


I have system restored computer many times in trying to locate exactly what is causing the problem and it definately only starts to occur once ccleaner has been run.


This is not a complaint but a request that maybe you can solve the problem as I find ccleaner a valuable tool in maintaining and fixing other computers and would like to be able to use it on this one in the future.

Link to post
Share on other sites
  • Moderators

Julian can you say which operating system you have.


Also what build of ccleaner.


Are you doing a registry clean? (issues)


What security software do you have installed?

Link to post
Share on other sites

Windows 7 Home Premium


ccleaner build 3.07.1457 but has been happening with all the versions since February when I got the computer, I always use the latest ccleaner, (that is how long it has taken me to pinpoint this to purely a problem with ccleaner, at first I thought it might be a fault in the manufacturers driver software)


Yes a normal (no advanced options) registry clean, no issues before doing it, just to try and improve performance of the computer.


security software on my computer Norton 360 but problem also occuring on my sisters computer same make and model but she uses microsoft security essentials.

Link to post
Share on other sites
  • Moderators

Hi Julian, and welcome to the forum.


If anything I would suspect running the registry cleaner would be the chief suspect, but before trying to eliminate different sections of the issues scan, have you tried any of the suggestions which can be found online to fix a "Code 52" error?


It may be something as simple as the fix found in the link below, which is also Windows 7 Home Premium ...


I found the answer through searching other sites, it's probably here somewhere as well. Reboot the computer. Press 'F8' during restart. Select Disable Driver Signature Enforcement from the boot menu. This fixed the driver issue in my case.


Windows cannot verify the digital signature for the drivers required for this device:


This solution pops up a number of times in similar "Code 52" problems apparently not involving any prior registry cleaning, and may be worth a try before going through an elimination process with CCleaner.

Link to post
Share on other sites

yes tried all the usual things I have been using computers for 25 years and other people usually come to me for problems like this.


Before running ccleaner everything is fine, it is not a case of a new unsigned driver as in the case you point too but I have tried that solution too though with no success


The solution you point too is for only 1 device not working in my case it is all the usb mass storage devices internal and external no matter which usb port is used.


It is as if ccleaner alters or deletes an entry which has something to do with mass storage control or activation in my case.


I have searched a lot of forums for this problem and apart from some in 2009 from people using windows 7 beta test version (which were solved by the official win 7 release) I have found a few posts since march this year of people getting a similar problem on various model computers and no working solutions. The only thing that seems consistant in all these cases is that the computers all have USB3.



Also it is pointing towards ccleaner as being the problem as if I restore the computer to a restore point before running ccleaner everything works fine for as long as I want and the problem does not reoccur until ccleaner is run again.

Link to post
Share on other sites
  • Moderators

Hi Julian.


Hazel may have some different suggestions, but I can't see it being caused by the temp file cleaning, so it can only be a case of elimination with the "Issues" scan and clean, unless something pops up in a registry scan which has obvious ties to your problem.


Firstly, instead of doing a full System Restore, assuming that you do follow the CCleaner dialogue and make a backup of the registry entries removed, have you tried restoring the backup registry file as a much quicker and less invasive fix?


To solve your problem, I think it will have to be a case of unchecking all the registry scan check boxes, and then activating them one at a time and scanning and cleaning with each one. Eventually, the guilty party should become evident.


A pain in the backside, but unless a scan shows up something obvious, which can be easily excluded, I can't see any other way.


If any of the other members are using Windows 7 Home Premium and USB3, then I'm sure they'll contribute any similar experience and possible solution.


Got nothing else positive for now I'm afraid.

Link to post
Share on other sites
  • Moderators

Julian are you using 32 or 64bit?


I would go for unticking each reg entry as Dennis suggested.


Perhaps ccleaner is 'cleaning' the signing keys in your case in a reg clean, although I don't know how you could test this apart from painfully slow unticking everybox and reticking them one by one.


If however you found a cause using this method I'm sure everyone would be grateful :)


This guy here mentions code 52 and usb ports not working for ALL ports, however he doesn't specifically mention usb 3.




Keep in touch with any other info you can think of.

Link to post
Share on other sites
  • Bug Fixers

Can you please let us know the set of actions you do with CCleaner in order to reproduce the problem?

Do you clean anything with CCleaner? If so, please let us know what is being cleaned.


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...