Jump to content

Wildcard within Path in File Includer


Recommended Posts

I have a folder structure that is as follows

C:\Workspace\src\ModuleA\bin
C:\Workspace\src\ModuleB\bin
C:\Workspace\src\ModuleC\bin
...

I want all these bin Folders within all modules to be scrubbed by a custom clean. I thought that I could add a line to the .ini with

Include1=PATH|C:\Workspace\src\*\bin\|*.*|REMOVESELF|0|0|24

to delete all the bin folders. But this does not work for some reason. Looking at other threads about wildcards, most of them were either at the end of the path or the answer referred to the winapp2 project.

Therefore the question: Is this feature just not supported? Or did I do something wrong?

Link to comment
Share on other sites

  • Admin

I'm not able to reproduce this issue. I copied the precise configuration line that you have listed, namely:

  • Include1=PATH|C:\Workspace\src\*\bin\|*.*|REMOVESELF|0|0|24

into my CCleaner INI, and then created a folder structure exactly like you described with some temporary files that I could handle having deleted. 

I've attached an image showing how the Rule was interpreted by CCleaner, and then the Cleaning results produced; I also went and checked, and yes, the appropriate 'bin' folders and their contents were deleted (though not the other 'dummy' files I'd put into ModuleA, B, and C).

A couple of questions, then:

  • Are you using the most recent version of CCleaner? I recall that there was an issue of this sort quite a few years ago, so any reasonably recent version should be fine, but if you want to reproduce my setup, make sure to use 5.92.
  • Does the software have admin permissions? (You'll notice this listed near the bottom of each screenshot) If not, that could prevent it from being able to access the files/folders.
  • Make sure to use Custom Clean, as I believe Health Check does not follow Include Rules (though it will follow Exclude Rules).
  • Is there any chance that the files are in use by another program when you attempt to clean them? 
  • If all else fails, recreate the Rule via the Options > Includes interface (you should now have a template to use :) ) and see if that takes care of it?

binA.png

binB.png

Link to comment
Share on other sites

Posted (edited)

Yup, probably messed up the path somewhere. Tried the way you told me with basing the path from one existing folder and now its working. Albeit very slowly, as its ~30GB of dlls and obj files.

Edited by Brut
Link to comment
Share on other sites

  • Admin

I'm glad to hear it's working now, though I'm not surprised at all that it's taking a bit of time to work through that much data. :) 

Typos and the like can certainly happen, I'm just happy I could double-check this for you. Thanks for letting us know the good news, too.

Link to comment
Share on other sites

Well the "customer" support was very timely, so I guess its just fair for me to not keep you waiting as well.

Speaking of the much data problem: Will there ever be an option to simply delete the folders entirely instead of going through every file and deleting them on their own? If I would do the scrubbing work through the file explorer I would take a whole while selecting all the folders, but the deletion process goes way quicker (in terms of: 30 sec vs 30 min)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.