Jump to content

Recuva Installer tries to install on non-existent drive L:


Recommended Posts

I tried to recover a lost video from a new XQD card. My old verson didn't find a video on my card after deep search of 40min.

Then I tried to install the upgrade V.1.5.3.. After I downloaded and started the installation file rcsetup153.exe it showed the start window. After clicking on the "install" button it stopped with the error message that it's not possible to install on drive L:.

See attached screenshot.

Of course I haven't a drive L:

I tried the same with the installer of the earlier version rcsetup152.exe with the same result.

I have Windows 10 home actualized to version 1909.

Please tell me how to circumvent the installer problem.




Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.