Jump to content

USB drive recover not working


Recommended Posts

I tried to make my usb-memory bootable (8GB Flash Voyager) and now all files and everything disappeared. I replaced my boot sector with one from a diskette and it changed from FAT32 to FAT12 and now I try to recover the files, but the drive is not a choice in Recuva. It appears in Explorer, but Windows doesn't recognize it and wants to format it, which I haven't chosen to do yet. I guess most should be recoverable since I only replaced the 512byte in the boot sector? Any ideas or is Recuva not a program for this scenario? Will it be?


I tried another program as well, Active UnDelete, and it found the drive and after 14h advanced scanning it found some files, but only in the boot partition (FAT1 of FAT2) and not in my data partition. And nothing happened when I tried to choose FAT2 in the list as well. :(


Any ideas? Would be nice if Recuve could find these problems as well. Any debug information you want me to provide to help out?


Vista 32-bit, running Recuva 1.04.104 elevated.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.