Jump to content
CCleaner Community Forums
Nurick

DAT icons changed to Windows Media Player

Recommended Posts

I just recently started using ccleaner and think it's great. But tonight I noticed that all the .dat files on my XP pc now showed a Windows Media Player icon. The files weren't actually associated with WMP, i.e., double-clicking on one would produce the "what would you like to use to open this" dialog; and the File Associations section of Explorer had no entry for .dat.

 

I did a bit of Googling and learned that this is a common problem, and one many people have a lot of trouble solving. I tried a few things which didn't help, and had a somewhat more complex solution to try next, when it struck me that I had run ccleaner for the first time a few nights ago.

 

I restored the registry using the ccleaner backup I had created, and sure enough the .dat icons reverted from the WMP logo back to the typical "generic" Windows icon. (Ironically, several of the posts I found about the .dat-to-WMP issue had said things along the lines of, "any good registry cleaner should identify the source of the problem and fix it.")

 

Out of curiosity I ran ccleaner again, and found that the problem was in the "Unused File Extensions" option in ccleaner. Sure enough, ccleaner lists .dat among the many unused extensions, and the "fix" message says, "The file extension .dat references an invalid program identifier. These are often left behind after uninstalling software. Solution: Delete the registry value."

 

Well, obviously in this case that's not a "solution"! .dat files may not identify a program, but they are certainly "used"! Perhaps an advanced user should have known this right away, but still I think it would be useful for ccleaner to add something along the lines of, "unless you are sure this extension is not used for any purpose, do not proceed with this fix". Other extensions listed by ccleaner as deletable included .tmp; .bak; .regkey; .ax (used for video codecs, I believe), and dozens of others.

 

It's still a mystery to me why deleting the .dat extenstion from the registy made the .dat icon turn into a WMP icon. But I'm wagering that lots of folks who have encountered this "annoyance" did so after using a registry cleaner (not necessarily ccleaner). I can't possibly be the first person to encounter this from ccleaner, especially since I see that the same thing happened on my other pc, where I installed and ran ccleaner at about the same time. However, I couldn't find any posts about this during a brief (likely TOO brief!) search through this forum.

 

As much as I like and appreciate ccleaner, I won't be using the Unused File Extensions portion of the registry cleaner any more!

Share this post


Link to post
Share on other sites

Out of curiosity I ran ccleaner again, and found that the problem was in the "Unused File Extensions" option in ccleaner. Sure enough, ccleaner lists .dat among the many unused extensions, and the "fix" message says, "The file extension .dat references an invalid program identifier. These are often left behind after uninstalling software. Solution: Delete the registry value."

 

Well, obviously in this case that's not a "solution"! .dat files may not identify a program, but they are certainly "used"! Perhaps an advanced user should have known this right away, but still I think it would be useful for ccleaner to add something along the lines of, "unless you are sure this extension is not used for any purpose, do not proceed with this fix". Other extensions listed by ccleaner as deletable included .tmp; .bak; .regkey; .ax (used for video codecs, I believe), and dozens of others.

I don't think its quite as straightforward as that. If I click on a file such as a dat file that gives the Windows message 'Windows cannot open this file' (or whatever it says), then the next time I run CCleaners issues scan it picks it up as an unused file extension and I've always let it delete these without any problem (in 2 years of using the program). I've just done it now to double check and the icon doesn't change.

Obviously if restoring the backup of that particular issue fixes the problem it must be related but there must be some other contributing factor going on, unfortunately I'm not sure what but hopefully someone else will have some ideas :unsure:

Share this post


Link to post
Share on other sites

Interesting! What's curious is that the same thing occurred on both of my pc's. Of course, I've set them to share many of the same general preferences, e.g. via TweakUI and much more. So maybe that explains why whatever caused the .dat/WMP icon issue did so on both of my pc's. But yes, I wonder if anyone has insight into what that "whatever" might be...or if anyone else has experienced a similar issue. Maybe whatever causes .dat files to change to the WMP icon for many others -- as evidenced by my aforementioned Google search unrelated to ccleaner -- somehow was "triggered" by ccleaner in my case. I do remember that I had a similar issue pop up about a year ago, before I had ever heard of ccleaner. I think I fixed it through some "trickery" in the file associations dialog accessible through Windows Explorer.

Share this post


Link to post
Share on other sites

In some media players .dat can also be a MPEG Media File, so if you've switched players that could be the reason why the icon has changed, etc.

 

You "may be able to change the icon" by editing the registry and looking for dat or datfile, it could possibly be under something else as well. If you do make sure you first make a System Restore Point and/or an ERUNT registry backup to restore the registry if something goes wrong.

Share this post


Link to post
Share on other sites

Windows relates to the three letter extension and associates the extension with one program. It can not distinguish .dat files from different programs because they all have the same extension. Another fix could be to goto "WINDOWS EXPLORER" (NOT Internet Explorer) and click tools-> folder options->file types. Scroll down to the extension you want and change "open with" if desired. The three letter extension is being modified to include four letter extensions in Microsoft Office 2007 (see http://filext.com/ and http://www.fileinfo.net/)

Share this post


Link to post
Share on other sites

Happened to me last year after installing a Sony DVD burner and the Nero OEM software that came with it. All the icons for .dat files turned into the little green one associated with some other application, Nero I think. Couldn't fix it, everything worked OK, so just ignored it until the next time I redid the hard drive.

 

Happened again when I installed Arcsoft PhotoStudio. Right now, the icon is the one for ArcSoft, but they open with the windows picture and fax viewer unless I select a different one.

Share this post


Link to post
Share on other sites

All .dat files on my system were associated with K-Lite Mega Codec Pack until I uninstalled it, and then they all went to PowerDVD which calls .dat files VideoCD files. Although I've never personally had any MPEG video files wrapped into a .dat before.

Share this post


Link to post
Share on other sites

Just wanted to thank those who have provided ideas and suggested fixes -- although I don't really need fixes. I took care of the issue (which was really just a minor annoyance anyway) easily by restoring the registry with the ccleaner backup, and then unchecking the Unused File Extensions Options before doing any further registry work with ccleaner.

 

BTW, when I had the same issue a year or two ago, unrelated to ccleaner, I believe I did the following to resolve it: First, I checked to ensure .dat was not listed in the File Associations table, which is accessible via Windows Explorer/Options as well as other routes. (If .dat HAD been listed -- presumably with a Windows Media Icon -- I think the issue would have been resolvable by simply removing the entry for .dat.) Then I went to a .dat file, double-clicked it and chose notepad as the program to open it with, ticking "always use this program to open this type of file." This gave all the .dat icon files a notepad icon (and of course made them readable as text by simply double clicking...maybe not such a bad thing). Then I went back to File Associations, and removed the entry for .dat which now appeared there (with a notepad icon).

 

CAUTION in case anyone ever runs across this and attempts to solve a similar problem the same way: I believe this is an accurate accounting of what happened, but I can't be *positive* my menory is 100% correct and complete on this.

Share this post


Link to post
Share on other sites

Hi,

 

I battled with this problem for weeks last year. CCleaner has never caused it, in fact, it may even have helped avoid it. The issue resolved itself following a WMP Security Update last summer.

 

When I suddenly noticed a few days ago that the .DAT files were again appearing with WMP icons, I re-installed WMP 10, and I think -- at least so far, that has done the trick.

 

Pesche

Share this post


Link to post
Share on other sites
Hi,

 

I battled with this problem for weeks last year. CCleaner has never caused it, in fact, it may even have helped avoid it. The issue resolved itself following a WMP Security Update last summer.

 

When I suddenly noticed a few days ago that the .DAT files were again appearing with WMP icons, I re-installed WMP 10, and I think -- at least so far, that has done the trick.

 

Pesche

 

I'm contemplating rolling back to WMP 10 also. Did you encounter any problems doing this? I just don't like WMP 11.

Share this post


Link to post
Share on other sites
I'm contemplating rolling back to WMP 10 also. Did you encounter any problems doing this? I just don't like WMP 11.

 

I haven't actually ever upgraded to WMP 11, because the reviews weren't too complimentary. But during the .DAT extension issue phase I briefly rolled back to WMP 9 at one stage, and that seemed to be fine.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...