Jump to content
CCleaner Community Forums

Windows cannot start the Windows Firewall/ICS service.


occam

Recommended Posts

This is the message I get after running a cleaning of the registry. I've tried all of the solutions on the Microsoft Knowledge Base website, and nothing is working. It's giving me an Error 5, which is something to do about permissions. I've checked that my account is still an administrator, and it is, so I'm not entirely sure what else there is to do. I'm hoping that someone has come across this problem as well and can point me in the right direction! Here's the message I get when I attempt to start the SharedAccess service (the service that controls the Windows Firewall/ICS service):

 

"Windows cannot start the Windows Firewall/Internet Connection Sharing (ICS) service."

 

Thanks for any help,

 

Occam

Link to post
Share on other sites
  • Moderators

First make a System Restore Point and then you could try out Dial-a-fix (the link is located below in my signature). In Dial-a-fix you'd click:

1. Tools (it's the small hammer icon).

2. Highlight Reinstall Windows Firewall.

 

Note: I have no idea if this will actually fix it or not, hence the reason to make a Restore point first. Dial-a-fix states 'Windows Firewall' which is in Service Pack 2.

 

Since the firewall is disabled on your system it could be related to a malware infection, and I'd recommend posting a HijackThis log after reading the information located in the Malware Removal Guide.

Link to post
Share on other sites
  • 11 months later...

It finally works!!! But you have to run "Reinstall WMI/WBEM", maybe also "Repair permission" first, just "Reinstall Windows Firewall" did not do it alone.

 

So, for everybody who is struggling for days to get rid of the message

"Windows cannot start the Windows Firewall/Internet Connection Sharing (ICS) service."

 

The solution is:

1. run the software "Dial-a-fix"

2. click the little hammer "tools"

3. Run "Repair Permissions" (I don't know whether this step is needed)

4. run "Reinstall WMI/WBEM" (I don't know whether this step is needed) but one of the steps 3 or 4 is needed, maybe both

5. run "Reinstall Windows Firewall"

 

That is it!

 

My problem was actually that I couln't ping my virtual guest (Virtualbox XP on XP host), then I found that I couln't configure my firewall, it was actually not running I believe, but the system was not responding pings.

 

Thanks to DjLizard (Michael Cooke)

 

You saved me days, God bless you. I know each internet site with steps out of this problem, none worked on my system.

 

 

First make a System Restore Point and then you could try out Dial-a-fix (the link is located below in my signature). In Dial-a-fix you'd click:

1. Tools (it's the small hammer icon).

2. Highlight Reinstall Windows Firewall.

 

Note: I have no idea if this will actually fix it or not, hence the reason to make a Restore point first. Dial-a-fix states 'Windows Firewall' which is in Service Pack 2.

 

Since the firewall is disabled on your system it could be related to a malware infection, and I'd recommend posting a HijackThis log after reading the information located in the Malware Removal Guide.

Link to post
Share on other sites

By the way, if missing files are requested when reinstalling Windows parts, just download and unpack XP SP2 (for instance with winrar) and search for those files in th i386 folder. All other files should be in your original i386 folder which can be located in your %windir% or somwhere else (recovery partition, c:\ ...)

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...