Jump to content
CCleaner Community Forums
Jamex

Drive Problem

Recommended Posts

I have a problem with my portable drive, but i dont know how to fix it. i think i have a driver issue. i know by usb connection isnt broken or anything, because other drives like my friends external drive still works in em, i also know that my drive works still because it works in other computers. here's the problem. it never needed anything to be installed before to work on ym comp, and i can just plug it into any random comp and itll work, but when i plug it into my comp, it says that i need new drivers, and when i throw in the little disk (which i think is corrupted somehow), or search online, it never works. every link i can find seems to be dead. here's another point which i think might have something to do with my problem. whenever i try to plug in my portable drive with someone else who has an external drive, i wont work. and in some cases i just have to unplug it and itll work, but in others, depending on the external, my portable will never work on that comp. weird. and i mentioned before that my friends external works on my comp. ... so maybe if i were able to locate the drivers from his drive which might be conflicting with mine... this is way out on a limb here and i have no idea if im going in the right direction, please respond with some suggestions, if im in the right direction or not, if you need the model number of my drive or my friends external, etc.

thanx

Share this post


Link to post
Share on other sites

You dont say which operating system you are using on your PC.

 

Windows XP does not require special drivers for USB externals older systems do. That may explain why it works on some PC's and not others. What external drive is it and have you contacted the maker or your supplier for a new driver.

Share this post


Link to post
Share on other sites

You dont say which operating system you are using on your PC.

 

Windows XP does not require special drivers for USB externals older systems do. That may explain why it works on some PC's and not others. What external drive is it and have you contacted the maker or your supplier for a new driver.

 

 

I am using windows xp, and my external model is HY2501-2.5" USB2.0

"http://www.fieondigital.com/product_detail.asp?productId=1261&type=&bc=98&sc=133"

but it used to work, and now it doesnt. I have gone onto the website, and used the contact support system, but havent gotten a reply there. Also the driver is available on the site, but the link doesnt work, and ive tried 2 different browsers. My concern is that my friends external but some sort of conflicting driver on my comp, i donno, because it worked fine before he plugged in his external, and my external works on other comps also.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...