Jump to content

CCleaner will no longer start on early 2013 mac


Recommended Posts

I have used CCleaner for many years on my 27" early 2013 Mac running OS 10.15.7. When I tried to download the update to the latest CCleaner version 2.* it will only install ver. 1.13, and then it will not start up. I have tried uninstalling, reinstalling, cleaned all cache, cookies, and other items, but the program just will not start up. No message is given as to why it won't start up. I know that I need a newer Mac but I do not like the newest version with a separate Mac Studio and Studio Display. Is there a way to get an earlier version of CCleaner that might work? Thanks for any help.

Mike

Edited by MtnMike787
Grammer
Link to comment
Share on other sites

  • Admin

You can try downloading the latest version prior to version 2.X here: https://download.ccleaner.com/mac/CCMacSetup118.dmg and see if that works better on your system.

Make sure, of course, not to accept any update and to turn off any update functionality in the software so it doesn't update to version 2.X when using this version.

You're also welcome to get in contact with our support team via the Contact Us form located here: https://support.piriform.com/hc/en-us/requests/new?ticket_form_id=86507 or by emailing support@ccleaner.com directly; we'll be happy to help look for logs and the like which might help shed light on this issue.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.