Jump to content

Getting "Unable to create file or directory" message


Recommended Posts

I'm trying to recover a BUNCH of jpgs/videos from an NTFS external drive (2TB USB)

I ran Recuva with deep scan enabled, and after about 65 hours, it said it found 206,000 files.  I plugged in a 250 GB FAT32 drive (empty) and started copying.

It said there were 160,000 that were "not recovered", and the "Reason" for each was "The directory or file cannot be created"

All of the files had a state of "Excellent", with no overwritten clusters.  Most had lost their folder (they came back as "F:\?\"), and I told Recuva to rename if it ran into duplicated names.

I tried several times, with slightly different results each time, but it's getting about 4.7 GB / 27,000 recovered (once, it managed 25 GB / 35,000).  The last shot at recovery ran 46 hours, so it apparently took a while each time it failed.

The lifeboat drive (G:) is nowhere near full, and I'm restoring them into "G:\From Unknown Folder\".  The files it couldn't recover ranged in size from 20 BYTES (easily fitting in a cluster) to 270 MB (videos).

What could be causing the "The Directory or file cannot be created" message?  Do I need to try another lifeboat drive formatted as NTFS?

Link to comment
Share on other sites

  • Moderators

If you are recovering a lot of files with no identifiable folder then they will all go into one default directory. The max directory size in FAT32 is 65536 entries, and one file will require a minimum of two entries. This may be the cause of your problem.

Furthermore FAT directory entries are not held in sequence, so for each file added the entire directory has to be scanned to avoid duplicates,  which takes time. FAT is probably not the best choice for large recoveries.

Is recovering from a 2 tb drive onto a 250gb drive a little optimistic?

Link to comment
Share on other sites

I had no idea that there was a limit if 64K directory entries.  I assumed that a long directory could hold as many as needed (I know that some versions of DOS/FAT required a fixed-size root directory, but I didn't realize there was a limit on non-root directories).  I suspect it goes back to having used an uint_16 to count the number of files.

I now have the files restoring to an NTFS drive, and it seems to be working.  Based on the 64K limit, the number of 8.3 and LFN entries for the number of files it WAS able to recover when I attempted to use a FAT32 drive seems to add up.

As for the size of the drive, I don't think there was anywhere near 2 TB ON the original drive, and I have four 320GB drives to recover them to.  They may very well even fit on one.

Thank you for pointing me in the right direction!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.