Jump to content
CCleaner Community Forums

Desktop Icons - Windows XP


Recommended Posts

Help, my desktop icons are all messed up!

 

Specifically, the transparency of the icons are messed up. They don't seem to be transparent

anymore. They almost look as if they are highlighted, but the icons are not selected in any way.

 

I'm not sure if this problem is directly or indirectly related to CCleaner, but

it happened after I installed and ran CCleaner v1.32.345 (default settings), then

rebooted my computer. Running Windows XP.

 

I've read to look at the My Computer -> Performance -> Settings -> Visual Effects ->

"Use drop shadows for icon labels on the desktop" option, but I've checked and unchecked

it, nothing has changed.

Link to post
Share on other sites

Yes, my desktop is set to 32-bits.

 

I have never had this problem before.

 

I've tried deleting the icons and creating the shortcuts again, but still, the icons

are not transparent. Tried resetting some desktop options, nothing is working so far.

Link to post
Share on other sites

There are a few reasons as to why you have desktop icons without transparency.

 

Your desktop background is a transparent or animated GIF image; you have placed Web content on the desktop; or you have chosen to lock Web content on the desktop. You can check for and correct all three in the Display Properties dialog, invoked by right-clicking on the desktop and choosing Properties.

 

  1. First click the Desktop tab, select one of the default Windows background images, and click Apply.
  2. Next, click the Customize Desktop button and click the Web tab in the resulting Desktop Items dialog box. If there are any checked items in the Web pages list, uncheck them. Also uncheck the Lock desktop items checkbox.
  3. Click OK, and OK again.

 

Your desktop icons should now have a transparent background for their labels, with a drop-shadow effect.

Link to post
Share on other sites
  • Moderators

I think it has something to do in the registry, however I could be wrong. You could try something like Microsoft Tweak UI, then in Tweak UI do the following:

1. Click Repair, select Rebuild Icons.

2. Click the Repair Now button. You may have to click it twice.

3. Reboot.

 

If that doesn't work start your computer in Safe Mode which will rebuild the icons at a lower resolution, and then reboot into Normal Mode to have them rebuilt again at a higher resolution.

 

EDIT:

DjLizard's Dial-a-Fix may actually be your best first choice. In Dial-a-Fix do the following:

1. Click Tools.

2. Highlight Flush Icons.

3. Click GO.

Link to post
Share on other sites

I think it has something to do in the registry, however I could be wrong. You could try something like Microsoft Tweak UI, then in Tweak UI do the following:

1. Click Repair, select Rebuild Icons.

2. Click the Repair Now button. You may have to click it twice.

3. Reboot.

 

If that doesn't work start your computer in Safe Mode which will rebuild the icons at a lower resolution, and then reboot into Normal Mode to have them rebuilt again at a higher resolution.

 

Windows XP has the ability to display desktop icon labels with a transparent background and drop-shadow effect. When you have a nice picture for a desktop background, this looks a lot better than having the labels backed by blocky rectangles of the default desktop color. Sometimes, though, even when you have the system configured to use drop shadows, you still get those ugly rectangles. This occurs when your configuration requires use of a feature called Active Desktop. In earlier versions of Windows, you could turn this feature on and off; in Windows XP, it's enabled automatically when needed. To turn it off, you need to find out why it got turned on. ;)

 

He's actually referring to the icon labels themselves; not the icons. I've seen this issue here on CCleaner before (but was unable to locate the old post).

Link to post
Share on other sites
  • Moderators

He's actually referring to the icon labels themselves; not the icons. I've seen this issue here on CCleaner before (but was unable to locate the old post).

 

Ahh, I'm thinking of something else then?

I have seen where some icon flushers namely RegSeeker remove the ability to have Alpha-blended icons display correctly.

Link to post
Share on other sites

Dial-a-fix also has a Flush Icons feature in the Tools section. Under it he has this information:

 

Use this tool if your desktop or shell icons have become corrupted.

 

NOTE: This will also reset the locations of all of the icons on your desktop.

 

There is no command-line or standalone equivalent to this tool.

Link to post
Share on other sites

Thanks for everyone's suggestions. I finally fixed my problem!

 

I went through Taun's 3 steps in post #4, but nothing has changed.

I then noticed under 'Display Properties', there is an option called 'Color'.

Whatever color this is, it is set to my desktop icon's caption text, which is

strange, because the desktop caption text used to be transparent before. There

was no color.

 

I then tried installing TweakUI, but I couldn't find where it was located.

Couldn't find in Control Panel either.

 

Last, I tried Dial-a-Fix, with its 'Flush Icons' tool, and nothing changed

either.

 

At this point, I went back to the My Computer -> Properties -> Advanced ->

Performance -> Settings -> Visual Effects -> "Use drop shadows for icon labels on the desktop" option,

and checked it, and I couldn't believe it. The text transparency came back!

This didn't work before, so I can only assume something was corrupt.

 

Thanks again for helping me out. :)

Link to post
Share on other sites

here's another thing what you can try in Windows XP,if your icons are messed up; delete file iconcache.db. it's hidden file in C:\Documents and Settings\<user>\Local Settings\Application Data folder.

 

iconcache.db will be recreated after reboot.

Link to post
Share on other sites
  • 1 year later...

I had the same problem, i did everything i read in forums but nothing happened...

 

The first time i solved this problem i had to delete my user's profile completely and had windows to recreate it... it worked fine :D

 

Eventualy (i'm talking about 2 or 3 days), the f***ing rectangles came back and this time really pissed my off 'couse i went through hell reconfiguring all my profile. I downloaded Dial-a-Fix and it encountered with a problem... i changed this registry value to 0, restarted and it worked :D

 

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\ForceActiveDesktopOn

 

Hope it helps.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...