Jump to content

Ccleaner stopped my bluetooth dongle from working


Jim Mills

Recommended Posts

I have tried the 14-day trial of Ccleaner for the first time today. I ran it and asked it to update drivers. It updated 13 drivers and told me to reboot.

After reboot my bluetooth mouse no longer works. Bluetooth no longer appears in quickstart menu. The bluetooth on-off no longer appears in settings.

I use a desktop PC with a dongle that I purchased and installed a few years ago just so I could use a bluetooth mouse.

I have been trying and trying but cannot yet get bluetooth to enable. It shows up in services.msc and I restart it, but no difference.

I have resorted to using an old buggy mouse that I keep for backup. Some of the functions do not work smoothly. I would prefer to get my bluetooth mouse and dongle working again rather than go out and buy a new mouse.

Can anyone help? What do I do to get my bluetooth dongle working again? Thanks in advance.

Link to comment
Share on other sites

Okay... I had already uninstalled Ccleaner. I reinstalled it. It tells me all my drivers are up to date and it does NOT display any "Fix the problem" button.

I would hate to have to revert my PC to factory start or a reset point (which is years ago). I'd have to spend days restoring from backups and reinstalling software, etc.

Now what do I do?

Link to comment
Share on other sites

I'm on a 14-day free trial. I finally got the "Fix a problem" button to appear, but it took me to Windows Backup/Restore.

Windows backup/restore says I have NO restore points, so apparently the auto-restore point generation failed.

I'll try contacting support, but I doubt they'll be able to do much. Maybe they know something that will help tho. We'll see. Thanks for the advice.

Link to comment
Share on other sites

For me it helped to deinstall The Bluetooth Dongle, which still was shown under usb devices in Device Manager Deinstall und replugged it in. never do an driver update again via ccleaner XD 

Link to comment
Share on other sites

Flx: That didn't work for me. CSR Core Bluetooth DOES show up in device manager under Universal Serial Bus Controllers.

I checked for updates and it says the best update is already installed.

I have a ticket in to support and they are escalating it to 2nd tier, so I am hopeful that they may come up with a fix.

Link to comment
Share on other sites

Okay, I followed this suggestion from someone else in the thread: I removed my bluetooth dongle from the usb port. Then I went to device manager and uninstalled Core Bluetooth under Universal Serial Bus Controllers. Then I plugged my dongle back in. 

Then all my bluetooth functionality suddenly reappeared. I had to repair some devices but it appears to be working now. Hope this helps.

Always gotta have something breaking huh?

Edited by pambo
syntax/typo
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.