Jump to content

Defraggler detecting my HDD as SSD


Recommended Posts

Recently swapped out my older secondary drive with a new Seagate BarraCuda 2TB, but Defraggler detects the new drive as an SSD. I'm using free version 2.22.995 on Windows 10. The drive is formatted as NTFS and is not the drive that Windows is installed on. I've already tried reinstalling Defraggler.

Interestingly, Speccy detects the drive as a mechanical drive, which is correct.

Any ideas?

Link to comment
Share on other sites

hello computerwhiz,

i mean speccy is correct.

if i looked right your seagate is an 3,5 zoll hdd with 256 mb cache - with perhaps 5.400 or 7.200 u/min?


if defraggler makes a "drive-analyse" and read data (less than 256 mb) from this hdd/ssd it could much more faster from the big cache. perhaps with this defraggler sorts this speedy hdd into an ssd...


i think defraggler detected your hdd is an ssd because the big hdd-cache-size of 256 mb. normally this hdds have a cache size of 64 mb.

the exact details knows only the programmers of defraggler and/or speccy how it detects hdd/ssd.


but there are different kinds of hdds. perhaps defraggler and speccy should be updated.

Versions of CCleaner Cloud; Introduction Ccleaner Cloud;

Ccleaner-->System-Requirements; Ccleaner FAQ´s; Ccleaner builds; Scheduling Ccleaner Free


Es ist möglich, keine Fehler zu machen und dennoch zu verlieren. Das ist kein Zeichen von Schwäche. Das ist das Leben -> "Picard"

Link to comment
Share on other sites


I'm sure there's an explanation but it doesn't matter much to users who usually want an app that works. Not an app with issues and reasons why something's wrong.

I'm facing the same issue with 3 HDD external 4TB and 5TB hard drives

Windows defrag, O&O, and a few other disk defragmenter I tried all see my HDD drives as HDD. Only Defraggler sees them as SSD...

Doesn't matter much as the optimization runs anyway.

Edited by hansolocambo
Link to comment
Share on other sites

  • 1 year later...

The larger cache on the HDD is not the reason. As can see from the attached image here, I have 2 identical WD 4TB HDD's in same system that have 256MB cache (only difference is the serial number as date of manufacture is the same on both). One is detected as an SSD & the other is detected correctly as a HDD! I also have several other HDD's in the system as well with 256MB Cache & they are detected correctly as well. All other drives in the system are detected correctly. Place the drive in another machine & is detected as a HDD by Defraggler & Speccy, as is placing another drive in this system to check also detects correctly (have tried both SATA SSD & HDD to make sure)


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.