Jump to content

Driver Updater Can't Connect To The Internet


SuperTRev

Recommended Posts

For some reason, when trying to scan my computer with the driver updater, it says that it can't connect to the internet.

There are two reasons this is weird: I've used it in the past when it first came out, and it worked fine.  It had installed several drivers.

And I do have internet access.  Submitting this post is proof.  I've just updated to the latest Ccleaner version, tried the scan again, and it's still not working for me.

Link to comment
Share on other sites

  • 7 months later...

My Driver Updater still doesn't work.  It just freezes and if I leave it long enough, it tells me I don't have access to the internet.

Do I have access to the internet, Piriform?

This is going on a year or so it hasn't worked.  When it was first introduced it worked once and then it hasn't since.

Link to comment
Share on other sites

  • Admin

@SuperTRev: I can see that you contacted support about this August 19th 2021 @ 12:32 GMT, got an initial response from 1st line support 15 minutes later saying that it had been passed up to second line support, who contacted you on August 20th @ 08:07 GMT with a couple of suggestions to fix your issue and requesting some diagnostic information from you if those suggestions didn't help, to try to get an idea of what might have been been going wrong on your computer.

I can't see a response from you to that request, or the "was your issue resolved" followup that would have come a few days later.

A recap on the advice you would have received from support:

  • You have one active licence and a couple of expired licences that no longer have access to any of CCleaner's paid features.  Are you using your active licence (ending with 2NFF) on the computer in question?
  • Are you running CCleaner as an Administrator?
  • Are you using the latest version of CCleaner currently (5.91) or an older version

If CCleaner says that it does not have access to the internet, it may mean that you do not currently have an internet connection or, more likely, that some configuration on your computer has blocked CCleaner's access to the internet. 

  • Do any other CCleaner features show you internet connection errors, such as Automatic Updates, Software Updater or the "Speed" feature of Health Check?
  • Have you blocked CCleaner in some fashion via a firewall or hosts file change?
  • Are you using a firewall that would require you to permit software to connect to the internet?

Piriform Homepage - [CCleaner - CCleaner Mac - CCleaner Android - CCleaner Browser - Defraggler - Recuva - Speccy - Kamo] - Product Support

Looking for your licence key, expiry date or download link? Check here first: https://www.ccleaner.com/support/license-lookup
To find out how we protect your privacy - read CCleaner's Data Factsheet.
What's new? Check the latest CCleaner for Windows release notes

Link to comment
Share on other sites

4 hours ago, Dave CCleaner said:

 

I can't seem to remove this accidental quote above, or discard this draft to start over.  Even if I close out the webpage and come back to this.  Yikes.

Yes I'm running the 2NFF active license.  Checked the program files and the 64 bit version is set to run as administrator, and the box is greyed out.  32 bit version wasn't set to run as admin.  I enabled it, but the about screen says I'm running the 64 bit version anyway.

I might have a firewall block on it; that would make sense.  I will have another look at it, but what firewall entries are in association with Ccleaner?

 

Link to comment
Share on other sites

  • Moderators
35 minutes ago, SuperTRev said:

what firewall entries are in association with Cclean

Depends on the firewall.

P. S. I too sometimes get the stuck quote,  it's a flaw in the forum software by invision

 

ADVICE FOR USING CCleaner'S REGISTRY INTEGRITY SECTION

DON'T JUST CLEAN EVERYTHING THAT'S CHECKED OFF.

Do your Registry Cleaning in small bits (at the very least Check-mark by Check-mark)

ALWAYS BACKUP THE ENTRY, YOU NEVER KNOW WHAT YOU'LL BREAK IF YOU DON'T.

CCLEANER, RECUVA, DEFRAGGLER AND SPECCY DOCUMENTATION CAN BE FOUND AT  https://support.piriform.com/hc/en-us and  https://www.ccleaner.com/docs

Pro users file a PRIORITY SUPPORT request at https://support.piriform.com/hc/en-us/requests/new

link to WINAPP2.INI explanation

Link to comment
Share on other sites

Ok I've checked out my firewall list.

I like how windows says my firewall isn't even running.  That probably has something to do with having spybot take care of security things.

I do have some groups of entries manually blocked.  If the driver updater relies on one of them in this list, that would explain the problem:

- Cast To Device

- Delivery Optimization

- Distributed Transaction Coordinator

- File And Printer Sharing

- Media Center Extenders

- Microsoft Edge

- Remote Assistance

- Windows Media Player

- Wireless Display

Thanks for the registry scan tips.  I've never had an issue with that, even though I've always just fixed issues without studying them.

Firewall.png

Link to comment
Share on other sites

The issue with opening up firewall permissions, is I have them blocked for a reason.  It's not worth it to allow microsoft's electric eye to shine its pale malevolent glow on me, just for a simple updater tool.

Does anyone know which particular firewall the driver updater relies on?

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.