Jump to content

Synaptics Touchpad stopped responding after using Driver Update.


Recommended Posts

The Synaptic Touchpad stopped responding to touch, after the driver updater updated a few drivers (14 of them). Mine is an E490 with Win 10(latest updates)

Tried rolling back - no success.

Reinstalled OEM updated driver - no success.

In the settings the touch pad is enabled(ON), the device manager reports everything is OK.  Tried uninstall & reinstall method - no success.

Searched on MS site & OEM site - no such case is experienced by anyone other than me, yet.

Strangely, the touchpad press action (click) works when you use the trackball to point to any button etc.

What am I missing here? Is it some registry setting?

Link to comment
Share on other sites

  • Admin

You can try running a System Restore as described here: https://support.microsoft.com/en-us/windows/use-system-restore-a5ae3ed9-07c4-fd56-45ee-096777ecd14e to before the driver update was performed, as that should reverse all the changes made.

You might also try seeing if any of the drivers in the Mouse, Pen, and Keyboard section of: https://pcsupport.lenovo.com/us/en/products/laptops-and-netbooks/thinkpad-edge-laptops/thinkpad-e490-type-20n8-20n9/downloads/driver-list help (double-check that's the right model first, though!).

If you keep having problems, please get in touch with our support team directly here: https://support.piriform.com/hc/en-us/articles/204043844 for further assistance.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.