Jump to content

Chrome pages slow to open -- or disappear -- with Kamo installed


bemused59

Recommended Posts

Couldn't find this specific issue in here, thought I'd post it and maybe get an answer.

Re-upped my subscription to CCleaner the other day, took advantage of the option to add Speccy / Defraggler / Kamo to test drive them.

Since installing all of them, pages in Chrome have been very slow to open. I have Chrome open with a half-dozen tabs... and it takes forever to open them now. Same holds true for new tabs I open with other programs.

I've tried whitelisting the main ones in the Kamo Settings menu, no effect.

And, for some reason, I cannot get newegg.com to display at all. The page loads... displays for a couple of seconds... and then goes blank.

I uninstalled Kamo, and the problems disappeared. How can I get the best of both worlds -- Kamo to help protect my online presence, but still be able to have web pages load quickly / at all. 

Any help is appreciated.

Link to comment
Share on other sites

  • 2 weeks later...

That's reassuring, db702. Good to know it wasn't a hallucination.

Contacted their support, got pretty much no help. "Are you using a VPN? No?  Must be some extension, then..."

Was hoping their support might know something... or at least want to work with me on finding a solution."

Link to comment
Share on other sites

  • 3 weeks later...
  • Admin

Hi. I was able to replicate this problem with Newegg.com, even when configuring the "Allow" option under the "Anti-tracking > Website tracking" feature of Kamo, and when adding Newegg.com to the "Whitelisted websites" area of the program; I've reported this issue to our development team so they can work on getting this resolved.

@bemused59 As Kamo does its work to intercept tracking attempts and change the attributes, it typically has an imperceptible impact on speed. However, pages that are running a significant amount of trackers may have a noticeable slower load times — usually not to the detriment of web usability or experience, but it can be noticed.

One of our senior support agents would be happy to investigate further and/or provide some additional suggestions; do they have permission to contact you via email, using the same address that is registered to your forums account?

Link to comment
Share on other sites

  • 1 month later...

Hello, I'm experiencing exactly the same. Last week, right after installing the same renewall package with Speccy, Defraggler,  Kamo and Recuva, anything I browse or open using  Chrome as a browser has gone unbelievably slow.. reminds me of the telephone modem days. I like classsic things but this truly makes me wanto to de-install everything. 

I also run a paid AVG antivirus version, didn't speed life up either, but have accepted this hesitantly. I haven't yet de-installed Kamo to see the difference but did think this part of the installation was the culprit. Tried the newegg.com page just to try and won't open either.

Using Edge Chromium i experience the normal browsing/flicking speed I'm used to.

Since the CC cleaner package, Kamo at least, does not seem to like having relations with Google Chrome, is it better advised to not use them together? It would mean not using the CCcleaner product(s) because I prefer using Crome.

Quite disappointed after purchassing this package.

 

Thanks in advance for replies, advice

 

 

 

Link to comment
Share on other sites

  • Admin

Hi @Camperman First of all, I am very sorry to hear about how this is happening.

As Kamo is designed to intercept tracking attempts, websites that are configured with a significant amount of trackers may have a noticeable slower load times.

Our support team would like to investigate this further. Do they have permission to contact you via email, using the same address registered to your forums account?

Link to comment
Share on other sites

MeganCCleaner... I hope your support team provides Camperman better answers than I got when I first contacted them, months ago (see original post on this thread). Who knows? Maybe they've learned something since March...?

Link to comment
Share on other sites

6 hours ago, MeganCCleaner said:

Hi @Camperman First of all, I am very sorry to hear about how this is happening.

As Kamo is designed to intercept tracking attempts, websites that are configured with a significant amount of trackers may have a noticeable slower load times.

Our support team would like to investigate this further. Do they have permission to contact you via email, using the same address registered to your forums account?

Hello MeganCCleaner, yes they can, please. Bare with would i not respond right away since GMT+2 here.

I understand how Kamo performs it's duty but this would quite likely stun you. I have to wonder wether anyone at CCleaner has simply tried it for themselves, easily done. I appreciate slightly lesser performance due to thorough scanning/protecting etc. but not 10-20 seconds to fully load a page, foto etc.. browsing on Google Chrome? 

But as said I'm open to support?contact if only it concludes something to help me decide on keeping Kamo running and helps others experiencing the same/scimilar problems.

 

Link to comment
Share on other sites

6 hours ago, bemused59 said:

MeganCCleaner... I hope your support team provides Camperman better answers than I got when I first contacted them, months ago (see original post on this thread). Who knows? Maybe they've learned something since March...?

Me hope so too, bemused59, and when they do I hope it benefits you as well. I will post updates wether improvements or not.

Link to comment
Share on other sites

  • Admin

@Campermanwhich version of Kamo are you using (can be found under Menu > Settings) eg:

image.png
 

Piriform Homepage - [CCleaner - CCleaner Mac - CCleaner Android - CCleaner Browser - Defraggler - Recuva - Speccy - Kamo] - Product Support

Looking for your licence key, expiry date or download link? Check here first: https://www.ccleaner.com/support/license-lookup
To find out how we protect your privacy - read CCleaner's Data Factsheet.
What's new? Check the latest CCleaner for Windows release notes

Link to comment
Share on other sites

On 11/06/2021 at 02:52, Dave CCleaner said:

@Campermanwhich version of Kamo are you using (can be found under Menu > Settings) eg:

image.png
 

Hello Dave, I was awaiting contact through my mailbox as Megan suggested hence the delay..

version 2.0.218.258

Link to comment
Share on other sites

  • 2 weeks later...

Camperman... I keep hoping -- since you got a flicker of acknowledgement from these guys -- that you might get a useful answer to the question I posted three months ago. I'm sorry (for both of us, and db702) that doesn't seem to be the case.

I'm thinking I'm going to end my 20+ year relationship with CCleaner, stop sending 'em my money if this is the kind of support they provide for products I can, literally, duplicate for free.

Link to comment
Share on other sites

16 hours ago, bemused59 said:

Camperman... I keep hoping -- since you got a flicker of acknowledgement from these guys -- that you might get a useful answer to the question I posted three months ago. I'm sorry (for both of us, and db702) that doesn't seem to be the case.

I'm thinking I'm going to end my 20+ year relationship with CCleaner, stop sending 'em my money if this is the kind of support they provide for products I can, literally, duplicate for free.

@bemused59 .. There's a limit to my acceptance as well but for now still hoping for the best. Fully understand your position 🙏

Link to comment
Share on other sites

  • 1 month later...

I've had the exact same experience. Saw the pop-up to upgrade and did so. Installed Kamo and have had trouble with two main things... USB connected mouse (intermittently not working), all webpages (Shopify, HubSpot, Google, etc) v e r r r r y s l o o o w, and mostly never load. As soon as I "End Task" for Kamo (which is consuming massive amount of all resources - CPU, Memory, etc), the problem is fixed immediately. When I restart the computer, it reloads Kamo and it turns on, and the problem appears again. End Task, problem fixed. Not sure what I "upgraded" for as there has been no benefit. I would like the features Kamo says it has, but not at the detriment of a non-responsive computer.

Link to comment
Share on other sites

Your choice if you want to follow Laurence's advice, LtdEd. Just keep in mind that they have provided ZERO actual help to any of us on this thread. Just the cookie-cutter message above... followed by crickets.

 

Link to comment
Share on other sites

  • Moderators
2 hours ago, bemused59 said:

Your choice if you want to follow Laurence's advice, LtdEd. Just keep in mind that they have provided ZERO actual help to any of us on this thread. Just the cookie-cutter message above... followed by crickets.

 

This is a user forum, not a staff forum, the easiest way to access support is the email address in the "cookie cutter" message so they've actually been as in touch with you as they are for pro users.

 

ADVICE FOR USING CCleaner'S REGISTRY INTEGRITY SECTION

DON'T JUST CLEAN EVERYTHING THAT'S CHECKED OFF.

Do your Registry Cleaning in small bits (at the very least Check-mark by Check-mark)

ALWAYS BACKUP THE ENTRY, YOU NEVER KNOW WHAT YOU'LL BREAK IF YOU DON'T.

CCLEANER, RECUVA, DEFRAGGLER AND SPECCY DOCUMENTATION CAN BE FOUND AT  https://support.piriform.com/hc/en-us and  https://www.ccleaner.com/docs

Pro users file a PRIORITY SUPPORT request at https://support.piriform.com/hc/en-us/requests/new

link to WINAPP2.INI explanation

Link to comment
Share on other sites

18 minutes ago, Nergal said:

This is a user forum, not a staff forum, the easiest way to access support is the email address in the "cookie cutter" message so they've actually been as in touch with you as they are for pro users.

Perhaps they're getting better. I only know for sure that when I contacted them directly, I got one reply -- that ignored much of the info I provided in my original email -- and nothing more when I responded.

Others in this forum have reported similar experiences.

I will refrain from sowing discontent among new posters here, though -- sorry for my snark this AM.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.