Jump to content
CCleaner Community Forums

Chrome pages slow to open -- or disappear -- with Kamo installed


Recommended Posts

Couldn't find this specific issue in here, thought I'd post it and maybe get an answer.

Re-upped my subscription to CCleaner the other day, took advantage of the option to add Speccy / Defraggler / Kamo to test drive them.

Since installing all of them, pages in Chrome have been very slow to open. I have Chrome open with a half-dozen tabs... and it takes forever to open them now. Same holds true for new tabs I open with other programs.

I've tried whitelisting the main ones in the Kamo Settings menu, no effect.

And, for some reason, I cannot get newegg.com to display at all. The page loads... displays for a couple of seconds... and then goes blank.

I uninstalled Kamo, and the problems disappeared. How can I get the best of both worlds -- Kamo to help protect my online presence, but still be able to have web pages load quickly / at all. 

Any help is appreciated.

Link to post
Share on other sites
  • 2 weeks later...

That's reassuring, db702. Good to know it wasn't a hallucination.

Contacted their support, got pretty much no help. "Are you using a VPN? No?  Must be some extension, then..."

Was hoping their support might know something... or at least want to work with me on finding a solution."

Link to post
Share on other sites
  • 3 weeks later...
  • Admin

Hi. I was able to replicate this problem with Newegg.com, even when configuring the "Allow" option under the "Anti-tracking > Website tracking" feature of Kamo, and when adding Newegg.com to the "Whitelisted websites" area of the program; I've reported this issue to our development team so they can work on getting this resolved.

@bemused59 As Kamo does its work to intercept tracking attempts and change the attributes, it typically has an imperceptible impact on speed. However, pages that are running a significant amount of trackers may have a noticeable slower load times — usually not to the detriment of web usability or experience, but it can be noticed.

One of our senior support agents would be happy to investigate further and/or provide some additional suggestions; do they have permission to contact you via email, using the same address that is registered to your forums account?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...