Jump to content

Edge Chromium Not Getting Cleaned on Close


Peanut99

Recommended Posts

Hello,

Running Windows 10 Pro v20H2 - updates current with CCleaner v5.75.8238.

Under CCleaner - Smart Cleaning - Enable Smart Cleaning (selected) - Enable Automatic Browser Cleaning (selected) - Edge Chromium - Automatically clean on closing with notification (selected). Actually all browsers are selected under Enable Automatic Browser Cleaning. Edge is the only Browser installed on the system.

When I close Edge, I do not ALWAYS get the notification pop up window that CCleaner has cleaned Edge. Wait a minute or so, manually start CCleaner, run analyze, and sure enough, there is Edge listed with the usual assortment of files.  Manual clean takes care of this with no issue. But I should not have to run the manual clean.

And yet, there are other times when I close Edge I get the pop up notification that that Edge has been cleaned.

I would expect to get this action (the clean notification on close) every time, as defined in Enabled Smart Cleaning selections. 

This is an error situation and should not be happening. 

Link to comment
Share on other sites

  • Moderators

Just to make sure, have you turned off "continue running background apps when Microsoft Edge is closed" in edge's setings (under the system chapter).

 

ADVICE FOR USING CCleaner'S REGISTRY INTEGRITY SECTION

DON'T JUST CLEAN EVERYTHING THAT'S CHECKED OFF.

Do your Registry Cleaning in small bits (at the very least Check-mark by Check-mark)

ALWAYS BACKUP THE ENTRY, YOU NEVER KNOW WHAT YOU'LL BREAK IF YOU DON'T.

CCLEANER, RECUVA, DEFRAGGLER AND SPECCY DOCUMENTATION CAN BE FOUND AT  https://support.piriform.com/hc/en-us and  https://www.ccleaner.com/docs

Pro users file a PRIORITY SUPPORT request at https://support.piriform.com/hc/en-us/requests/new

link to WINAPP2.INI explanation

Link to comment
Share on other sites

Yes,  "continue running background apps when Microsoft Edge is closed" is turned off. 

I went through the forum looking for posts in this area that could identify what is wrong. And settings are in agreement with those recommended.

This behavior is also present when there are multiple applications running on the desktop, (e.g., word or excel) and Edge, AND when there is only Edge running with a single tab.

I should also add that this behavior has been present for quite a while, not just recently. Here I am talking a year or more. There are times when CCleaner runs perfectly, and at other times this inconsistent behavior becomes the norm. I have not watched it closely enough to tie it to certain updates, either CCleaner or Windows.

So this has been occurring for quite a while, past updates in both CCleaner and Windows.

Link to comment
Share on other sites

  • Moderators

Hi @Peanut99 What you describe, with only sometimes getting the 'Browser Cleaned' notification and other times not, sounds as if it's being caused by a known bug.
You can check for this yourself, see below.

Some users have noticed that for an as yet unknown reason Smart Cleaning will sometimes turn off following an automatic clean.
That is - Smart Cleaning it will do an automatic clean once (giving you the notification) and then stop running (so no more notifications).

As you rightly say, that shouldn't be happening and is a bug. But it's not yet clear if the bug is in CCleaner or in Windows itself.

So if one automatic clean has been run, and Smart Cleaning has wrongly got turned off, then Smart Cleaning won't restart again until you either open and close CCleaner, or restart your computer.
You yourself are doing that by manually opening CCleaner when you don't get a Notification that the browser has been cleaned on closing it.
Once you have closed CCleaner again then Smart Cleaning will be running again.

You can check if this is what is happening for you fairly simply:

Check 1:
Look in the System Tray (the right hand end of the taskbar), don't forget to click on the 'up-arrow' as well.
If there is not a CCleaner icon showing then Smart Cleaning is not running for you, (although it may have run once and then closed).
ie. In this screenshot there no CCleaner icon in the Tray so Smart Cleaner is not running, you can restart it by simply opening/closing CCleaner and the icon will then come back.
image.png
For contrast here is one where Smart Cleaning is running:
image.png

Check 2:
If the ccleaner icon is there for you then open Edge Chrome, browse a couple of pages and close it again to get the Smart Cleaning notification, wait a minute
THEN check the system tray again to see if Smart Cleaning has closed itself after cleaning and the icon removed - if it has then you are being affected by this bug.

Why this is only being reported by some users, and just what is causing it, is under investigation.
It seems to have started with Windows 2004, although has also been reported with 1909.
It also seems to be tied into the Windows Task Scheduler, the affected users most probably have some different setting in Windows 2004/20H2 than others do - it's tracking down what particular setting(s) this may be that takes time.

*** Out of Beer Error ->->-> Recovering Memory ***

Worried about 'Tracking Files'? Worried about why some files come back after cleaning? See this link:
https://community.ccleaner.com/topic/52668-tracking-files/?tab=comments#comment-300043

 

Link to comment
Share on other sites

Hi @nukecad,

Thank you for the response. It sheds some light on this mystery. Here is another interesting tidbit. There have been many times in the past when I notice CCleaner did not perform the automatic clean, which caused me to go over to the System Tray and select the 'up-arrow' to 'Show Hidden Icons'. Here is the weird part: Left click on the up-arrow, to show the icons, and the CCleaner icon is there. Move the mouse pointer up to the CCleaner icon  and it disappears.  At that point, if I am concerned about cleaning, I will manually select CCleaner from the 'Start' menu. 

But that's not all, there are many times when I do a power up and the CCleaner icon is not there in the 'hidden icons' of the system tray. Yet I will get the pop-up notice to clean based on the size I set under settings. Or I might get an 'update is available' notice. Perform the update with no change in behavior, the CCleaner icon is not there. 

And of course when I want it to happen, it doesn't. Right now the check on the system tray shows the CCleaner icon. The last few times I've closed Edge I get the automatic clean pop up window. 

Will start checking the system tray hidden icons upon initial power up and randomly during the time I'm on to see if there is a subtle pattern in behavior. 

 

 

Link to comment
Share on other sites

  • Moderators

TBH I suspect that there is something subtle going on with Windows Task Scheduler, (which is after all what is responsible for putting the icon in the tray).

It wouldn't be the first time that a glitch in Windows (especially in Win 10) has had software developers around the world chasing their tails trying to find bugs that are in fact Microsofts fault.

*** Out of Beer Error ->->-> Recovering Memory ***

Worried about 'Tracking Files'? Worried about why some files come back after cleaning? See this link:
https://community.ccleaner.com/topic/52668-tracking-files/?tab=comments#comment-300043

 

Link to comment
Share on other sites

  • 1 month later...

Ok, it is now Feb 24, 2021 and Edge Chromium Not Getting Cleaned on Close issue posted back in Dec 2020 is still not resolved.

No matter what selection you make under Options - Smart Cleaning - Enable automatic browser cleaning nothing works for Edge Chromium (except maybe 'Disable' which does nothing).

Edge Chromium is the only installed browser on the system.

For Edge Chromium - If you change the setting from Automatically Clean on Closing with Notification to Prompt me to clean on closing, it works one time and then will not work again. Switch it back to the previous selection - nothing. The only setting that seems to works is Disabled.

There has been at least one or more updates to CCleaner since Dec 2020 and this problem still persists. 

Once you close Edge and nothing happens, if you see CCleaner in the hidden icons area and move the pointer to it  - it disappears.  Other times it does not.

Open Outlook check mail, look at mail, click on link in Outlook mail message opens Edge to that site, close Outlook, then close Edge (now all apps are closed - there are no open apps on the desktop). CCleaner does not run. Manually start CCleaner - go to Custom Clean - Analyze and the results show that CCleaner did not run. Internet Explorer, Edge Chromium, Windows Explorer, all have items to be deleted. 

This really needs to be fixed - 4-6 months of this ongoing issue shows CCleaner engineering is not addressing this issue. And if this feature isn't working correctly what else in CCleaner is not working correctly?

At least when Microsoft messes up and update they do get a fix out. This is getting to be ridiculous.

 

Link to comment
Share on other sites

  • 2 weeks later...

I started getting this two days ago. When I force CClearn to close Edge Chromium it will work, but then what is weird is when I go back online after running CCleaner Edge will say that my last session was ended abruptly and if I want to restore my last session. When I did that it took me to the last website I visited before I ran CCleaner. I think it may have something to do with the latest windows update.

Link to comment
Share on other sites

  • Moderators
3 hours ago, Joseph29 said:

I think it may have something to do with the latest windows update.

 

In your particular case this may be something different/new.
It may be due to recent changes in Edge Chromium.
Check if you have 'Startup Boost' enabled, (edge://settings/system) and try turning it off if you have.
 

Quote

To improve Microsoft Edge startup speed, we have developed a feature called startup boost. Startup boost keeps the browser running in the background ....

 

*** Out of Beer Error ->->-> Recovering Memory ***

Worried about 'Tracking Files'? Worried about why some files come back after cleaning? See this link:
https://community.ccleaner.com/topic/52668-tracking-files/?tab=comments#comment-300043

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.