Jump to content
CCleaner Community Forums

CCleaner 5.74 causing errors in Wndows Event Viewer


Recommended Posts

Hello, my Windows Event Wiever is full of those errors. Win 7 64bit:

Event ID 1000 Application error:

Název chybující aplikace: CCleaner64.exe, verze: 5.74.0.8184, časové razítko: 0x5fa3260a
Název chybujícího modulu: CCleaner64.exe, verze: 5.74.0.8184, časové razítko: 0x5fa3260a
Kód výjimky: 0xc0000005
Posun chyby: 0x0000000000d68283
ID chybujícího procesu: 0xd24
Čas spuštění chybující aplikace: 0x01d6b6ac8bf060b1
Cesta k chybující aplikaci: C:\Program Files\CCleaner\CCleaner64.exe
Cesta k chybujícímu modulu: C:\Program Files\CCleaner\CCleaner64.exe
ID zprávy: d3f27b1e-229f-11eb-a8da-40167ea966e2

So i hope it will be fixed.

Link to post
Share on other sites

I just found one thing. Anytime i check for updates, it causes those error. But i have too much errors in Windows Event Viewer so it cannot be only one thing which trigger those errors.

Link to post
Share on other sites

me too. win7 x86, portable, free edition.

ccleaner is crashed when exit and *.dmp file is created in ccleaner folder.

always "UpdateAuto=1" in ccleaner.ini regardless of GUI "Keep CCleaner updated automatically" option is off.

I manually edited it to "UpdateAuto=0" but, it is reverted to "UpdateAuto=1" when CCleaner is launched.

1.png

Edited by circcc
Link to post
Share on other sites
  • Admin
2 hours ago, balloon66 said:

Here too.

There is something wrong with „Smart Cleaning“ in options. It can’t be deactivated. Closing Ccleaner in the taskbar throws this error in Win event viewer. 

@balloon66: To confirm, did you mean to include an error message, or are you saying that you received the same error as TheOwner?

I just tried this myself to deactivate Smart Cleaning on CCleaner Professional and it seemed to work as intended.  When I disabled Smart Cleaning it popped up with the usual "are you sure" box, I confirmed and everything was unchecked on the Options > Smart Cleaning screen.  When I closed CCleaner it disappeared from the task bar as would be expected if Smart Cleaning is switched off.  When I restarted CCleaner and reopened Options > Smart Cleaning the options all remained unchecked as per the screenshot below.

I tried this with an active licence that expires December 2020 and also a "legacy" licence (ie: it shows an expiry date in 2014 and is "Expired" but remains active) with the same experience for both.  Although it did toggle Smart Cleaning back on when I reset and changed accounts, it seemed to stick properly for each specific account.

Not sure what could be causing this experience for you, so please bear with us as we try to pinpoint what might be causing this:

  • Is your copy of CCleaner showing itself as CCleaner Free or CCleaner Professional in the top left corner?
  • If it is showing as CCleaner Professional, when you go to Options > About > License Information is it showing your current licence key as active and unexpired?
  • If it is expired, what year does it show as the expiry year? 2012-2018? 2019-2020? Or 2000 (meaning that the licence was disabled)
  • Have you changed licence key recently? Does this failure to deactivate happen more than once, or just the one time and it works on subsequent occasions?
     
  • ?name=inline-2086206352.png
Link to post
Share on other sites

Error seems to register in event viewer when user closes CCleaner.  

I have tried disabling Smart Cleaning and Auto Update but error still appears after closing program.

The only fix is to uninstall program.

Edited by kathy 14
Link to post
Share on other sites
  • Admin
2 hours ago, katlani said:

According to another post, disabling the Smart Cleaning option while also disabling the new Auto Update feature will resolve it for now, until it is patched soon.

Indeed, we have confirmed this to be a bug, and we're working on a patch release at the moment to fix this.  We hope to have this out in a couple of days and apologise for the inconvenience in the interim.

In the meantime, to make deactivating Smart Cleaning stick, the work-around is:

  • Unchecking all of the boxes on the Options > Smart Cleaning screen in CCleaner (going from top to bottom, as the "Enable Smart Cleaning" is greyed out if "Tell me when there are junk files to clean" is checked); and
  • Unchecking the Options > Updates > Keep CCleaner updated automatically option.

The production of .dmp files and error logs associated with this bug will be fixed with the patch release.

Link to post
Share on other sites

Windows 8.1
When I close the program I get this: 
Ccleaner has stopped working

Problem signature:
  Problem Event Name:    APPCRASH
  Application Name:    CCleaner64.exe
  Application Version:    5.74.0.8184
  Application Timestamp:    5fa3260a
  Fault Module Name:    CCleaner64.exe
  Fault Module Version:    5.74.0.8184
  Fault Module Timestamp:    5fa3260a
  Exception Code:    c0000005
  Exception Offset:    0000000000d68283
  OS Version:    6.3.9600.2.0.0.256.103
  Locale ID:    1033
  Additional Information 1:    9317
  Additional Information 2:    93173ac77c943b699f47a5e8f9736fb1
  Additional Information 3:    fb5a
  Additional Information 4:    fb5ad86d732dbdaac05cc62452e7d06a

Link to post
Share on other sites
  • Moderators
4 hours ago, kathy 14 said:

There seems to be another problem that dates back to the previous version of CCleaner.  When you check enable UAC in settings and then try to uncheck it there's an error box that pops up.

It's another small bug that is due to be fixed. It isn't affecting the running of CCleaner just the UAC skipping.

If it's bugging you then you can easily cure it for yourself by following the 4 simple steps quoted in this post. (You may have to do this after each CCleaner update until the permanent fix is rolled out).

 

Link to post
Share on other sites
22 hours ago, nukecad said:

It's another small bug that is due to be fixed. It isn't affecting the running of CCleaner just the UAC skipping.

If it's bugging you then you can easily cure it for yourself by following the 4 simple steps quoted in this post. (You may have to do this after each CCleaner update until the permanent fix is rolled out).

 

Thanks, Nukecad,  but I think I'll be moving on..

Link to post
Share on other sites

Closing CCleaner still throws a warning in Event Viewer: 

Protokollname: Application
Quelle:        Application Error
Datum:         11.11.2020 17:21:09
Ereignis-ID:   1000
Aufgabenkategorie:(100)
Ebene:         Fehler
Schlüsselwörter:Klassisch
Benutzer:      Nicht zutreffend
Computer:      DESKTOP-R4V4B1J
Beschreibung:
Name der fehlerhaften Anwendung: CCleaner64.exe, Version: 5.74.0.8198, Zeitstempel: 0x5faae541
Name des fehlerhaften Moduls: CCleaner64.exe, Version: 5.74.0.8198, Zeitstempel: 0x5faae541
Ausnahmecode: 0xc0000005
Fehleroffset: 0x0000000000d68253
ID des fehlerhaften Prozesses: 0x870
Startzeit der fehlerhaften Anwendung: 0x01d6b846913bf31d
Pfad der fehlerhaften Anwendung: C:\Program Files\CCleaner\CCleaner64.exe
Pfad des fehlerhaften Moduls: C:\Program Files\CCleaner\CCleaner64.exe
Berichtskennung: 529b901b-2bfb-4de7-9109-c6ba00657dcb
Vollständiger Name des fehlerhaften Pakets: 
Anwendungs-ID, die relativ zum fehlerhaften Paket ist: 
Ereignis-XML:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Application Error" />
    <EventID Qualifiers="0">1000</EventID>
    <Version>0</Version>
    <Level>2</Level>
    <Task>100</Task>
    <Opcode>0</Opcode>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2020-11-11T16:21:09.2904527Z" />
    <EventRecordID>74706</EventRecordID>
    <Correlation />
    <Execution ProcessID="0" ThreadID="0" />
    <Channel>Application</Channel>
    <Computer>DESKTOP-R4V4B1J</Computer>
    <Security />
  </System>
  <EventData>
    <Data>CCleaner64.exe</Data>
    <Data>5.74.0.8198</Data>
    <Data>5faae541</Data>
    <Data>CCleaner64.exe</Data>
    <Data>5.74.0.8198</Data>
    <Data>5faae541</Data>
    <Data>c0000005</Data>
    <Data>0000000000d68253</Data>
    <Data>870</Data>
    <Data>01d6b846913bf31d</Data>
    <Data>C:\Program Files\CCleaner\CCleaner64.exe</Data>
    <Data>C:\Program Files\CCleaner\CCleaner64.exe</Data>
    <Data>529b901b-2bfb-4de7-9109-c6ba00657dcb</Data>
    <Data>
    </Data>
    <Data>
    </Data>
  </EventData>
</Event>

Link to post
Share on other sites

Same here. CCleaner crashes on exit and creates a .dmp file in the program folder. Here is a brief of an analysis of this dump.

FAULTING_IP: 
CCleaner64!CryptoPP::DetectX86Features+20aa70
00007ff7`3413d9c0 488b4010        mov     rax,qword ptr [rax+10h]

EXCEPTION_RECORD:  (.exr -1)
ExceptionAddress: 00007ff73413d9c0 (CCleaner64!CryptoPP::DetectX86Features+0x000000000020aa70)
   ExceptionCode: c0000005 (Access violation)
  ExceptionFlags: 00000000
NumberParameters: 2
   Parameter[0]: 0000000000000000
   Parameter[1]: 00007ffdc99282d8
Attempt to read from address 00007ffdc99282d8

DEFAULT_BUCKET_ID:  INVALID_POINTER_READ

PROCESS_NAME:  CCleaner64.exe

FOLLOWUP_IP: 
CCleaner64!CryptoPP::DetectX86Features+20aa70
00007ff7`3413d9c0 488b4010        mov     rax,qword ptr [rax+10h]

READ_ADDRESS:  00007ffdc99282d8 

ERROR_CODE: (NTSTATUS) 0xc0000005 - A instru  o no 0x%p referenciou a mem ria no 0x%p. A mem ria n o p de ser %s.

EXCEPTION_CODE: (NTSTATUS) 0xc0000005 - A instru  o no 0x%p referenciou a mem ria no 0x%p. A mem ria n o p de ser %s.

EXCEPTION_CODE_STR:  c0000005

EXCEPTION_PARAMETER1:  0000000000000000

EXCEPTION_PARAMETER2:  00007ffdc99282d8

WATSON_BKT_PROCSTAMP:  5faae541

WATSON_BKT_PROCVER:  5.74.0.8198

PROCESS_VER_PRODUCT:  CCleaner

WATSON_BKT_MODULE:  CCleaner64.exe

STACK_TEXT:  
000000b7`b26ff0f0 00007ff7`334a0367 : 00000251`d4261590 00000251`d297de70 00000000`ffffffff 00000251`d28aed10 : CCleaner64!CryptoPP::DetectX86Features+0x20aa70
000000b7`b26ff120 00007ff7`3343c128 : 00000251`d4261590 00000251`00000001 00000251`d28aed10 00000000`00002614 : CCleaner64!CryptoPP::BlockOrientedCipherModeBase::BlockOrientedCipherModeBase+0x37a47
000000b7`b26ff150 00007ff7`340d8f55 : 00000251`d297de70 00000251`d2704140 00000251`d297cd20 00000000`00000000 : CCleaner64!CryptoPP::BlockTransformation::OptimalNumberOfParallelBlocks+0x4818
000000b7`b26ff180 00007ff7`33479c00 : 00000251`d28aed10 00000251`d28aed10 000000b7`b26ff490 00000251`d297cd20 : CCleaner64!CryptoPP::DetectX86Features+0x1a6005
000000b7`b26ff360 00007ff7`340e0286 : 00000251`d297c960 00000251`d28aed01 000000b7`b26ff490 00000251`d297cd20 : CCleaner64!CryptoPP::BlockOrientedCipherModeBase::BlockOrientedCipherModeBase+0x112e0
000000b7`b26ff390 00007ff7`340dfda3 : 00000251`d26c22e8 00000000`002f0036 00000000`00000000 00008000`00000000 : CCleaner64!CryptoPP::DetectX86Features+0x1ad336
000000b7`b26ff560 00007ff7`3355708d : 00000251`d26c22e8 000000b7`b26ff700 00000251`d26c22e8 00000000`00000000 : CCleaner64!CryptoPP::DetectX86Features+0x1ace53
000000b7`b26ff850 00007ffd`e7737c24 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : CCleaner64!CryptoPP::VariableKeyLength<16,0,2147483647,1,4,0>::StaticGetValidKeyLength+0x1ac5d
000000b7`b26ff890 00007ffd`e832d4d1 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : kernel32!BaseThreadInitThunk+0x14
000000b7`b26ff8c0 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : ntdll!RtlUserThreadStart+0x21

It's failing at DetectX86Features... maybe occurs on only some CPUs, here is a IvyBridge...

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...