Jump to content
CCleaner Community Forums

turning off giving CCleaner permission everytime Windows 10 boots - [Workround]


Recommended Posts

Is there a way of turning off Windows asking me for permission for CCleaner each time, I reboot/restart the machine? This has only happened since the Oct2020 update & it's annoyance. I do NOT want to disable UAC as a whole.

Link to post
Share on other sites
  • Moderators

There is a switch for this in Options>Advanced -  if ticked it only applies to CCleaner :

image.png

 

Although I do note that you say it's only started happening for you with 20H2, which as a full release has only been out today , so something may have changed that needs looking at.

Link to post
Share on other sites

Unfortunately this doesn't help me. There is NO advanced under Tools in my  CCleaner.

 

I have the free version & can't afford to purchase the paid version (retired, low income). Is there another solution? Otherwise, I'll stop using CCleaner.

Edited by Purrceyz
Link to post
Share on other sites
  • Moderators
5 minutes ago, Purrceyz said:

Unfortunately this doesn't help me. There is NO advanced under Tools in my  CCleaner.

 

I have the free version & can't afford to purchase the paid version (retired, low income). Is there another solution? Otherwise, I'll stop using CCleaner.

It's not under Tools it's under Options.. Advanced and then look down the list.

Link to post
Share on other sites

Thank you for your reply.

I looked under options, found it and looked at the "skip  user account control warning" box. It's already checked. Rebooted and it still asked.

 

So I went back to Options so I could uncheck it and recheck it, thinking that might help. When I try to uncheck it, I get the message "The system cannot find the path  specified" (I reinstalled it, used the default settings.)  Rebooted again. So this problem persists. 

Edited by Purrceyz
Link to post
Share on other sites
  • Moderators

I'll try some testing now that I have 20H2 installed.

Are you using 'Run CCleaner when the computer starts' or 'Smart Cleaning', or both?

Link to post
Share on other sites
  • Moderators

I've done some testing and cannot replicate this UAC problem, so another couple of questions:

Do you have Windows Fast Startup enabled?
Are you using a Windows admin account or a standard user account?

Link to post
Share on other sites
  • Moderators

A couple of times after a big Windows 10 upgrade what I had to do was untick and re-tick that UAC box in CCleaner as shown in nukecad's screenshot then it no longer prompted.

It's a task in Windows Task Scheduler which is perhaps disabled by a major Windows upgrade and it may need to be re-enabled. I think it's sort of a common issue for some types startup items after a major Windows 10 upgrade installed. Speculation: Maybe Microsoft is disabling some things so the Windows 10 upgrade installs without issue. It also happens to some SSD toolbox software that utilizes a non-standard cache system such as Crucial's/Micron's SSD Momentum Cache and Samsung SSD Rapid Mode.

 

Link to post
Share on other sites
  • Moderators

@PurrceyzThe message that you got when trying to untick the option may well point to the Task Scheduler entry being missing. (I suspect that I may also have lost a few during the 20H2 update).

Can you open the Task Scheduler to check if it's there. If I rember correctly the task is called 'CcleanerSkipUAC'.

Give me a shout if you need step by step instructions on how to do that. (On the phone so can't screenshot them at the moment).

Link to post
Share on other sites

nukecad, thank you for all your suggestions to resolve this issue. 

 

The workaround did work for me (after rebooting). Do you want to want to report this issue to the developers or would you prefer if I did? (Your explanation would probably be more detailed than mine.)

 

Thank you again for your work. 

 

Link to post
Share on other sites
  • Moderators

I've already reported it to the staff thanks, and another possible 20H2 issue.

It's always going to be an issue - Microsoft changes something and then everyone else has to work out what they have done and catch up.

Link to post
Share on other sites
  • nukecad changed the title to turning off giving CCleaner permission everytime Windows 10 boots - [Workround]

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...