Jump to content
CCleaner Community Forums

Recommended Posts

I have just installed the latest version of CCleaner for macOS (1.18) on a Mac Laptop running Catalina (10.15.7), but unfortunatley CCleaner is stubbornly refusing to start - I see a spinner and then nothing more; the only thing I can do is to Force Quit the app. I'm aware of the problems with Catalina in general and have tried the usual tricks of right-clicking and selecting "Open" under Applications, as well as checking for Gatekeeper issues in "Security & Privacy | Allowed app", but am seeing nothing listed.

Is there any way I can diagnose what's wrong? I've tried launching from the CLI, but same problem and no additional output...


Link to post
Share on other sites
  • Moderators

As you say it may be an issue with Catalina.

Unfortunately we don't have many (any?) knowledgable Mac users posting here.

If you can run CCleaner Mac in debug mode the logfile may help pinpoint just where it is hanging.

If you let CCleaner eventually open then you should see a large time gap in the log for the process it got stuck at.

Link to post
Share on other sites
  • 2 weeks later...
  • Moderators

There is also a bigger delay in the first one at:

[20:46:37]    CUninstallOutlineDataSource:objectValueForTableColumn return : (null)
[21:14:52]    CSafariCleaner:GetCookies enter

I'll flag the logs up to the staff to have the devs look at them.

Link to post
Share on other sites
  • Admin

@phantomathkgThanks for providing these as we've received some other reports about this issue so we are actively investigating, and collecting logs.

To confirm, were these logs created using v1.18.28 of CCleaner, or were they created using the new version we released on October 6th, v1.18.30 ?

(I assume they're from the latest version, 1.18.30, but I need to verify this - just in case)

Link to post
Share on other sites

CCleaner 1.18.30 on macOS 10.15 Catalina:

�[17:45:21]	CCleanerManager:init
��[17:45:21]	CCleanerManager:InitCleaners
��[17:45:21]	CApplicationCleanersGenerator:Generate
��[17:45:21]	CApplicationCleanersGenerator:Generate - Cache
��[17:45:21]	CCacheCleanersGenerator:GenerateCleaners enter
��[18:05:53]	CCacheCleanersGenerator:GenerateCleaners cacheDirs: (


��[18:05:54]	GenerateSystemCleaners
��[18:05:54]	GenerateNonSystemCleaners
��[18:05:54]	GenerateOtherCleaners
��[18:05:54]	CCleanerManager:AddCleanerToGroup: cleaner: Safari group: Mac OS X
��[18:05:54]	exists == NO
��[18:05:54]	CSafariCleaner:GetCookies enter
��[18:05:54]	FilterDuplicatedCookies enter
��[18:05:54]	FilterDuplicatedCookies return
��[18:05:54]	CSafariCleaner:GetCookies return
��[18:05:54]	FilterDuplicatedCookies enter
��[18:05:54]	FilterDuplicatedCookies return
��[18:26:41]	CCleanerManager:AddCleanerToGroup: cleaner: System group: Mac OS X
��[18:26:41]	exists == NO
��[18:26:41]	CCleanerManager:InitCleaners [applicationsCleanersGen GetSystemCleaners]
��[18:26:41]	CCleanerManager:AddCleanerToGroup: cleaner: System Applications group: Mac OS X
��[18:26:41]	exists == NO
��[18:26:41]	CCleanerManager:AddCleanerToGroup: cleaner: Advanced group: Mac OS X
��[18:26:41]	exists == NO
��[18:26:41]	IsApplicationInstalled found path: /Applications/Firefox.app
��[18:26:41]	CCleanerManager:AddCleanerToGroup: cleaner: Firefox group: Applications
��[18:26:41]	exists == NO
��[18:26:41]	CFirefoxCleaner:GetCookies enter
Edited by LanikSJ
Link to post
Share on other sites

Also, a MacBook Pro 16, Catalina 10.15.7 with CC 1.18.28 Pro. It will not upgrade (null) version.

When I closed the lid and came back later and opened it again it was freezing the mac.

I am having the same not responding problem. I reinstalled, uninstalled and reinstalled but the problem persists. I am currently waiting to see if it will eventually start.

When it did, the problem did not go away. 


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...