Jump to content
CCleaner Community Forums

CCleaner Not Working Properly While Connected to VPN


Recommended Posts

Hi, I'm a longtime pro user and have a serious issue that just started recently.  I am no longer able to access the CCleaner domain while connected thru NordVPN on Windows 10.  This means that the app also does not function properly (ie fails to check updates, recycle bin shortcut hangs app when running, etc.).  As soon as I disconnect from Nord the app functions as expected.

Are you all intentionally blocking Nord's servers from accessing your product(s)?  If so, I cannot continue to support this product as I'm not going to disconnect from my VPN provider every time I empty the bin or run the app.  I truly hope this is a temporary issue that will be resolved.

Please advise...

Link to post
Share on other sites
  • Admin
3 hours ago, nateinva said:

Hi, I'm a longtime pro user and have a serious issue that just started recently.  I am no longer able to access the CCleaner domain while connected thru NordVPN on Windows 10.  This means that the app also does not function properly (ie fails to check updates, recycle bin shortcut hangs app when running, etc.).  As soon as I disconnect from Nord the app functions as expected.

Are you all intentionally blocking Nord's servers from accessing your product(s)?  If so, I cannot continue to support this product as I'm not going to disconnect from my VPN provider every time I empty the bin or run the app.  I truly hope this is a temporary issue that will be resolved.

Please advise...

 

We don't block NordVPN, or VPNs generally - indeed we think they're neat and spend a lot of time using them ourselves.  But it certainly sounds like something is amiss somewhere.

  • Usual debug questions - Windows Edition and build? Firewall and AV software?  
  • Are there any entries in your c:\Windows\System32\Drivers\etc\hosts file?  Especially anything referencing CCleaner domains?
  • Which browser were you using to access https://www.ccleaner.com? Do you have the same experience when using a different browser?  If the same problem, are there any plugins that you are using on both browsers?
  • I take it that you also have the same problem connecting to https://community.ccleaner.com and had to disconnect your VPN to post this?  With the VPN connected were you able to reach https://download.ccleaner.com/ccsetup569.exe or https://support.piriform.com ?
  • What message (if any) do you get when attempting to connect to www.ccleaner.com or checking for updates?
  • May I ask what countries you are emulating when connecting through the VPN and, if you do an IP lookup of yourself, what ISP they turn up as?
  • Are you always using the same VPN exit point?  Does your experience change when using different exit points?

 

Link to post
Share on other sites
11 hours ago, Dave CCleaner said:

Dave, thank you for the thorough response and I'm thankful it isn't an issue of blocking services. Some responses on the bulleted items below...

  • Running Windows 10 Pro, version 1903, build 18362.959.  Not running any third party Firewall / AV software, just built-in services
  • No entries in hosts file
  • Using new Chromium-based Edge browser.  Same experience when trying multiple browsers (again this issue just started after one of the recent CCleaner updates).  Plugin usage is minimal, only common extension is HTTPS Everywhere.
  • Oddly enough, I can successfully connect to https://community.ccleaner.com thru the VPN.  The other domain links are not reachable and I'm including screenshots
  • Screenshot attached for error message when checking for updates
  • For NordVPN connection, I simply use the "quick connect" feature.  I am located in the US so it is always a US server that is geographically close to me and has the fastest available connection.  For the record, I haven't had any other connectivity issues and when this began I immediately knew something wasn't working right.  I'm attaching a screenshot from my taskbar icon tray and you can see the CCleaner icon stuck on 40%.  It's been like this since yesterday evening and it will resolve/finish to 100% immediately upon disconnecting from the VPN.
  • I'm attaching a screenshot from speedtest.net with current assigned IP and the recognized service provider
  • As far as the exit point question, I'm not sure how to reply to that one.  I just use the quick connect feature of the VPN app.  When connected, I encounter the stated issues.  As soon as I disconnect and use my ISP's assigned IP address, all the problems immediately go away.

Let me know what else I can provide.  Thank you for your prompt reply and support.

############################################################

We don't block NordVPN, or VPNs generally - indeed we think they're neat and spend a lot of time using them ourselves.  But it certainly sounds like something is amiss somewhere.

  • Usual debug questions - Windows Edition and build? Firewall and AV software?  
  • Are there any entries in your c:\Windows\System32\Drivers\etc\hosts file?  Especially anything referencing CCleaner domains?
  • Which browser were you using to access https://www.ccleaner.com? Do you have the same experience when using a different browser?  If the same problem, are there any plugins that you are using on both browsers?
  • I take it that you also have the same problem connecting to https://community.ccleaner.com and had to disconnect your VPN to post this?  With the VPN connected were you able to reach https://download.ccleaner.com/ccsetup569.exe or https://support.piriform.com ?
  • What message (if any) do you get when attempting to connect to www.ccleaner.com or checking for updates?
  • May I ask what countries you are emulating when connecting through the VPN and, if you do an IP lookup of yourself, what ISP they turn up as?
  • Are you always using the same VPN exit point?  Does your experience change when using different exit points?

 

 

2020-07-31 11_45_29-Window.png

2020-07-31 11_46_31-Window.png

2020-07-31 11_52_13-Window.png

2020-07-31 11_52_25-Window.png

2020-07-31 11_58_30-Window.png

2020-07-31 12_06_04-Window.png

Link to post
Share on other sites
  • Moderators

Along with the invalid/wrong URL I watched a YouTube video yesterday that stated VPN software should be updated immediately whenever there's a new version available because they're supposedly prone to becoming incompatible with Windows 10 after Windows Updates.

Link to post
Share on other sites
16 hours ago, cbaumer0628 said:

@nateinva

I noticed typo in one of your screenshots above.

support.periform.com

s/b

support.piriform.com

 

Thanks, so support.piriform.com is accessible thru the VPN but the others are not, and regardless the main issue is the app hanging/not functioning while connected thru the VPN.  That is the problem that just started recently that is most troublesome.  All issues immediately go away and app function returns to normal as soon as the VPN is disconnected...but that is no solution.

I've completely removed CCleaner and downloaded/reinstalled the latest available release, still no change.

And also just replying here to the follow up comment below yours, NordVPN isn't some hack, shady product and it is updated on a very regular basis.  I keep my apps updated and this computer doesn't run anything that isn't necessity as it is my main workstation.  I keep it lean, fast and reliable.

The simple fact is this software combo has gotten along perfectly fine for several years and suddenly the app no longer functions until disconnecting from the VPN, to me, warrants further investigation.  I initially got a very thorough response and just looking for further support on this.  Is there any other way to obtain direct technical support other than this forum?

Link to post
Share on other sites
  • Admin

We have something in the app that blocks use in trade-embargoed countries like North Korea or Syria. If the IP address Nord leases/purchased for its VPN service used to belong to an embargoed country, it's possible that the IP tables have not been updated by all geolocation services.

E.g. Syria sells one of its IP addresses to an ISP. The ISP assigns a new location, but perhaps doesn't notify all the Geolocation services of this change. Nord leases or purchases the IP address from the ISP (or even via an intermediary like a DataCentre). Products and services that check country location via a Geolocation Service that wasn't updated would still see the country as 'Syria'.

This can happen with any VPN provider. It's pretty routine to lease or buy new IP addresses. And IPv4 addresses are getting extremely rare and valuable these days as the internet 'runs out' (hence the move to IPv6).

You could confirm this hypothesis by trying to connect through other US VPN servers on Nord. If CCleaner starts working again when connecting through a different server (e.g. different VA server or different US State location), then the problem is likely what I mentioned above.

Link to post
Share on other sites
On 06/08/2020 at 06:36, Stephen CCleaner said:

We have something in the app that blocks use in trade-embargoed countries like North Korea or Syria. If the IP address Nord leases/purchased for its VPN service used to belong to an embargoed country, it's possible that the IP tables have not been updated by all geolocation services.

E.g. Syria sells one of its IP addresses to an ISP. The ISP assigns a new location, but perhaps doesn't notify all the Geolocation services of this change. Nord leases or purchases the IP address from the ISP (or even via an intermediary like a DataCentre). Products and services that check country location via a Geolocation Service that wasn't updated would still see the country as 'Syria'.

This can happen with any VPN provider. It's pretty routine to lease or buy new IP addresses. And IPv4 addresses are getting extremely rare and valuable these days as the internet 'runs out' (hence the move to IPv6).

You could confirm this hypothesis by trying to connect through other US VPN servers on Nord. If CCleaner starts working again when connecting through a different server (e.g. different VA server or different US State location), then the problem is likely what I mentioned above.

 

Thanks for the reply.  I took your advice and have tried numerous US servers, Canadian servers, Mexico, etc. and Nord also has an option for "compatibility purposes" to enable obfuscated servers, this also did not help.  Same issues, unable to run CCleaner from the recycle bin (hangs at 40% until disconnecting VPN), check for software updates, etc.

I'm at a loss for anything else to try.  At the moment, Nord's Windows 10 client does not allow for split tunneling of individual applications like they do on their Android client.  If this was available, I'd try this.

If at all possible, please escalate this issue on your end if you are able to have someone research it further.  This just suddenly started happening with a recent update and I've used both products on this workstation without issue for years.  VPN usage is commonplace these days so I hope it is something worth investigating/fixing.

I will also reach out to Nord to let them know of the issue and see if they can offer any solutions.

Nathan

Link to post
Share on other sites
  • Moderators
13 hours ago, nateinva said:

unable to run CCleaner from the recycle bin (hangs at 40% until disconnecting VPN), check for software updates, etc.


Not an offer of help here, (cos I don't know what the solution is), but is this only happening if you run CCleaner from the recycle bin context menu?

Do you see the same thing if you run CCleaner from the Desktop Icon, or from File Explorer?

Just trying to see if it may be connected to the bin in some way.

Link to post
Share on other sites
18 hours ago, nukecad said:


Not an offer of help here, (cos I don't know what the solution is), but is this only happening if you run CCleaner from the recycle bin context menu?

Do you see the same thing if you run CCleaner from the Desktop Icon, or from File Explorer?

Just trying to see if it may be connected to the bin in some way.

 

Hi, and thanks for your reply.  So I'm finding there is another issue in the mix of getting CCleaner to run properly.  The hang up of running the app either via context menu or opening and running manually is hanging up when it gets to the Clipboard.  If I disable Clipboard cleaning in CCleaner, the app runs fine from both the context menu and opening the app.  When it hangs up, it hangs CCleaner at 40% and the app becomes unresponsive until force quit.

That said, this is progress.  I still can't connect to any CCleaner domains or check for updates within the app while connected to the VPN.  Nord responded and gave me several things to try so I'll work on those.

I'll report back as I have time to check these things.

Link to post
Share on other sites
  • Moderators

I'm not sure but that may be because of the (newish) Windows multi-clipboard, if you are using that?

I believe that it saves clips in the cloud to a Microsoft server so that it can sync them to other devices.
I think there was some discussion about it when it first came out.
CCleaner can't touch cloud servers, they are protected, CCleaner can only clean you machines local storage.

Whilst it probably shouldn't hang like that, as you have already found your quick fix for that one would be to disable clipboard cleaning.

I don't know about the VPN issue, but like Stephen CCleaner I would suspect Nord have purchased a range of IPs that have been 'relocated' from a banned country.
We have seen that happen before more than once on this forum. Once reported by the user to the ISP they usually get them re-registered with the geo services pretty quickly.
So now that you have reported the issue to Nord it may simply dissappear in a couple of days if they re-register the IPs.

I will say that there are a core of users who actively try to prevent CCleaner from phoning home.
(Never realy understood that, why try to cripple something that you want to use?).
No doubt if you can find out why Nord is preventing the connections they would be interested.

PS. Many of the regulars here don't use the CCleaner in-app update, we check the announcements here for a new version and then download the slim installer from the builds page.
https://www.ccleaner.com/ccleaner/builds

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...