Jump to content
CCleaner Community Forums

Installs, but only runs immediately after install.


Recommended Posts

The last two versions (maybe three), will Install AND run correctly immediately after I install it.   After shutdown, then reboot (usually next day) Clicking the ICON or even going to the command line and RUNning it from the Directory does not run CCleaner.    I stopped using CC when this problem started hoping that the next release would fix the problem.  It didn't.  Again with the most recent version.

I have watched the task manger and it appears that it starts and immediately stops.

I am on Windows 7 home, 64bit  (no snickers, I have fewer issues than Win 10 users!).  McAfee AV - is up to date.   

Bob

 

 

 

 

Link to post
Share on other sites

I Just DELETED all CCeaner from both PROGRAM FILE directories.  (don't know why the most recent was in the 32bit Progfile??)   intalled and ran again.. and as I reported,  It ran only after the Install.  BUT This time, I ran the Registry Analyze  and noted an anomaly  with CCLEANER's start directory!

Sure enough,  the ICON had "C:\Program Files (x86)\CCleaner64.exe"  and that is where I find the 4 installed programs.   Shouldn't they be in their own directory?  CCLEANER ????

 

 

Link to post
Share on other sites
  • Moderators

When CCleaner runs once from the installer and then won't run again it is almost certainly the Antivirus that is stopping it running the second and subsequent times.
(It may even quarantine/remove the CCleaner.exe and CCleaner64.exe).

We saw this a lot with v5.68, where some AV's took a while to update their definitions for the new version.

Plus - You say that your AV is up to date, but is it?

With 5.68 Trend Micro AV users checked and it said they were up to date - but it was TM 2019 that was up to date. As soon as they went to the Trend website and updated TM to the 2020 version then their problem with CCleaner not running more than once disappeared.

No snickers, (I know what it's like to have to run an old OS) but does your particular McAfee AV still fully support Windows 7?
From their Knowledge Centre it would seem that it may not do:
 

Quote

 

Windows 7

    McAfee provides only "best effort" support for McAfee products installed on Windows 7.

 


https://service.mcafee.com/webcenter/portal/oracle/webcenter/page/scopedMD/s55728c97_466d_4ddb_952d_05484ea932c6/Page29.jspx?wc.contextURL=%2Fspaces%2Fcp&locale=en_US&articleId=TS102312&_afrLoop=99912195282898&leftWidth=0%25&showFooter=false&showHeader=false&rightWidth=0%25&centerWidth=100%25#!%40%40%3FshowFooter%3Dfalse%26locale%3Den_US%26_afrLoop%3D99912195282898%26articleId%3DTS102312%26leftWidth%3D0%2525%26showHeader%3Dfalse%26wc.contextURL%3D%252Fspaces%252Fcp%26rightWidth%3D0%2525%26centerWidth%3D100%2525%26_adf.ctrl-state%3D3mkm8iavk_9

You may want to try disabling (or uninstalling) McAfee and seeing if CCleaner runs then.

More importantly you may want to change your AV to one that does still fully support Win7.

Software not working fully/properly on Win 7 will only be an increasing problem now that Win 7 is end-of-life and many softwares will cease supporting Win 7.

 

Why CCleaner.exe was in \Program Files and not a CClearer folder I can't say for sure, had you at sometime done a custom install?
But when you say you deleted the fies did you just delete them or did you uninstall them?
If you only deleted the files then there will be registry entries left over. (Which could explain why it's re-installing in Program Files rather than a CCleaner folder).

Link to post
Share on other sites

Thanks for your help.   Win 7 may be end-of-life,  but I know too many Win 10 users telling me I should be glad I'm still on 7.

 After cleaning the registry of the reported errors,  The Install this time was good.  The ICON has all the correct values, and the CLEANER directory was created & filled in the correct place,"Program files (x86)" with it's files.

I can only guess that when one of the two prior versions installed, in the wrong PROGRAM FILES, (leaving the older version in (x86) that began a registry screw-up which persisted each time I added the newer version.   I don't think they'd be looking for multiple versions to clean out.     Could that had been at the heart of what they're blaming on an AV?


 

 

Link to post
Share on other sites
  • Moderators

Good to hear you got it sorted.

I think it's probable that at sometime in the past you (or someone else) has done a custom install of CCleaner and changed the install path to put it straight into Program Files without any CCleaner folder.
That 'redirect' would have been (correctly) noted in the registry and so any later installs would follow that redirect and be put there, and the desktop icon pointed to there.
Once you cleared that registry entry redirect the next install created the CCleaner folder as it should.

The problems with AV's not recognising new CCleaner versions are solely down to the AV's, it's been shown to be the case with more than one AV.
It's become more of an issue with lockdown and working from home, some AV companies are slower to update their definitions to recognise the new CCleaner version.
It was a bigger issue with v5.68 than it has been with v5.69, maybe they learned they were being a bit slow?
BTW it's not just an issue with CCleaner, we see it hapening with other softwares as well when they bring out new versions.

We see two problems with users checking within their AV and it telling them it is up to date,
Firstly all that meant was that it has the latest released definitions, and the AV company hasn't updated/released their definitions for the new CCleaner version yet.
Secondly when we told some of them that actually theirs wasn't the latest version of the AV, and that they should go to the AVs website to get the latest version, some didn't want to listen to us. Which is fair enough when their AV was telling them one thing but we were telling them the opposite. (But frustrating when you know that you are right).
As I said above we saw that quite a bit with Trend Micro 2019, once the user followed our advice and got the latest 2020 version from the Trend website all was fine for them again.

PS. Even Windows Defender has been having a False Positive moment the last couple of days and has been blocking some, but not all, installs of v5.69.
Microsoft are supposed to have updated that now.

Link to post
Share on other sites
  • 1 month later...

Well, turns out I didn't clear the problem..

I had uninstalled CCleaner.  Deleted the CCleaner directory from "Program Files" (the 32bit one),   Ran Glary Utilities to (hopefully) clean leftovers from the registry.  nothing seemed to be awry after the uninstall .. I then "Custom Installed"  CCleaner forceing it back to the "Program File (x86)" directory.. 
All *Seemed* to be good..
BUT - the next day, it didn't work..

I fiddled with it,, looked for anything in the registry that didn't look right (not understanding what to look for didn't help 😉


I finally discovered what does work -    If I click the desktop's CCleaner option, it doesn't work.   I can see the program start in TaskMgr, and immediately disappear.
Yes, the desktop's CClearner properties show it is in "Program Files (x86)" & CCleaner64.exe is set to run.

If I go directly to the CCleaner directory, and run CCLeaner65.exe, it does the same disappearing act..   UNTIL -- I run CCleaner.exe (the 32bit version)  .. it too fails BUT THEN ----
When I run CCleaner64.exe -- NOW IT WORKS!! 

What should I look for to correct this?

Bob K

 

Link to post
Share on other sites
  • Moderators

why are you forcing a 64 bit program into the special 32 bit folder. That might be to root of your issue, the x86 programs are virtualized (windows on windows).  See

https://social.msdn.microsoft.com/forums/vstudio/en-US/da6d3c29-6da8-4223-8e36-ea006d60f23d/whats-the-meaning-of-x86-and-x64-wow

Note running ccleaner.exe on a 64bit automatically hands over to ccleaner64.exe. The handoff might not work well if run from x86 folder

Edited by Nergal
Link to post
Share on other sites
  • Moderators

Iagree with Nergal, it shouldn't really be in the (x86) directory but I don't think that is your main issue.

What you report is typical of having an AntiVirus programme  that is not up to date.
In those cases CCleaner will run once from the installer, but then can't be launched again.

We've seen this quite often and one of the signs is that the last version of CCleaner that is able to run in those circumstances is CCleaner version 64, later CCleaner versions get blocked by the out of date AntiVirus.
This is because of various (security) changes that were made to CCleaner at that time which the out of date AV's don't recognise.

Trend Micro 2019 and Comodo Internet Security Premium v.12.0.6818 are two that are known to have this problem, but other AVs can also have the same issue.
Both will report that they are up to date if checked from within the AV itself, but there are newer versions available from the makers website.
Once the newer version is manually downloaded/installed the issue goes away.

Which AntiVirus are you using, and what version number is it?

Go to the AV makers website and check what the latest version is there.
(For instance Trend Micro 2019 will say that it's up to date, but the latest is Trend Micro 2020 which you sometimes have to get manually from the website).

Link to post
Share on other sites

Thanks, for the explanations, but I still need a better fix (work-around) than I've found.   (P.S. Nergal,  I Did NOT put CCleaner in the 32bit Program Files, it did wind up there!)

I have McAfee AV,  I can't find any version when brought up, and it's updated automagically.   I don't think that AV is the cause..   Even if it was, that's moot at this point.

If you go back to my first post -   the first time It didn't work  I found that my 64 bit version being called while installed in the "PROGRAM FILES" directory.. no idea how the previous install got there.  Let's just put that aside, and work on why it continues to NOT WORK --

I uninstalled it from that wrong directory, had to delete the CCleaner directory as re-install wanted to keep going back to the 32bit directory.   I created CCleaner subdirectory in "PROGRAM FILES (x86)" and custom reinstalled (forced) it there.    Didn't help.   CCleaner64.exe runs after the install but subsequent running it shows that it starts, but immediately stops.

But now I'd discovered that running the 32bit CCleaner.exe first (& it too fails),, BUT THEN the 64bit CCleaner64.exe NOW runs!!   (all done from the directory itself, not from the desktop)... Other clue was that the uninstall from 'program files' left the directory there, and a reinstall would go back to it!!? 

Was hoping this 'clue' would help explain what I should look for in the registry or wherever to get the proper fix...  There's something obviously bolloxed up in my system.

 

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...