Jump to content
CCleaner Community Forums

Unable to Retrieve Files from a Removable Drive


Recommended Posts

Hi,

I have just bought Recuva Professional because I want to retrieve files from an old external hard drive.  I used a free download (not Recuva) to scan the disk, so I know there are approximately 7,000 files that are candidates to be recovered.  However Recuva will not read the drive at all, but gives me an error message saying that drive cannot be read.  Has anyone else seen this issue ?

Cheers, Mark

Link to post
Share on other sites
  • 2 months later...

I am having the same problem. I purchased a full Standard licence, but when I try to open an external drive, I get "Unable to open drive". I am using Recuva Professional v.1.53.1087 (64 bit) On Windows 10.

 

Help...

Link to post
Share on other sites
  • 3 months later...
On 11/07/2020 at 02:01, Slade said:

I am having the same problem. I purchased a full Standard licence, but when I try to open an external drive, I get "Unable to open drive". I am using Recuva Professional v.1.53.1087 (64 bit) On Windows 10.

 

Help...

iam using the voll liecense recuve programm after deep scan when I used recovers files its come bug says that the files cant recovered becose the divece is not ready

Link to post
Share on other sites
  • Admin

This behavior most commonly happens when the drive is automatically 'spun down' because of overly aggressive Sleep/Hibernation settings. To avoid this from happening, you take the following steps to disable "Turn off hard disks" and to disable Sleep/Hibernation modes:

 

  1. Click Start > Control Panel > Power Options (or, on newer versions of Windows, click Start > type Power Options > click 'Edit Power Plan' and move to step 3)
  2. Next to your selected power plan, click "Change plan settings"
  3. Click "Change advanced power settings"
  4. Expand the Hard Disk section > Turn off hard disk after
  5. Change the setting to Never
  6. Expand the Sleep section > Sleep after
  7. Change the setting to Never for "On Battery" and "Plugged in"
  8. Expand the Allow hybrid sleep section
  9. Change the setting to Off for "On Battery" and "Plugged in"
  10. Expand the Hibernate after section
  11. Change the setting to Never for "On Battery" and "Plugged in"
  12. Expand USB Settings > USB selective suspend settings
  13. Select "Disabled" from the drop-down
  14. Click Apply > OK.
Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...