Jump to content
CCleaner Community Forums
Sign in to follow this  
Marc R

Auto extension cancellation doesn't work

Recommended Posts

Hi,

I want to cancel my registration to Ccleaner by the end of the year and the "cancel" button in the subscription manager has just no effect on the "Auto Extension" criteria which remains "Enabled" whatever I do...

Any suggestion please ?

THX

Share this post


Link to post
Share on other sites

Do neither of these ways work?

https://support.piriform.com/hc/en-us/articles/360020931831-How-do-I-manage-my-CCleaner-subscription-

Share this post


Link to post
Share on other sites
On 19/04/2020 at 09:49, Marc R said:

Hi,

I want to cancel my registration to Ccleaner by the end of the year and the "cancel" button in the subscription manager has just no effect on the "Auto Extension" criteria which remains "Enabled" whatever I do...

Any suggestion please ?

THX

@Marc R: I just checked your records and the good news is that your auto-extension was indeed cancelled with Cleverbridge. I can see that Cleverbridge seems to have sent you an email to that effect on the 17th.

image.png

Your concern is completely understandable, however, as on the CCleaner subscription management centre it contradicts this and it does still show as active, even though it is not.  

There does seem to be an issue impacting a number of users where under certain circumstances, the subscription management centre can incorrectly show you as still subscribed, even though you cancelled. The chain of events that can cause this seems to be if you cancel directly with Cleverbridge from link in the the billing reminder email when the connection from Cleverbridge to CCleaner's systems is interrupted at that particular moment.  Then when you check your subscription information from the CCleaner side it doesn't know that you cancelled, and when you click the cancel button it throws a silent error since you already cancelled.  The customer then angrily shouts at our long-suffering customer support team (thanks for skipping that step, by the way 🙂 )

TL;DR version: It's basically a display bug - don't worry it was cancelled

 

Share this post


Link to post
Share on other sites

Hi guys,

Thank you for your help !

I must add I was really satisfied of Cleverbridge products, as I subscribed to MalwareByte too, but I need to abandon these products cause I'm moving on Linux.

Good bye !

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...