Jump to content
CCleaner Community Forums

Cannot defrag free space

Recommended Posts

There's a block of $UsnJrnl:$J file near the end of my drive and the defraggler tried to move it to fill up free space in the middle of the drive

The file is not moved but the defraggler continue trying to move it to the next block of free space (the $UsnJrnl:$J block blink yellow and the green block slowly move across the free space block one by one but nothing is written in those empty block)

This process continues until the program finished defragment with the free space still scattered across the drive.

I also notice that the $UsnJrnl:$J file is 7 GB and has only 1 fragment but it took only 1 block which seems strange



I tried to move some files to the end of the drive and defrag free space again
Somehow, it's work and the program filled in all the gap with small files. However, when it reach the large free space area it continue trying to move the $UsnJrnl:$J file.

Here's the current screenshot (the $UsnJrnl:$J file still located near the end of drive)


Edited by PC2
Link to post
Share on other sites

Put in a system restore point first as a safety net.

Then I'd run System File Checker (SFC): Run > cmd > "sfc /scannow"

No quotation marks of course.

Hopefully no system file problems will be found but if it does it may repair them.

Next I'd run CHKDSK without repair options* (as it is your primary drive) and see if it reports anything about the USN Journal (Update Sequence Number Journal). That is what that file appears to be. 

If it does find a problem then try scheduling CHKDSK to run on next boot with repair options.

*Computer > C drive > Right Click > Properties > Tools tab > Check now, untick the repair options and click Start.

For boot time do the same thing but tick the repair boxes, When you click Start it will give you the option to schedule the scan at next boot.


Link to post
Share on other sites

- "$UsnJrnl:$J" is one of those many system files used by the NTFS filing system and contains (like the other files that start with a "$") socalled metadata. And Defraggler is unable to move and/or defrag that kind of files.

- One thing that COULD help is to use an option in CCleaner called "Wipe Free Space". That option will FORCE the disk management system to compact and/or re-wite those socalled "Metadata" files.

Link to post
Share on other sites

^ Yes, agreed.

However, that does mean there must be something wrong if Defraggler is trying to defrag it.

My concern was/is either that it is corrupted or that the HDD may have a bad sector and it needs to be moved and the sector identified so it is not written to again. CHKDSK should do that. 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...