Jump to content
CCleaner Community Forums

CCleaner 5.61 Installs Incorrectly in Windows XP


Recommended Posts

When installing CCleaner 5.61 in Windows XP, the installation gets botched!  Upon starting the installation, it doesn't present the installation start-up options screen allowing you to select install options, nor does it present the next screen showing the install process, and after about 5-10 seconds it appears to be done (according to my task manager CPU, Processes, and hard drive activity). After this, there is no CCleaner listed in the Start Menu Programs, nor no shortcut icon on the desktop. Checking Add/Remove Programs, the CCleaner entry appears, but has no information, and trying to uninstall it, results in an error. I discovered that instead of it creating a CCleaner folder in the Program Files folder and installing the files there, it instead installed the files into the root of C drive with no folder. It also fails to create a correct Windows Registry entry in HKEY_LOCAL_MACHINE/SOFTWARE/Piriform/CCleaner with missing, incorrect, and blank registry keys. I was only able to uninstall it by referencing another Windows XP machine that had CCleaner 5.60 and manually recreating the what should have been there with a proper installation, including recreating the Windows Registry entries similarly. I rebooted, then went into the recreated Program Files/CCleaner folder and double-clicked on "uninst.exe". I then rebooted, and next did a manual search for any files referencing "ccleaner" and "AU_exe" and deleting all of them, and then in Windows Registry, by searching for "ccleaner" and "ccsetup", and "AU_.exe" and deleting those key entries as well. I again rebooted, and afterwards gave it one more try, but still got the same result. So, I repeated everything again, but this time I re-installed CCleaner 5.60 and everything was perfect. Could you please fix this, as I'm a fan of CCleaner and would like to continue using it on Win XP as well as on Win 7 and Win 10. Thanks.

Link to post
Share on other sites
  • Moderators

See this official post on a "possible solution" although I don't know if the issue is related or the same you're having but it's something they changed in the Standard installer that isn't compatible with WinXP:
https://forum.piriform.com/topic/54880-cant-uninstall-ccleaner/?do=findComment&comment=310286

Link to post
Share on other sites

 ^ Yes.

First, delete any remaining files with Revo Uninstaller and reboot your PC.

https://www.revouninstaller.com/

Then, either install the Slim version or use the Portable version of CCleaner.

https://www.ccleaner.com/ccleaner/builds

In my case, it worked.

If you're not satisfied with this solution, then I can only recommend going back to version 5.59.7230 (or 5.60, as you said in your OP).

Cheers.

Edited by Sniktbub
adding url codes
Link to post
Share on other sites
  • Admin
6 hours ago, Dave CCleaner said:

There is supposed to be OS detection on the standard download page to automagically redirect XP users to the Slim build

... an update on this, the auto-routing of XP users to the slim build will be released next week.  The issue with Windows XP for CCleaner 5.61 and 5.62 is only with the full installer

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...