Jump to content
CCleaner Community Forums

Installer "frozen" with ads blocked


Recommended Posts

Hi, I run an ad-blocking script in my router, and this seems to be causing the CCleaner installer to take a long time to run. First it remains in the background with no visible window for about 1-2 minutes, then the main screen appears which is again "frozen" for a while. I'm guessing this is the result of blocking PUP malware. (Avast etc)

 

2019-06-11 - 10.08.19 ~ Cropped Capture.png

Link to post
Share on other sites
  • 3 weeks later...
1 hour ago, Nicon said:

Your permission buttons are disabled from looks like process explorer. Lets start by rights? Ransomware enabled?

Nope, it's all about the PUP getting blocked. I'm guessing the installer has a long timeout to resolve and connect to the hosts where to retrieve the malware (avast etc).

Link to post
Share on other sites
  • Admin
34 minutes ago, Himeko said:

Nope, it's all about the PUP getting blocked. I'm guessing the installer has a long timeout to resolve and connect to the hosts where to retrieve the malware (avast etc).

That is not how it works. The full installer may display an offer that the bottom of the install screen, but if that does not appear you would still get the rest of the screen loading, enabling you to continue.  The slim build has no additional offers to retrieve at all.  Sounds like something else is afoot with your system configuration that is causing your problems.

 

Piriform Homepage - [CCleaner - CCleaner Mac - CCleaner Android - CCleaner Browser - Defraggler - Recuva - Speccy - Kamo] - Product Support

Looking for your licence key, expiry date or download link? Check here first: https://www.ccleaner.com/support/license-lookup

To find out how we protect your privacy - read CCleaner's Data Factsheet.

Link to post
Share on other sites
11 minutes ago, Dave CCleaner said:

That is not how it works. The full installer may display an offer that the bottom of the install screen, but if that does not appear you would still get the rest of the screen loading, enabling you to continue.  The slim build has no additional offers to retrieve at all.  Sounds like something else is afoot with your system configuration that is causing your problems.

 

Well check this video, the installer works after I disable the adblocker.

https://streamable.com/x8sjb

Link to post
Share on other sites
  • Admin

While we are all in favour of ad-blockers (we're even starting to offer the functionality ourselves), if an ad blocker has been configured to additionally block things that aren't ads then you may find it interfering with the legitimate function of other software.

Piriform Homepage - [CCleaner - CCleaner Mac - CCleaner Android - CCleaner Browser - Defraggler - Recuva - Speccy - Kamo] - Product Support

Looking for your licence key, expiry date or download link? Check here first: https://www.ccleaner.com/support/license-lookup

To find out how we protect your privacy - read CCleaner's Data Factsheet.

Link to post
Share on other sites
5 hours ago, Dave CCleaner said:

While we are all in favour of ad-blockers (we're even starting to offer the functionality ourselves), if an ad blocker has been configured to additionally block things that aren't ads then you may find it interfering with the legitimate function of other software.

Sorry but I disagree. The adblocker runs in the router itself, it does not interfere with the process in any way, only in the network connections outside of the machine. Why should the CC installer freeze for 2 minutes when it can't connect?

This is CC with adblocker on:

uuKmeYr.png

then CC without adblocker:

y7w0c8n.png

slim installer also attempts to connect:

eB4b6cj.png

K0DXJ6p.png

why does the slim installer connect to avast if it does not include any PUPs?

Link to post
Share on other sites
  • 1 month later...
Guest
This topic is now closed to further replies.
×
×
  • Create New...