Jump to content
CCleaner Community Forums

shutdown.exe /s /t 00 And CCleaner Startup Problem


Recommended Posts

I subscribe for  CCleaner Professional Version 5.46.6652 (64 Bit). I am using Updated Windows 10 Pro.

Now I am using Version 5.47.6716 as it Automatically Updated. 
I store CCleaner in F:\Applications\Piriform\CCleaner. 

I use command for Shut Down my Laptop. Command is 'shutdown.exe /s /t 00'.
When I use command & Shut Down my Laptop, then after start, I can see there is No CCleaner automatically start. 
But When I Shutdown my Laptop by 'Select Start and then select Power > Shut down', then CCleaner start normally. 

I found 4 ways to find out startup apps. 
1. 'shell:startup' 
2. Settings - Apps - Startup 
3. Startup tab of Task Manager 
4. Registry (In it, HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Run) 
All Screenshots, here I attached. 
You might ask me why you use shutdown command, my answer is 
1. https://social.technet.microsoft.com/Forums/windows/en-US/3a6a2ed8-c6e2-4941-a31c-f1ca5b2a450c/why-shutdown-doesnt-reset-the-quotup-timequot-counter?forum=win10itprogeneral 
2. https://www.winhelponline.com/blog/incorrect-uptime-taskmgr-wmi-refresh/

So after study these 2 links I started to use shutdown command.

For CCleaner related:- If other apps works perfectly as per instruction even after shutdown command, why CCleaner not? 
Need to debug it & find out root cause of this scenario. 

When I 'Request' to Customer Support, I got Answer as follows:-

At 07-Sep-2018 "As for the rest, it may indeed be a bug so I will submit it to development for further research." And marked Request as Solved.

When I asked about 'Solved' Status, I got Answers as follows:-

"You have not received an update to this because you wouldn't anyway. But besides that, it could realistically takes months for development to get around to looking at this particular issue since you are the only one who has reported it.
As I said previously, this is most likely just a limitation of the Windows OS when the command prompt is used to shutdown the computer, it shuts it down completely.
I will send a nudge to development, but I would not expect a personalized update on it. It will probably be announced in the Newsletter for the particular version that it is finally addressed on."

If in this forum anyone know the work around for this please write here as answer.
Waiting for reply. 
Thanks,

startup_by_registry.jpg

startup_by_settings.jpg

startup_by_shell_command.jpg

startup_by_task_manager.jpg

Edited by Mandar Khire
Story was incomplete. now Complete.
Link to post
Share on other sites
  • Moderators

You could try a workaround, that is have CCleaner automatically clean and shutdown the computer for you, it's in the documentation here. Then when you start your computer again see if that fixes the issue.

Example:

"F:\Applications\Piriform\CCleaner\CCleaner.exe" /AUTO /SHUTDOWN

 

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...