Jump to content
CCleaner Community Forums

System restore points are missing

Recommended Posts

Hi sethm1:

Just to clarify, there are lots of new bugs in CCleaner v5.45, especially with the Active Monitoring feature in the 64-bit ccleaner64.exe version (see Ron2017's thread Piriform Personal Security Concern with CCleaner Latest v. 5.45.6611 for a good discussion), so I'm not actually endorsing that you use CCleaner Portable v5.45.  I only wanted to report back and let you know that my 32-bit CCleaner Portable v5.45 doesn't seem to be wiping my system restore points like the previous version.

I'm not a big fan of Privacy Eraser either - especially the fact that users can only see a summary of the number of items that will be cleaned and total disk space recovered but can't view a detailed list of each file and/or registry items that will be deleted during the disk clean.  I was just using Privacy Eraser to monitor my system restore points while testing CCleaner because I wanted to make sure that my system restore points would continue to accumulate after I stopped using the previous CCleaner Portable v5.44 on 10-Jul-2018.
32-bit Vista Home Premium SP2 * Firefox ESR v52.9.0 * Norton Security Premium v22.14.2.13 * Malwarebytes v3.5.1-1.0.365 * CCleaner Portable 5.45.6611 * TreeSize Free Portable v4.1.2.407

Link to post
Share on other sites
  • Moderators

I also have to say that there have now been 3 'cumulative updates' to Windows 10 1803 this month, which have totally buggered up trying to work out what is going on with RPs.

Link to post
Share on other sites
2 hours ago, nukecad said:

I also have to say that there have now been 3 'cumulative updates' to Windows 10 1803 this month, which have totally buggered up trying to work out what is going on with RPs.

Hi nukecad:

Extended support for my Vista SP2 OS ended on 11-Apr-2017.  That's not a good thing from a security standpoint but it makes troubleshooting third-party applications much easier for me since I haven't had any updates for Vista SP2 / IE9 delivered via Windows Update since April 2017.  As previously noted, all my testing over the past month has pointed to CCleaner Portable v5.44 as the cause of my volsnap errors and disappearing system restore points on my 32-bit machine - just too bad no one from Avast / Piriform has shown any interest in helping us diagnose the problem.
32-bit Vista Home Premium SP2 * Firefox ESR v52.9.0 * Norton Security Premium v22.14.2.13 * Malwarebytes v3.5.1-1.0.365 * CCleaner Portable 5.45.6611 * TreeSize Free Portable v4.1.2.407

Link to post
Share on other sites
On 7/28/2018 at 17:10, lmacri said:

Good news.  I've been testing 32-bit CCleaner Portable v5.45 since 26-Jul-2018 and so far this latest version hasn't wiped any system restore points (RPs). I have a few more tests to run so I'll post back later if my RPs start disappearing again.,,

One thing I did differently this time is that when I unzipped ccsetup545.zip on my USB drive I did not copy over the ccleaner.ini file I was using with v5.44.  Instead, I ran CCleaner Portable v5.45 to generate a brand new ccleaner.ini file and then re-configured all my personalized settings from scratch.  Is it necessary (or at least a best practice standard) to create a new ccleaner.ini file every time CCleaner Portable is updated?  It's difficult for me know if there was a bug in v5.44 that was deleting my RPs and/or the registry keys that were pointing to my RPs when no one from Avast/Piriform has shown any interest in viewing a debug log.

Can anyone answer my question about whether it is necessary to create a new ccleaner.ini file and re-customize configuration settings every time CCleaner Portable is updated?

Stephen Piriform posted today in Changes in v5.45 and Your Feedback that CCleaner v5.45 has been pulled and the old v5.44 installers have been re-posted to the download page at https://www.ccleaner.com/ccleaner/builds.  It's good to see that Avast has agreed to address the obvious problems with Active Monitoring in v5.45, but I don't want to revert back to v5.44 when I've provided evidence in this thread that the 32-bit CCleaner Portable v5.44 was silently wiping my system restore points.
32-bit Vista Home Premium SP2 * Firefox ESR v52.9.0 * Norton Security Premium v22.14.2.13 * Malwarebytes v3.5.1-1.0.365 * CCleaner Portable 5.45.6611 * TreeSize Free Portable v4.2.1.470

Link to post
Share on other sites
  • Moderators

No you don't have to recreate ccleaner.ini the only files in the portable zip are: lang files; ccleaner.exe; ccleaner64.exe; portable.dat; and license.txt

No other files are erased or overwritten. Conversely you can delete any file not those files from your ccleaner folder.

You can even delete any language files you don't need. If english no language file are needed at all.  This fact about language files is true for non-portable too.

Link to post
Share on other sites
  • 3 weeks later...
On 7/11/2018 at 08:45, lmacri said:

Further to my post <here> of 08-Jul-2018, I have more evidence that this problem could be associated with CCleaner v5.44.

I ran CCleaner v5.44 the mornings of 08-Jul-2018 and 09-Jul-2018.  I had ~98 GB of used disk space the morning of 10-Jul-2018 but when I checked again in the evening my used disk space had dropped by about 10 GB to 88 GB, there was another volsnap error in my Event Viewer, and the vssadmin list shadowstorage command showed 0 GB of my allotted 33 GB of disk space for restore points (RPs) was being used (i.e., all my RPs had been wiped)....

I have no idea if any Piriform/Avast employees are monitoring this thread, but I felt I should post another update now that v5.45 has been pulled from the download servers and v5.44 (i.e., the version that wipes my restore points) is now the "recommended" version.

I haven't had any further volsnap errors logged in my Event Viewer since I stopped using CCleaner Portable v5.44 on 10-Jul-2018.  The vssadmin list shadowstorage command shows I've continued to accumulate restore points since then and I maxed out my allotted 33 GB of reserved disk space on my C:\ drive some time around 12-Aug-2018...


..and my current CCleaner Portable v5.35 shows I currently have 15 restore points dating back to 26-Jul-2018.  As expected, my oldest restore point is deleted before a new restore point can be created now that I've maxed out my allotted disk space for saving restore points.


Just an FYI that I decided to roll back all the way to CCleaner Portable v5.35.6210 (rel. 20-Sep-2017) using a ccsetup535.zip file I found on my external backup drive.  This version was released after the bundled Floxif malware of v5.33 and has newer digital signatures than v5.34 but does not include unwanted features like the Emergency Updater of v5.36, intrusive pop-up advertisements of v5.44 or the Active Monitoring that runs continuously in the background (even when disabled) of v5.45.
32-bit Vista Home Premium SP2 * Firefox ESR v52.9.0 * Norton Security Premium v22.15.0.88 * Malwarebytes v3.5.1-1.0.365 * CCleaner Portable v5.35.6210
HP Pavilion dv6835ca, Intel Core2Duo T5550 @ 1.83 GHz, 3 GB RAM, NVIDIA GeForce 8400M GS

Link to post
Share on other sites
  • 5 months later...

Windows 7 SP1

Recently, I've been encountering this same problem (auto-deletion of Win7 Restore Points — all of them).

I think it's a Ccleaner issue, but I have to admit I'm not sure.

In any case, I have:
• uninstalled Ccleaner v5.52 (using Revo Uninstaller Pro)
• searched the HDD for any Ccleaner remnants and deleted them (I found only one Prefetch file)
• shutdown and restarted the computer (power OFF/ON)
• rolled back to Ccleaner v5.46 (an arbitrary choice, made simply because that version is about 1 year old...)

It will be interesting to see if this problem persists using v5.46.

I will post an update to let everyone know how things turn out.

Link to post
Share on other sites
  • Moderators
9 minutes ago, PCFYTV said:

Well, that didn't work: using v5.46, the same problem cropped up again, literally within minutes.

It might well be Windows itself, not Ccleaner, but I think I'll follow lmacri's lead and try v5.35.

We'll see if that does it.

Do you have wipe free space enabled in ccleaner's system tab advanced section?

Link to post
Share on other sites

Do you have wipe free space enabled in ccleaner's system tab advanced section?

No: all of the Advanced items are disabled.

I mainly accepted the Ccleaner defaults for all the rest.

The additional items I enabled were under IE and Chrome  (e.g., Saved Passwords).


Link to post
Share on other sites

Unfortunately, rolling back to v5.35 didn't solve the problem.

Not sure what's causing it, but a little research suggests it's pretty common — and very difficult to solve

I keep a backup of my files on an older, external HDD with insufficient space for an image of the c-drive, so I think I'll get a new, larger external drive for exactly that purpose.

Either that, or a new PC.

I think Windows 7 is great, but its days are clearly numbered, and everyone likes a new ride.

Link to post
Share on other sites

Sometime back so firget which version of CC and thus does not matter, I uninstalled CC and for a few days concluded its not CCleaner but windows 10 itself.  I gave up. I back up stuff to the cloud and a second hard drive and use Aoemi backerupper, so when this pc dies, not the end of the world.

Link to post
Share on other sites
13 hours ago, PCFYTV said:

Unfortunately, rolling back to v5.35 didn't solve the problem.

Not sure what's causing it, but a little research suggests it's pretty common — and very difficult to solve...


One hint about your troubleshooting.

As I noted <here> on 04-Jul-2018, my system restore points are intermittently wiped when my system tries to create a system restore point (SRP) and a volsnap error occurs after newer versions of CCleaner are run (i.e., not while CCleaner is running).  I'm still not certain of the cause, but it almost seems like newer versions of CCleaner reset a configuration setting / registry entry or run a background task that triggers a volsnap errors the next time my system tries to create a SRP. That means that if I'm testing a particular CCleaner version (e.g., CCleaner Portable v.5.35) I have to run that same Cleaner version for a few weeks or so and monitor whether my SRPs are being deleted. According to  Tomasz Szynalski's old blog post What You Should Know About Volume Shadow Copy/System Restore in Windows 7 & Vista (FAQ):


"With the default settings, there is no guarantee that shadow copies will be created regularly. In particular, Windows 7 will only create an automatic restore point if the most recent restore point is more than 7 days old. On Windows Vista, the minimum interval is 24 hours, but remember that the System Restore task will only run if your computer is on AC power and idle for at least 10 minutes, so it could take days before the conditions are right, especially if you run a lot of background processes or do not use your computer frequently."

That blog post also states that  "if you use your machine every day on AC power and nothing prevents it from entering an idle state, you can expect automatic restore points to be created every 1-2 days on Windows Vista and every 7-8 days on Windows 7".  Other conditions will trigger the creation of a SRP (e.g., before Windows Update applies a system update), but it might take to a long period of testing to figure out exactly what's deleting the SRPs on your Win 7 SP1 machine.

I can't say with 100% certainty that newer versions of CCleaner are responsible for my volsnap errors but I haven't been able to correlate anything else so far (e.g., a Malwarebytes Free Threat Scan, Norton Security Automatic LiveUpdate, etc.) with my volsnap errors.  By default, scheduled SRPs are normally created during system idles on my Vista SP2 machine so I have always suspected that some background task that runs during a system idle is the culprit.
32-bit Vista Home Premium SP2 * Firefox ESR v52.9.0 * Norton Security Deluxe v22.15.1.8 * Malwarebytes v3.5.1-1.0.365 * CCleaner Portable 5.35.6210

Link to post
Share on other sites

Hi lmacri,

Thank you for your post.

Event Viewer showed two errors during the time periods I lost all of my SRPs:
(1) Error 14, volsnap (which is apparently HDD-related)
(2) Error 27 (which was related to the Ethernet Adapter — which in turn I disabled because I don't use it)

Error 27 is now a thing of the past.

Error 14 Message:
The shadow copies of volume C: were aborted because of an IO failure on volume C:

Googling Error 14 and that message suggested the HDD has had it.

But I also gathered there might still be hope, so I ran:
chkdsk /f (HDD 'PASSED' — only 4 kb in "bad sectors", which is apparently no big deal, if not a 'normal' result)
Western Digital Data Lifeguard Diagnostic (Quick Test — again, the HDD PASSED)
sfc /scannow (just in case)

For a short while, it looked like that might do it.

A few hours later, all my SRPs were gone again.

I might try running:
chkdsk /r

If that doesn't 'fix' it, I would guess it's true the HDD is failing.

Either that, or it's entirely beyond me — which is likely.

I do OK banging on Windows computers from the front end, but I am no expert on the Windows OS, much less hardware diagnostics/repair.

Also, a new HDD might solve the problem, but not if it's in Windows: it would carry over to the new drive.

In that case, I would have to 'recover' the computer from the OEM files, remove the included junkware, update Windows, reinstall/update all the other software I have, and probably do a few other things that don't come to mind right now.

I'm not sure it's worth it; Microsoft has basically said win7 will soon be toast (no more updates or support beginning next year).

I should probably just buy a new PC, but I'll have to think about it (no doubt chkdsk /r would give me time for that...lol)

Meantime, thank you for your assistance.

Link to post
Share on other sites


Since I've become virtually obsessed with this issue, I searched for, found, and tried a couple of other 'solutions' to
the problem (i.e., *ALL* System Restore Points being auto-nuked in Win7).


(1) c|net • Windows 7 forum — Why are my Windows system restore points disappearing?

"System Restore Points" (Posted by hideout587 | JUNE 25, 2010 10:07 AM PDT)

While I do not run Windows 7, I did have this same problem a while back with my two of my Windows XP (SP2) systems, as well as on my old Windows ME system. Each system had different problems/resolutions and I will give you each one that worked for me. Hopefully, there is something I will detail below that will also work for your Windows 7 system...

-=Resolution 1: The most likely culprit is that the System Restore folder has been corrupted somehow. Going on this assumption, do the following (note that you will lose any and all previous restore points you might still have by using this method)

a. Right-click My Computer> Properties, then click on the System Restore tab.
b. Check the box that says "Disable Restore on all drives"
c. Click "Apply" then reboot your PC. (you will be prompted to reboot)
d. After the system fully reboots, go back to the System Restore tab again and uncheck the "Disable Restore on all drives" box.
e. Reboot once more.
f. After the second reboot, go to Start > Accessories > System Tools > Restore and choose "Create a Restore Point"
g. Name the restore point whatever you wish (Date and time will be automatically added)
h. After the restore point has been created (assuming without error), go back to Start> Accessories> System Tools> Restore and choose "Restore my computer to an earlier date and time". Select the restore point you created.

If all goes well, you should receive a message that the system has been successfully restored.

-=Resolution 2: [missing from post...]


(2) Microsoft Technet Forums — System Restore and lots of errors!

"Answers" (Posted by Thomas77 | Monday, February 15, 2010 5:22 AM)

Step 1: Remove all restore points
1. Click start button, right click computer and choose properties.
2. Click Advanced system settings.
3. In system protection tab, select the available drives which has protection on, click Configure, click "Turn off system protection".
4. Then turn on the Protection. 

Step 2: Restart Volume Shadow Copy Service
1. Click start button, type in services.msc and then press enter.
2. locate  Volume Shadow Copy Service and double click.
3. Click stop button to stop the service. Then click start to restart it.


Unfortunately, neither of these procedures worked for me; my SRPs continue disappearing, including those created manually; the SRPs on my system only 'last' a few hours — at most — then *ALL* of them evaporate into the ether.

I am posting these references/procedures here in the hope that one or both might help someone else on this forum.

Link to post
Share on other sites
  • Moderators

Are any of you using any 3rd party disk defragmenting software? Disk defragmenting programs (especially those that are old) which haven't been updated to be VSS compatible can cause restore points to go missing, etc., even those that have VSS compatiblity can still cause issues. One defrag program (Puran) recommends in their VSS compatiblity guide to disable defragmenting files above 128 MB, and even more thoroughly to format the disk with a 16K cluster size. Allot of effort to keep restore points in my opinion.

Link to post
Share on other sites
3 hours ago, Andavari said:

Are any of you using any 3rd party disk defragmenting software?...

Hi Andavari:

No, I don't have any third-party defraggers like Piriform's Defraggler or Auslogics Disk Defrag installed and both defrag tasks in my Norton Security antivirus (Settings | Task Scheduling | Automatic Tasks | Disk Optimization and Settings | Administrative Settings | Idle Time Optimizer) are disabled.

I actually stopped using Piriform's Defraggler several years ago because it started wiping all my system restore points - see my 2014 thread Full Defrag Wipes All Restore Points. I eventually found a workaround (i.e., enable the option to Replace Windows Disk Defragmenter, close Defraggler, and disable the option again) but this bug was never fixed and I got fed up having to remember to toggle this setting every time I updated Defraggler .

From the last post <here> in my 2014 thread:


"Piriform Support have also been running test defrags with Vista.  Their results show Used Shadow Copy disk space increasing over the course of a Defraggler full disk defrag even when VSS is disabled, and that the number of restore points deleted at the end of the defrag depends in part on the max. space allocated for restore points (which can be adjusted with a command similar to "vssadmin resize shadowstorage /For=C: /On=C: /MaxSize=40GB"). Test results have been passed on to the developers and Piriform Support's last e-mail stated that 'hopefully we will be able to have this fixed in a future version'. "

32-bit Vista Home Premium SP2 * Firefox ESR v52.9.0 * Norton Security Deluxe v22.15.1.8 * Malwarebytes v3.5.1-1.0.365 * CCleaner Portable 5.35.6210

Link to post
Share on other sites

Defrag isn't an issue in my case, either.

For example,
• If I manually create a System Restore Point, it disappears within a few minutes to several hours — with no defrag in between
• If I manually create more than one SRP, all of them evaporate just as quickly
• If Windows automatically creates a System Restore Point, the same thing happens

So, are the SRP files corrupted?

Apparently not.

The "System Restore Points" solution above that was originally posted by hideout587 @ c|net forums includes the manual creation of an SRP, then testing it after reboot by using it to restore the system.  This worked just fine, but that same SRP was auto-deleted soon afterwards (again, within a few hours).

As far as Ccleaner goes, I thoroughly uninstalled it, and the problem persists.

I would therefore conclude:
• Ccleaner isn't the issue
• Disk Defrag isn't, either

In addition, other 3rd-party 'optimization' software isn't the culprit because I am not using any.

So, what about malware?

Possible, but it appears unlikely.

I deep-scanned the system with Microsoft Security Essentials, MalwareBytes, and Comodo AV, and found nothing.  That doesn't mean absolutely nothing is there, of course, but at least it's good for a few warm fuzzies.

I might try more Google-mining for other ways to fix this, but I should probably just drop it.  If the system dies altogether — by whatever means — then fixing it would likely cost a significant fraction of the price of a new PC.  That doesn't seem worth it since the one I using now is fast approaching obsolescence.

If instead my obsession continues and I find a solution, I will post it here.  Meantime, I see Windows 10 coming my way sooner than I thought...  (Or hoped — lol)



RE: Ccleaner Uninstall (mine, not in general)

I did this primarily because of the privacy concerns raised here and elsewhere on this site.  I've used Ccleaner for years now and liked it, but I am none too keen on the idea that it is (or even might be) secretly collecting any data from my computer.  If I had known about it sooner, I would have dumped Ccleaner already.

Alternative to Ccleaner

Its replacement (for now at least) is [competion].  The interface is primitive, but I just need a good browser wiper.  Most of the other items don't really concern me, so I left them unchecked.  Moreover, it doesn't appear that [competition] comes with any kind of spyware.

Besides, if [competition] is good enough for Hillary, then it's good enough for me (lol)

Edited by Nergal
competition software name
Link to post
Share on other sites

- Interesting that work-around.

- This reminds of something else. In a different thread someone reported that without System Restore active, Defraggler ran (much) faster on his (her ??) Windows 10 system.



Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...