Jump to content
CCleaner Community Forums

Recommended Posts

I have Windows 10 version 1703 (because I don't have enough available memory to upgrade to the latest version) and for the first time today, I can't install the CCleaner download 5.43 because I didn't get it from the Windows store. I've been downloading and installing CCleaner updates regularly, and this just happened. Do you have this issue or something else?

Edited by Nonnamarg
typo for Windows 10 version
Link to post
Share on other sites
  • Moderators
5 hours ago, jengr2015 said:

Does this version have problems for just windows 10 users or does it have problems for everyone?

have a quick squizz around the forums and you'll discover a few issues with various members.

let's just say the Dev Team must be pulling some long shifts.;)

Link to post
Share on other sites
  • Moderators

To balance this I have Win 10 1803 and have no functional problems with CCleaner (free) at all.

The thing is that Personal Computers are, well personal. Meaning they are all different and are set up slightly differently, with different programmes installed, etc..

Often when you get a lot of reports about a problem the first job is to try and work out what is common between those having the issue.
It's usually one other programme (often an Anti-Virus) that all the affected users are using that is causing a clash.

(Most of the recent problems seem to have been a clash between CCleaner and Kaspersky - Another thread reported yesterday that this has been fixed by the latest Kaspersky update).

Having said that; Windows 10 is bit of a problem for all programme developers.
Gone are the days when there were a number of years between major changes to Windows with a new version.
Win 10 is evolving all the time, with major functional updates every six months.
This keeps programme developers on their toes as they try to keep up with what Microsoft has changed this time.

Link to post
Share on other sites

Thanks for the responses! I am running windows 8.1 and still using ccleaner version 5.40. I wanted to make sure that version 5.43 was working correctly before installing. I guess that I will go forward and install it. Again thanks for the responses!

Link to post
Share on other sites
  • Moderators

you are right, you won't know until you start walking that path.

it is varying per user so for you, it may be fine.

but the current list of issues seem to be with Chrome, with Kaspersky, with Macs, with SSD's, installing Avast, not installing CC, with MB3, I think that's the main ones... :)

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...