Jump to content

Portable version - link to 'builds' page not working


Recommended Posts

How to obtain ccsetup542.zip  ?

I seem to be circling around, back and forth on the Piriform website, but am not getting on the  'builds'-page.
Even when doing a Google search for   ccsetup542.zip  and clicking on the displayed URL ( https://www.ccleaner.com/ccleaner/builds )
it will get me on: https://www.ccleaner.com/ccleaner/download/portable  and from there immediately to https://www.ccleaner.com/

I prefer to use the portable version.

(also tried another browser, so I guess it is not a browser-issue)

Link to comment
Share on other sites

  • Moderators

Just downloaded portable from builds page as a test and had no problem. (Opera browser)

Have you tried cleaning your browser cache from within the browser first and then re-opening the browser and trying again?

Link to comment
Share on other sites

Thanks! It worked.
Chrome is my default browser, so, when it didn't work in Chrome, I tried Firefox, but was facing the same issue.
Therefore assumed it wasn't a browser thing, but maybe a wrong link or something.
I cleared the cache in Chrome and it worked.

Thanks a lot!


Link to comment
Share on other sites

I can't download the portable version either. Using  https://www.ccleaner.com/ccleaner/download/portable the link goes to the download page but, instead of starting the download, the page just goes blank. Using   https://www.ccleaner.com/ccleaner/builds only shows the standard installer, no portable version.

Cleared caches and tried Chrome, Firefox and Edge. No success.


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use.