Jump to content
CCleaner Community Forums

Avast Hidden Install [solved October 2019]


Recommended Posts

Still does the ninja install, ffs.

2017 laptop crawled with avast on it so it got uninstalled back when id purposefully installed it. Found malwarebytes actually did what it was supposed to unlike avast, ie not ignoring malware running while freaking out over every zip and exe. Honestly running adblockers is more reliable than avast, and windows defender is leaps and bounds beyond yalls boomerbait.

Figured id run crapcleaner, remembered chrome in the installer so went thru making sure nothing extra, avast wasnt even mentioned. Considering yalls lumbering ui, maybe it was what i assumed was TOS, where the middle was an artifact copy of the desktop and accept and decline buttons on either side. Aka boomerbait, "i hafta accept everything when installing" bs. If your product is good wont hafta bundle it, much less make an opt out vs opt in (either is still a slap in the face for those of us on metered conx)

Running cc when avast icon pops up, have to wait half an hour of uncancellable install still goin, then uninstall it, and the worthless junk installer it uses never frees windows so had to restart just to uninstall cc too.

Seriously. Eat me w the "oh it says it right thar" bs. Just downloaded it off your site minutes before. Shouldnt need to load a site in the installer to know what im accepting, esp since it looks like everyone elses crappy TOS section. Thanks for making me have to go wipe yalls feces out the registry.

Heck speccy still never figured out amd cpu temps, go figure

Bye

8iuj73in8ga51.jpg

Link to post
Share on other sites
  • Moderators
Quote

the middle was an artifact copy of the desktop and accept and decline buttons on either side


There is a very infrequent issue where the offer image does not load and only the 'Decline' and 'Accept' buttons are showing.
It is being worked on to try and find what may be causing it.

There may or may not also be a circle of dots and some grey text showing.

It happens so infrequently that it has been difficult to even capture a screenshot of it happening, but that has now been managed -

If this should happen to you then simply click on the 'Decline' button and nothing other than CCleaner itself will be installed.

image.png

 

The developers are looking into what may be causing it, but as it happens very infrequently it's proving hard to pin down any cause.

Link to post
Share on other sites
  • Dave CCleaner changed the title to Avast Hidden Install [solved October 2019]
  • Admin
On 13/07/2020 at 12:55, nukecad said:

It happens so infrequently that it has been difficult to even capture a screenshot of it happening

Indeed, out of over 80M successful installations with the improved offer layout since March @nukecad seems to be the only person to have actually captured this in the wild - and we've been unable to replicate it.  So if anyone else get a screen that looks like the one that he posted above - we'd love to hear from you.

For everyone else, if you get an AV offer in the installer (not the "if" - offers are not always made at all) it should be rather hard to miss:

image.png

 

 

Link to post
Share on other sites
  • 3 weeks later...
  • Admin
20 hours ago, wynford said:

This is why Windows Defender has blocked CCleaner as PUA

The free installs of CCleaner, Recuva, Speccy and Defraggler were flagged as containing PUA (not being PUA) for the presence of the Chrome offer ... which has been in there since 2010 ...

Again, none of the offers are silent installs.  And the risk of the AV offers slipping through unnoticed due to client connection failures was eliminated in October of last year.  Since then only @nukecad seems to have found a way to break it - and even he hasn't been able to replicate how he did it.

Link to post
Share on other sites
  • Moderators
1 hour ago, Dave CCleaner said:

  Since then only @nukecad seems to have found a way to break it - and even he hasn't been able to replicate how he did it.


I resent that somewhat.

I didn't 'find a way to break it' - it was broken at the server end.
I can't replicate it because I haven't tried to, - no point trying because it was broken at the server end.

Link to post
Share on other sites
  • Admin
2 minutes ago, nukecad said:

I resent that somewhat.

Was meant as a reflection of your debugging diligence, sir 🙂

3 minutes ago, nukecad said:

I didn't 'find a way to break it' - it was broken at the server end.

Indeed, that remains our working hypothesis - one time brief server glitch.

Link to post
Share on other sites
  • Moderators
3 minutes ago, Dave CCleaner said:

Was meant as a reflection of your debugging diligence, sir 🙂


Accepted,

Have you had time to look at the testing/debugging issues that I raised yesterday?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...