Jump to content
CCleaner Community Forums

MP4 files recovered but won't play

Recommended Posts

Recuva had a green symbol indicating that my four MP4 files were recoverable. Got a message saying successfully recovered.

Tried to play them. It says:

"This file isn't playable. That might be because the file type is unsupported, the file extension is incorrect, or the file is corrupt."

I added an MP4 extension, the same result.

Recuva has worked for other types of files, but every time I have ever tried to recover video files, both MP4 and WMV, I get a message saying they were successfully recovered, but cannot play them. I figure there must be something I'm doing wrong, or maybe an extra step I need to take?

This is so frustrating. Thanks for any help.



Link to post
Share on other sites
  • Moderators

There are difficulties in recovering very large files, very fragmented files, very old - and very new - files, and files on FAT32 devices. These are to do with the way the file system handles file deletion, not to do with Recuva (or any recovery software).

Recuva will recover (i.e. copy) whatever is in the clusters pointed to by the addresses held in the file tables. In Recuva advanced mode have a look at the file header. Does it look valid (you can find  out what a valid mp4/wmv file header looks like with Google)?

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...