Jump to content
CCleaner Community Forums

External Drive


lesliegug
 Share

Recommended Posts

Hi, lesliegug.

I am not a regular user of Recuva but the wizard (upon launching Recuva for the very first time -- thus, maybe requiring you to uninstall then reinstall it) allows the user to SELECT the drive to be browsed for files to recover. I have not used the feature for an entire drive and hence I do not know how well it will/can do so. The software was able recover files that were encrypted on a flashdrive/thumbdrive but, unhappily, I had forgotten this fact about them and could not view the contents of the files. This may serve as a warning that old files may be recovered but you will need to have password or other keys in order to reutilize them.

I hope this helps.

JackAnt 

2017-12-29--10-04-57-960.jpg

Link to comment
Share on other sites

If the 'drive' is not recognized as a drive, Recuva will not see it. You have to use the 'advanced ,,,' mode available to the right end of the bar near the top. I think that will cost you about $18. It will then show you the drives and ask essentially the same questions as the wizard shows as posted by JackAnt. If you have no idea about the workings at that point, you might need some help. I would pick the partition at the beginning of the drive and tell the program to recover everything (ALL). I forget the exact terminology, but it is similar to Recuva Wizard shown by JackAnt in a previous post. 

Update: The information I gave was erroneous about finding deep scan on the tool bar. I selected options and in advanced tab selected deep scan only. Then I selected the drive from the disks that were listed by clicking on the wedge next to the c:. A list came up that listed hard drives and one of them I was able to determine from its size or something like that determined from the list - it showed a drive without a letter hard drive 3 I think it was - now that drive is showing up as F: so they changed something. I did try to make an image of the drive I believe, but it didn't change anything that I noticed before I went ahead with the hard drive 3. Now the drive is drive F: 

So I don't know how to get into a dead disk anymore. I was successful by using deep scan and selecting the drive based on the hard drive name. But somehow the software has now made the drive unreadable - it says that the drive has no file system when yesterday it was able to read the file system. The only difference between then and now is the operation on it using Recuva Pro. I paid $18 (not much) for the privilege of waiting 36 hours for it to tell me that it had scanned all of the disks on my system and was able to recover everything on the C drive but nothing on the F: drive which it could now no longer read.

There is no warning that they actually rewrite the drive and it did indicate that it could not make an image of the drive which I tried first. I then selected the hard disk 3 which was the 3T drive with unallocated space and told it to deep scan which they indicated was a sector scan as I understood it. And as I said when it finished a day and a half later, it showed many files from the c: drive, I didn't see any from the F: drive. So I told it to recover the files (selected all) onto another 3 T external drive which was loaded as G: selected a location on the drive (path) and told it to add a new folder - it indicated the 'New Folder' and hung. After a few minutes, I said to cancel the operation. It waited for about 2 minutes and dumped the whole thing - stopped the program and lost all of the information. Upon bringing it back up, I see that I now had 9 drives on the system so I shut off most of them - including the G drive and a couple of others.

All I can figure is that they have a piss-poor gui and very little attempt to fix the problems with the program. I think that I will try to get my money back on this piece of junk.

I see by one of the comments under suggested improvements that someone said they should add such a warning about rewriting the drive. Good grief - couldn't make it work without rewriting things? It would seem it would be better to map the drive onto another virtual disk and create a virtual copy to work on by reading the sectors. Then they could try various methods on copies of the image to try to reconstruct the true image based on the info they found. Then by involving the user who might actually know something about the contents, ask him to verify things that he knew were right, from that they could get confidence as to their progress. As it is, it is a big waste of time. I also noticed that the drive I am using is a UEFI drive, I'll check, but I'll bet it now has an MBR file system and has been wiped as a result. Just a guess.

 

Link to comment
Share on other sites

  • Moderators
You can switch from Wizard to Advanced Mode any time, there is no cost implication. It will not show you any more drives than the Wizard does. Why would you ‘pick the partition at the beginning of the drive’? The O/P was referring to an external drive with no indication of whether there were multiple partitions.
 
You seem to think that as one of your drives hadn’t a drive letter then later had one that Recuva caused this. Recuva does not go around allocating drive letters. This behaviour can happen with a failing disk. You have already run EaseUS against this disk and that caused the drive to ‘no longer be recognized’.
 
Recuva does not rewrite any part of any drive it is recovering from. It’s unclear (to me) whether you chose to make a disk image, which the pro version can do, and if you did where you created it. You seem surprised that you had 9 drives on your system. To be honest I’m not quite sure what you were doing.
Link to comment
Share on other sites

1) That's right the cost implication was for Easeus - my bad. Update - no I wasn't wrong on this - it costs $18 to get the deep scan feature in the wizard of Recuva. Easeus charges $70 after claiming to offer 1 - 2 T of recovery for free, but then allow only 500 M when you use it.

2) Yes it might show more drives because it shows unlettered ones (ok, both modes might show them, but the wizard won't do squat with them) No, you don't have to go into advance mode, but it is more clear what it is doing.

3) I assumed that he might run into what I was running into - the drive did not have a letter and it showed partitions. It was not clear what drive was which. So by eliminating the ones that I knew were c: drive partitions (disk 0 some places or hard drive 0 or hard drive 1, etc), I aimed it at the lowest numbered hard drive beyond the C: drive's partitions. I don't recall exactly what I saw, but I know it was not the same as other programs like Disk Partition and Easeus used. The point is that he might see more than one partition on the hard drive and he could logically start at the first one because if it is a UEFI drive, it will have a small partition at the front end - he might have a  chance if it can be recovered. In fact my single partition has a hidden partition that holds the info for starting things up, so he could start by trying to recover that partition - I don't know.

4) No one said that Recuva allocated a drive letter. You know that the drive was not being recognized because it did not have a drive letter, yet after running under Recuva, the system found it and gave it a drive letter. My suspicion now is that Recuva does not support EFI. Or at least it thought that this drive was not EFI when it was. The drive that I am referring to is my failing drive. If you read in the suggested upgrades, the man writes that he suggests that you indicate something about things might get changed - it is clear to me that something changed mine, but it might have been my fault - if it was I don't know what I should have done differently. The fact remains that the first partition on this drive was somehow clobbered - at the same time as the c: drive I would guess. Both use EFI and both were acting like they were rewritten. However, different programs could read the drives' partitions and sizes etc. so all was not lost - not yet anyway. 

I did try to make a disk image, but it wouldn't do it - I think it said no file system, not sure. So I went ahead and attempted to recover the drive because I expected with deep scan to get sector by sector. It worked for 36 hours on the drive, went slowly through all 3 phases and then I was going to insert another drive to write on. I normally have a c: drive, d: drive (cd), e: drive (sd card), f: drive was the bad drive hooked to usb and an X drive for backup other stuff that I do. Before I could do that I realized that the drive was now F: and the software claimed there were 9 drives. Now you will count that out and see that there are nowhere near 9 drives, but when I was ready to hook up the g: drive to use for the recovery of the many files that it claimed to have found, it said there were 9. So how did it  get to 9? Obviously it is counting the drives in a strange way (well, not so strange) there are hidden partitions that it was calling drives - it said the c: drive or hard disk 1 or disk 1 had 5 drives on it. It has an MBR setup with a small boot partition, the main c: partition, some special Dell partition and a recovery partition at least 4, so there is one extra. The e drive has 1, the dead drive (now F:) had at least 1, should have been 2 or 3 and the x: drive has 3 I believe. I have no idea how it came up with 9, but that is what it said. Perhaps it did not count the unnamed partitions, but however you count them 9 isn't right. c, e, f, x should be only 4. I am quite certain that the d: drive was not included. That 9 count has a different terminology on it - so 9 drives is probably not accurate representation of what it meant. I took it to mean that it could scan any one of those 9 entities and I referred to them as drives - a very loosely used term anyway.

Be that as it may, when I noticed that things were not going to work as I had hoped (the drive was now  seen as F: and the entire system had been tested rather than just the F: (I had removed the e:, and the x: drives before I started the scan, but put them back on to do some other work after it had finished and was sitting there saying it was done) and then noticed that the list of files included c: drive files and there were 9 drives), so I disconnected the other drives that I could - the x, the e:, leaving only the c: and the now f: and plugged in a 3 T usb 3 drive to attempt to transfer the files to it. The program allowed me to select the drive g: and when I told it to transfer all the files onto it, it sat there for several hours looking at me - so I told it to cancel. It just sat there - so I disconnected the new drive (unplugged the usb) that I had canceled the operation on (it had the no data on it that wasn't already there). The F: drive was direct connect on an esata port. The G: drive was on a usb 3 hub which uses the output of the pcmcia ( forget the new name for that) card to run usb 3.0 and takes power from another usb port to power the whole thing.

I have a Dell Studio 1797 with 1T ssd hybrid drive for c: The system has about 6 Gig of memory and is I5 dual core 2.4 speed - it's pretty fast anyway. So when all of that happened I was a little surprised when the Recuva program closed itself down. No warning, no message - just gone. I have been around these pcs since 1980 (yes, I was a developer) and I have seen a lot of strange things so I recognized what happened was the software being dumped for bad actions. I understand that it provides an ini file capability, but that is probably special set up. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...