Jump to content
CCleaner Community Forums

CCleaner misreads size of Recycle Bin


Recommended Posts

Computer is Dell e6520 laptop, Win 10 Pro (64 bit) build 1703 with all system updates as of yesterday, 16GB memory, other parameters as shown on the attachment, running CCleaner Pro v. 5.35.6210 (64 bit). CCleaner monitoring is on, and the program recently has told me, every day, that it can save 104GB of disk space. I run it, and it reports that it has saved me a MUCH smaller amount of disk space (generally in the range of 10-40MB), which makes perfect sense, since it runs every day, and my C/system drive only has about 115BG of content of all kinds. Please see the attachment, CCleaner main screen after scan, showing 108GB in Recycle Bin. In fact, CCleaner ran and cleaned about 10MB just before I had it scan again, at which point it "found" 108GB in the Recycle Bin. Just not true, but somehow CCleaner is misreading the size of my Recycle Bin. Any thoughts on why this might be happening? 

 

post-80261-0-51181000-1507838003_thumb.jpg

Link to post
Share on other sites
  • 2 weeks later...

Thanks for the tip, hazelnut. I am adding this reply in case it might benefit another user in the future. Examining my machine, I found 3 recycle bins: one on C and one on each of 2 external USB drives, one of which is configured RAID-1. The recycle bin on the RAID drive showed "empty" when mousing over the icon, but in Drive Properties, it showed 1 folder, 3 files, 103GB of content. Since my original CCleaner issue involved "over-reporting" of 104GB that could be saved, I guessed that the RAID recycle bin was the culprit. I reviewed your post re: use of the "RD /S /Q C:\$Recycle.bin" command and ran it successfully on C drive and one external drive, but the RAID drive returned a notification that the RD command could not be executed, because it was "not allowed by storage policies. Contact your administrator." Administrator is me, and I could not figure out a way around storage policy issue. Actually, I admit I never really understood it, so I looked for a workaround. I was preparing to move about 600GB of content off the RAID drive to other storage, so I could format the drive and cure the problem, I hoped. Before doing that, however, I decided to try connecting the RAID drive to another laptop to try the RD command from a machine that might have different storage policies. Did so, and it worked!! Issue resolved.

 

As to CCleaner, this was informative, because I did not previously realize that the program monitors recycle bins on all of my attached storage drives. A nice additional benefit. 

 

Thanks again, 

 

Another happy customer!
 

Link to post
Share on other sites

Hazelnut, 

 

Have more insight. I run Macrium Reflect as my primary backup program. They recently added an "Image Guardian" feature, which is intended to protect stored images from virus-driven changes. As part of installing the new MS Windows 10 Fall Creators Update, I ran an image of my HDD just prior to installing the update. I wanted to copy that file out of the Macrium Reflect image target file (to prevent its deletion as part of the usual "cleanup" function for older images). I was prevented from doing that with the same "storage policy" warning I got previously while trying to clean the recycle bin on the storage drive. Within Macrium Reflect, I disabled Image Guardian, and I was then able to copy the image to another location beyond the reach of the normal Macrium Reflect cleanup routines. So, my problem was related more to Macrium Reflect than CCleaner. Posting this info for the community, just in case, and as a closeout for the topic. Cheers!  MBalog24126

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...