Jump to content
CCleaner Community Forums

Recuva can't recover more than 80MB of any file


Recommended Posts

Hi

 

I just tried to use recuva 1.53.1087 on a USB hard drive (WD 2.5") and it found all the missing

files ok and recovered some of them fine as long as they were smaller than 80MB

All green lighted files over 80MB were truncated exacly at that size (81920 bytes)

(Recuva lists them all at that size)

 

They were all marked as recoverable (excelent) and I recovered to a different physical

hard drive (the system drive in fact).

 

Is this a bug or a limitation?

 

thanks

 

 

 

Link to post
Share on other sites

Hello?

 

Can anyone help.

 

I have a number of files on a number of diks I can't recover.

The program cannot see any more than 80MB of any file

All of them are marked as excelent and recoverable

 

using win7-64 SP1

 

Getting a bit urgent now.

 

 

Link to post
Share on other sites

I have now tried to recover files on 2 different machines off several external USB hard drives.

 

Recuva is not fit for use on such drives and cannot recover files larger than 80MB on them.

 

If anyone can suggest a revovery program that works I'd appreciate it.

 

cheers.

Link to post
Share on other sites
  • Moderators

As this is an official forum for recuva, members are asked not to mention competition software.

 

ADVICE FOR USING CCleaner'S REGISTRY INTEGRITY SECTION

DON'T JUST CLEAN EVERYTHING THAT'S CHECKED OFF.

Do your Registry Cleaning in small bits (at the very least Check-mark by Check-mark)

ALWAYS BACKUP THE ENTRY, YOU NEVER KNOW WHAT YOU'LL BREAK IF YOU DON'T.

CCLEANER, RECUVA, DEFRAGGLER AND SPECCY DOCUMENTATION CAN BE FOUND AT  https://support.piriform.com/hc/en-us and  https://www.ccleaner.com/docs

Pro users file a PRIORITY SUPPORT request at https://support.piriform.com/hc/en-us/requests/new

link to WINAPP2.INI explanation

Link to post
Share on other sites
  • Moderators

Quite clearly Recuva can, and does, recover files larger than 80 mb. There is no limitation on the recovery size with the free version of Recuva. There is some other issue if you are only recovering 80mb. Assuming you have valid Piriform software, then what is the file system on the USB drive, and what are the cluster numbers on one or two of the files before recovery?

 

Recuva will recover from the start of the file to the end of the file's clusters or any other EOF marker.

Link to post
Share on other sites

Clearly it does not here.

 

There is nothing special here its just a windows7 system and all drives formatted with NTFS from it.

Recuva was downloaded from the piriformm site not a mirror.

The drives have now been surface scanned and have no errors.

 

Recuva reports all files at 80MB exactly every time and only recovers that much.

They are .TS files and the files play for the 80MB length after recovery.

 

Recuva just isnt recognising past that. The recovery window lists them as 80MB long

prior to recovery. Most are 2GB+ in reality.

 

They are recovered to a different physical drive.

 

The PC has now run memtest86 for 10 full passes with no issues.

Another PC also exhibited the same behaviour.

 

Processors are not overclocked. (Q8300 at 2.4Ghz) 4GB ram Packard bell Inspiron machine.

There is no other issue with the machine

Link to post
Share on other sites

hi, jazz123. 

Is it possible that the files really are just 80MB? 

Were they part of an original larger file or package of files?

Then after something happened to require a recovery software, those 80MB files might have been all that was left. 

 

Btw what did happen to those drives to mess them up?  Knowing might help recover the files. 

 

Just thinking . . .

The CCleaner SLIM version is always released a bit after any new version; when it is it will be HERE :-)

Pssssst: ... It isn't really a cloud. Its a bunch of big, giant servers.

Link to post
Share on other sites
  • Moderators

Perhaps my post wasn't clear. Recuva in a normal scan will read the cluster addresses in the MFT and recover (copy) them to the recovery disk. No more, no less, no matter what the clusters contain. In a deep scan Recuva will copy the first fragment of a file from the start cluster (identified by a file signature) until it hits another file header or an eof indicator. There are no file length limitations.

 

My money is on sentence three in my first post.

Link to post
Share on other sites

I did write a long response for explanation but it seems to have vanished. Maybe I pressed a

key or something

 

 

Long and short - the issue is with external drives only (I only use WD 2.5") and possibly USB

I have recovered the files by installing ntfs-3g on a linux box and using linux tools.

Also Recuva does not seem to recognise .TS files as video. Maybe that has some bearing.

I hope thats helpful.

 

I am changing my email address please remove me from the system

 

thank you.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...