Jump to content
CCleaner Community Forums
Traumatised

CCleaner stuck at 3%

Recommended Posts

I have been using computers since the "Pegasus Autocode" {!) and ccleaner for years, and never had a problem until the last two releases. I am presently running a tower, laptop and Lenovo MIIX 310 notebook, all running win10 and, all with ccleaner. The tower and laptop run ccleaner fine but ccleaner on the Lenovo sticks at 3%. I have uninstalled then reinstalled and the first run was fine but after that it reverts to sticking at 3%. Cancel doesn't work and I end up closing it from the task master. Anyone got any ideas?

Share this post


Link to post
Share on other sites

what area does it say it's cleaning at the 3% stage?

Is it IE or Edge?

have you tried running CC with the PC in Safe Mode?

Share this post


Link to post
Share on other sites

3% is internet explorer history. Haven't tried to run it in safe mode yet. I shall try that later today and let you know. Thanks.

Share this post


Link to post
Share on other sites

and you use IE on all 3 PC's?

if Safe Mode doesn't help, then go into IE and clean its history from its own mechanism: Tools, Internet Options, General tab, in the Browsing history area, click the Delete button, tick appropriate box and hit Delete.

Share this post


Link to post
Share on other sites

Hi guys. Yes, I also got CCleaner cleaning cycle stuck at 3%. Re-booting the PC also did the trick for me. Many thanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...