Jump to content
CCleaner Community Forums
bimmerdriver

Skip User Account Control warning does not work

Recommended Posts

I'm using ccleaner on windows 10. One computer is the latest public version. The other is running the latest insider version. In both cases, the setting to skip the UAC warning is not working. This started quite a long time ago. I've tried deinstalling ccleaner and even going through the registry to delete any leftover keys that the ccleaner uninstaller leaves behind. (It's somewhat ironic and disappointing that ccleaner doesn't clean up after itself.) After uninstalling and reinstalling ccleaner, the problem is still there. It's annoying to receive this warning and it's even more annoying that other users of the computer are complaining to me about it.

 

I searched for this problem in this forum and noted a few posts about it, but I did not see any solutions. Is there a proven way to get around this problem? Is it going to be fixed?

Share this post


Link to post
Share on other sites

Thank you for your reply.

 

I tried that previously and tried it again just now. It's strange. After I made the change, I logged out and back in. There was no warning. I went to another user account and made the same change, then logged out and back in. The warning still happened. I returned to the first account where I made the change and the warning still happened, so this doesn't seem to be a reliable fix.

 

Also, changing the task from windows 10 to windows 7 does not prevent the task from sending $(Arg0), at least according to the actions tab. It sends the argument whether the task is configured for windows 10 or windows 7. If the behaviour has changed in windows 10, ccleaner should be modified to support windows 10 as it currently operates. I like ccleaner, but this warning is really annoying.

Share this post


Link to post
Share on other sites

I just tried another test. I edited the task to remove $(Arg0). (It was set to windows 10.) Then I logged out and back in again. Now, ccleaner automatically starts in the normal mode, as if you manually opened it and there was no UAC warning. This seems to be a bug in ccleaner.

Share this post


Link to post
Share on other sites

Not a piriform issue. I have to change the task to be windows 7 for all of my ARG0 tasks (at least three) ARG0 is depreciated in windows 10 tasks.

Share this post


Link to post
Share on other sites

Not a piriform issue. I have to change the task to be windows 7 for all of my ARG0 tasks (at least three) ARG0 is depreciated in windows 10 tasks.

Exactly what did you do, because when I changed the task to windows 7, it made no difference, at least not consistently. If the problem is that $(Arg0) has been deprecated, it's not surprising that windows 7 mode doesn't work either, because it also uses $(Arg0). If I removed $(Arg0), ccleaner didn't start up in the background but at least it did not generate a UAC error. Clearly it's possible to start a task in the background without a UAC error.

 

With regards to whether or not this is a piriform issue, with all due respect, if Windows 10 no longer supports $(Arg0), then the approach being taken by piriform is broken. It's a bug. No other tasks have this problem. Unless Piriform has inside knowledge that Microsoft is going to restore $(Arg0) the way it was, for ccleaner to set up a task in "windows 10" mode passing $(Arg0) is broken and will never work and therefore piriform's "windows 10" mode needs to be fixed. Dropbox and google pass arguments to tasks, just not using $(Arg0). No other tasks have this problem. How is this NOT piriform's problem?

Share this post


Link to post
Share on other sites

You state you uninstalled, and reinstalled CCleaner. However did you reboot after uninstalling? Sometimes that can heal an issue.

 

As for it being a bug in CCleaner I don't know, it could be something to do with your system. I personally haven't had that issue in Win10.

Share this post


Link to post
Share on other sites

You state you uninstalled, and reinstalled CCleaner. However did you reboot after uninstalling? Sometimes that can heal an issue.

 

As for it being a bug in CCleaner I don't know, it could be something to do with your system. I personally haven't had that issue in Win10.

 

I did reboot after uninstalling, then reinstalled. It didn't fix the problem, so I went to the extra step of uninstalling, searching the registry and removing all ccleaner keys, then rebooting, then reinstalling. It made no difference. I have two computers running windows 10 and both have this problem, as of today, both are running the latest "creators" update.

 

I don't see how it's not a bug. ccleaner is trying to use $(Arg0) for windows 10 and windows 10 no longer supports it. piriform needs to make a new method of passing arguments not using $(Arg0) like every other app.

Share this post


Link to post
Share on other sites

Updating this thread. My computer is on the latest insider release, post creators update, build 16184 and ccleaner skip uac is still not working. It's probably reasonable to think that if Microsoft has not restored the $(Arg0) function by now, they have no intention of doing so. In that case, it's time for Piriform to fix this annoying bug.

Share this post


Link to post
Share on other sites
Updating this thread. My computer is on the latest insider release, post creators update, build 16184 and ccleaner skip uac is still not working. It's probably reasonable to think that if Microsoft has not restored the $(Arg0) function by now, they have no intention of doing so. In that case, it's time for Piriform to fix this annoying bug.

how do you propose they fix this. If the only way to skip uac is arg0. Again my windows 10 works, on multiple softwares, the way I describe in the sticky

Share this post


Link to post
Share on other sites

how do you propose they fix this. If the only way to skip uac is arg0. Again my windows 10 works, on multiple softwares, the way I describe in the sticky

First, I'm not the developer. However, I used to be a software developer. If Piriform wants to develop software for windows 10, they need to use available mechanisms. If arg0 is no longer supported, unless microsoft changes their mind, piriform continuing to use it won't make it work. Ccleaner isn't going to wear down windows 10. Doing the same thing over and over expecting a different result is the definition of insanity. Like it or not, Microsoft sets the rules. Not supporting arg0 is not a windows 10 bug. It's a feature. The fact that ccleaner is trying to use a feature that's no longer supported makes this a ccleaner bug.

 

Second, I'm not the only person for which the supposed fix doesn't work. As you sure you haven't simply disabled UAC for all applications so it appears to work? I have several different computers running windows 10. It happens on all of them.

 

Third, it makes no sense that using the windows 7 format should work, because it also uses arg0. If windows 10 doesn't support arg0, there is no reason for the windows 7 format to work.

 

Fourth, as I said, other applications start up upon login and don't generate any UAC warning. None of them use arg0. The tasks for other applications pass parameters in other formats, such as /c, /ua /installsource scheduler and sync. Pifiform needs to use a supported mechanism to pass the parameter, like other applications.

 

Fifth, if I remove the arg0 parameter from the windows 10 task for ccleaner, it starts without generating a uac warning. It just doesn't start in the right mode. Presumably, if the parameter is passed using a supported mechanism, ccleaner will start in the correct mode without generating a UAC warning.

Share this post


Link to post
Share on other sites

I have the creators update, as do friends computers that I have looked at and none of us have this skip UAC problem with Ccleaner.

 

I have had a problem with it in the past but this was well before the creators update.

 

In concentrating on arg0 you may be missing the real problem.

 

Have you tried any other troubleshooting, other than arg0?

 

I'll see if I can find my old posts from when I was having problems with skip UAC.

 

Just to ask though- is your Win10 Home, Pro, or Enterprise?

Obviously they do have differences so for troubleshooting you should say which one you are using.

 

EDIT

Looking back it was in 2015 that I was having problems with SKIPUAC, and with delayed starting of CCleaner.

It may have been a different problem at the time but-

The solution found back then was to make the CCleaner folder an exception in your anti-virus.

(Yes sounds a bit odd, but it worked which is what matters).

Share this post


Link to post
Share on other sites

This has not always been a problem. As far as I can remember, it started with the anniversary update. I have 6 windows 10 computers, running various versions of windows 10 and it effects all users on all of the computers.

 

The association of this issue with $arg0 came from this website. I'm not in a position to prove or disprove it. However, as I pointed out, if $arg0 really is the problem, changing the task type to windows 7 should not fix the problem, which is why I question that it does fix the problem.

 

There is nothing unique or special about my computers. I've tried completely deinstalling ccleaner including manually deleting any associated keys from the registry and the problem will not stay away.

 

As I said, if $arg0 has gone away, piriform needs to use another method for passing arguments at login. When I removed $arg0 from the task, there was no uac error, so perhaps the uac error is what windows 10 generates if it's passed arguments using $arg0. Maybe it's an incorrectly coded error notification from windows. Who knows?

Share this post


Link to post
Share on other sites

Since Vista introduced UAC, it's been a PITA and one of the first Windows customisations I do is to turn it off.

Just out of curiosity, any reason why you don't turn off UAC to avoid this whole situation.

Share this post


Link to post
Share on other sites

Since Vista introduced UAC, it's been a PITA and one of the first Windows customisations I do is to turn it off.

Just out of curiosity, any reason why you don't turn off UAC to avoid this whole situation.

I don't disagree that UAC hasn't been one of Microsoft's finer moments, but it serves a purpose and disabling it completely defeats that purpose. Users should not have to disable a security feature because of a bug in Piriform's software. Piriform, if you're listening, fix the d*amn bug!

Share this post


Link to post
Share on other sites

This is a strange one.  I have the $(Arg0) in my task and it's set as a windows 10 task, and yet, it works as intended.

 

Perhaps the $(Arg0) isn't set up correctly in the task ?.  This is a total long shot guess, but just check it in task scheduler, and by check I mean go to the task right click & select properties, then go to the actions tab, it will have the line it's executing, but don't trust that (there are two ways to get the same line appearing exactly the same in this window).  Select the line and click on edit, you will get a box, with details in it.  The $(Arg0) should be in the "additional arguments (optional)" box, not the top "program/script" box.  It should not have quotes around it, and should appear the same as I put it above.  (Perhaps the capitalization is wrong and matters, I don't think it should but maybe it does here ?), but if it's in the wrong box it will make a difference.

 

Anyway it's a long shot but maybe ? - reading your comments above, just so you know, $(Arg0) isn't an argument itself, it is meant to be a code which will pass arguments sent to it through to the command line, if and only if they are provided in the first place, if there are none then it should equate to "" (nothing or an empty string).  It's also unclear if windows 10 is meant to support this or not, reading this thread people are saying it doesn't work for them and changing the task to a windows 7 task fixes it (by causing the task to be treated in a kind of windows 7 compatibility mode) - so they assume windows 10 doesn't support this any more - I could be wrong here, there may be evidence that Microsoft have said this isn't supported anymore, but unless there is such evidence, and others who don't have this problem exist (like me) I would tend to think this is a bug in windows, and hence I can't really blame Piriform for not fixing something that they possibly can't reproduce.

Share this post


Link to post
Share on other sites

As of Creator Update for Windows I'm able to reset tasks as windows 10. Arg0 seems to work again

Share this post


Link to post
Share on other sites

Among the computers I'm running windows 10 and ccleaner on, some are updated post anniversary / pre creators, one is post creators and one is an insider fast ring (post creators). ccleaner has a uac warning on all of them. I've tried deinstalling ccleaner and even searching through the registry to remove any left-over keys after deinstalling it, then reinstalling it. It makes no difference. Every time I login, I get the warning.

 

I've attached the relevant screen captures.

post-32189-0-40701500-1494475061_thumb.png

post-32189-0-55822500-1494475070_thumb.png

post-32189-0-09385800-1494475080_thumb.png

Share this post


Link to post
Share on other sites

I deinstalled ccleaner and reinstalled it, enabled the setting to skip the uac warning, then logged out and back. There was no warning. I hope it stays working. If so, for some reason, it seems necessary to deinstall and reinstall the software for the setting to skip the uac warning to work.

Share this post


Link to post
Share on other sites

I can confirm that skip uac stayed working through a major insider update since I did the deinstall and reinstall. It's good to have this issue gone.

Share this post


Link to post
Share on other sites

Forgive bringing this thread back to life.

This issue has reared its head again on one of my laptops again.  (was a problem on one of the others a year or more ago, but I've forgotten what the fix was).

 

Not having a clue what y'all mean, or what needs to be done about ARG(0), even though I do know what that is, what is the suggested fix for machines that were recently broke by the recent Creator Update?

 

Every since that update came in the "Skip UAC" setting changes nothing. This machine has two users and both get the "allow" prompt with each login after a reboot.

Install is set for All Users, and Skip Account Control is checked.

I have reset the settings to the default in both accounts.

Is the only real fix to uninstall and reinstall?

Share this post


Link to post
Share on other sites

For the record, uninstalling CCleaner Pro Version 530  rebooting, and reinstalling it, does NOT fix this issue on Win10 Creator....and at least some machines....like mine.

Perhaps a new thread needs to be started since this one is old.

Share this post


Link to post
Share on other sites

Assuming you've tried the solution in the second post of this thread (FYI, the linked thread has also been updated since that post).  A couple of things to confirm are that  the required task exists in task scheduler and also that it isn't corrupted.  The first part is easy, (it's either there or it isn't), the second part can be tested by checking to see if you can change the task & then apply the change. Make a simple change you can easily change back should it work, but if it's corrupted it will either throw an error when it attempts to save the change or the change won't actually be saved, when you go back into it to change it back.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...